aboutsummaryrefslogtreecommitdiff
path: root/science/py-esda/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-01-03 19:57:58 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-01-03 19:57:58 +0000
commit098922819481e65166a763066f2997d632ab3c70 (patch)
treeded07fbad0e5d4f7c8c2211a54b4b9e47d056db6 /science/py-esda/Makefile
parentbf847c47aa22bb38029b712b4f65e02e55157414 (diff)
downloadports-098922819481e65166a763066f2997d632ab3c70.tar.gz
ports-098922819481e65166a763066f2997d632ab3c70.zip
Add py-esda 2.3.1
ESDA: Exploratory Spatial Data Analysis ESDA is an open-source Python library for the exploratory analysis of spatial data. A subpackage of PySAL (Python Spatial Analysis Library), it is under active development and includes methods for global and local spatial autocorrelation analysis. WWW: https://pysal.org/esda/ WWW: https://github.com/pysal/esda
Notes
Notes: svn path=/head/; revision=560051
Diffstat (limited to 'science/py-esda/Makefile')
-rw-r--r--science/py-esda/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/science/py-esda/Makefile b/science/py-esda/Makefile
new file mode 100644
index 000000000000..cc4c1d6cce2d
--- /dev/null
+++ b/science/py-esda/Makefile
@@ -0,0 +1,26 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= esda
+PORTVERSION= 2.3.1
+CATEGORIES= science python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Exploratory Spatial Data Analysis
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}libpysal>=0:science/py-libpysal@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pandas>=0,1:math/py-pandas@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scikit-learn>=0:science/py-scikit-learn@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=0.11:science/py-scipy@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>