aboutsummaryrefslogtreecommitdiff
path: root/science/py-geometric
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-09-13 19:55:43 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-09-13 19:55:43 +0000
commita761803b5abf5cce2434006fb380cfc5b035073f (patch)
tree896a15a822df5cdc4444feb82a61dae584b8e001 /science/py-geometric
parent29c954ead6d0808259223d2ec6b2a683c324683a (diff)
downloadports-a761803b5abf5cce2434006fb380cfc5b035073f.tar.gz
ports-a761803b5abf5cce2434006fb380cfc5b035073f.zip
New port: science/py-geometric: Geometry optimization for quantum chemistry
Notes
Notes: svn path=/head/; revision=548571
Diffstat (limited to 'science/py-geometric')
-rw-r--r--science/py-geometric/Makefile23
-rw-r--r--science/py-geometric/distinfo3
-rw-r--r--science/py-geometric/pkg-descr9
3 files changed, 35 insertions, 0 deletions
diff --git a/science/py-geometric/Makefile b/science/py-geometric/Makefile
new file mode 100644
index 000000000000..52ddea5dc2c9
--- /dev/null
+++ b/science/py-geometric/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= geometric
+DISTVERSION= 0.9.7.2
+CATEGORIES= science python # chemistry
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Geometry optimization for quantum chemistry
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}networkx>0:math/py-networkx@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils concurrent autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/science/py-geometric/distinfo b/science/py-geometric/distinfo
new file mode 100644
index 000000000000..dd5497438db6
--- /dev/null
+++ b/science/py-geometric/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1600026514
+SHA256 (geometric-0.9.7.2.tar.gz) = 6f69c8c31a188730e2b0f297aa17c66b2518b32c270bda29b6d62cbbffee3bdd
+SIZE (geometric-0.9.7.2.tar.gz) = 183455
diff --git a/science/py-geometric/pkg-descr b/science/py-geometric/pkg-descr
new file mode 100644
index 000000000000..028fdd6ac8af
--- /dev/null
+++ b/science/py-geometric/pkg-descr
@@ -0,0 +1,9 @@
+This is a geometry optimization code for molecular structures. The code works
+by calling external software for the energy and gradient through wrapper
+functions. Q-Chem, TeraChem, Psi4, Molpro, and Gaussian 09/16 are supported
+quantum chemistry codes through the command line interface. The PySCF and
+QCArchive packages also provide interfaces to geomeTRIC for optimization.
+MM optimizations using OpenMM and Gromacs are also supported through the
+command line interface.
+
+WWW: https://github.com/leeping/geomeTRIC