aboutsummaryrefslogtreecommitdiff
path: root/science/py-molmod
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-09-14 03:10:59 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-09-14 03:10:59 +0000
commit7914b6d861c5e9096328179d752d90b7b388ce2c (patch)
tree7e402c159d0199596d45899c2b782e77f2bcd276 /science/py-molmod
parentdd1f4ca30520715c061bd176a175f425700fd742 (diff)
downloadports-7914b6d861c5e9096328179d752d90b7b388ce2c.tar.gz
ports-7914b6d861c5e9096328179d752d90b7b388ce2c.zip
New port: science/py-molmod: Collection of molecular modelling tools for python
Notes
Notes: svn path=/head/; revision=479756
Diffstat (limited to 'science/py-molmod')
-rw-r--r--science/py-molmod/Makefile28
-rw-r--r--science/py-molmod/distinfo3
-rw-r--r--science/py-molmod/pkg-descr4
3 files changed, 35 insertions, 0 deletions
diff --git a/science/py-molmod/Makefile b/science/py-molmod/Makefile
new file mode 100644
index 000000000000..975c1fb89cf5
--- /dev/null
+++ b/science/py-molmod/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= molmod
+DISTVERSION= 1.4.4
+CATEGORIES= science python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Collection of molecular modelling tools for python
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+BUILD_DEPENDS= ${PYNUMPY}
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}future>=0:devel/py-future@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>=0:devel/py-nose@${PY_FLAVOR}
+
+USES= python shebangfix
+SHEBANG_GLOB= *.py
+USE_PYTHON= distutils cython cython_run autoplist
+
+do-test: # Tests fail: https://github.com/molmod/molmod/issues/27
+ @cd ${WRKSRC} && \
+ ${SETENV} ${MAKE_ENV} nosetests-${PYTHON_VER} -v molmod
+
+.include <bsd.port.mk>
diff --git a/science/py-molmod/distinfo b/science/py-molmod/distinfo
new file mode 100644
index 000000000000..3a3f259cad29
--- /dev/null
+++ b/science/py-molmod/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1536893478
+SHA256 (molmod-1.4.4.tar.gz) = ca0e461fe42fc8b7e0b481cda33aac247d86b5fb817b5076e20abc90dd577797
+SIZE (molmod-1.4.4.tar.gz) = 1692687
diff --git a/science/py-molmod/pkg-descr b/science/py-molmod/pkg-descr
new file mode 100644
index 000000000000..391394ea753e
--- /dev/null
+++ b/science/py-molmod/pkg-descr
@@ -0,0 +1,4 @@
+MolMod is a collection of molecular modelling tools for python. It is used by
+other software developed at the CMM, including Yaff, TAMkin and Zeobuilder.
+
+WWW: https://github.com/molmod/molmod