aboutsummaryrefslogtreecommitdiff
path: root/science/py-nilearn
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-01-21 03:53:48 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-01-21 03:53:48 +0000
commit79f65a7cc1ed942a7124ef134d0b66c49723a4e4 (patch)
treec946b226f96aaa09344cc9704176df8b56d6c05e /science/py-nilearn
parent84179b2328ccdc6b9d4754ee1d29e4211a026ab3 (diff)
downloadports-79f65a7cc1ed942a7124ef134d0b66c49723a4e4.tar.gz
ports-79f65a7cc1ed942a7124ef134d0b66c49723a4e4.zip
New port: science/py-nilearn: Statistical learning for neuroimaging in Python
Notes
Notes: svn path=/head/; revision=562173
Diffstat (limited to 'science/py-nilearn')
-rw-r--r--science/py-nilearn/Makefile31
-rw-r--r--science/py-nilearn/distinfo3
-rw-r--r--science/py-nilearn/pkg-descr12
3 files changed, 46 insertions, 0 deletions
diff --git a/science/py-nilearn/Makefile b/science/py-nilearn/Makefile
new file mode 100644
index 000000000000..e68ecf08ba37
--- /dev/null
+++ b/science/py-nilearn/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= nilearn
+DISTVERSION= 0.7.0
+CATEGORIES= science python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Statistical learning for neuroimaging in Python
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}joblib>0:devel/py-joblib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>0:math/py-matplotlib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}nibabel>0:science/py-nibabel@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pandas>0:math/py-pandas@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scikit-learn>0:science/py-scikit-learn@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR} \
+ bash:shells/bash
+
+USES= python:3.6+ shebangfix
+USE_PYTHON= distutils autoplist
+
+SHEBANG_FILES= nilearn/datasets/tests/data/list_archive_contents.sh
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/science/py-nilearn/distinfo b/science/py-nilearn/distinfo
new file mode 100644
index 000000000000..da24ae492e72
--- /dev/null
+++ b/science/py-nilearn/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1611199853
+SHA256 (nilearn-0.7.0.tar.gz) = e7c9df82a31319366f02919794e0ec4eacbae1fb24c41c826070c2a3acf117e6
+SIZE (nilearn-0.7.0.tar.gz) = 2900485
diff --git a/science/py-nilearn/pkg-descr b/science/py-nilearn/pkg-descr
new file mode 100644
index 000000000000..66032248bb20
--- /dev/null
+++ b/science/py-nilearn/pkg-descr
@@ -0,0 +1,12 @@
+Nilearn enables approachable and versatile analyses of brain volumes. It
+provides statistical and machine-learning tools, with instructive documentation
+& open community.
+
+It supports general linear model (GLM) based analysis and leverages the
+scikit-learn Python toolbox for multivariate statistics with applications such
+as predictive modelling, classification, decoding, or connectivity analysis.
+
+Nilearn now includes the functionality of Nistats. Here's a guide to replacing
+Nistats imports to work in Nilearn.
+
+WWW: http://nilearn.github.io/