aboutsummaryrefslogtreecommitdiff
path: root/science/py-phono3py
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2020-01-01 11:46:08 +0000
committerRene Ladan <rene@FreeBSD.org>2020-01-01 11:46:08 +0000
commit12f974ad28b37b69ae565644784623a4a49b1d32 (patch)
treee1de30302164fba037edd51962e8f336730aa5ed /science/py-phono3py
parentf2aea6bcb5e33f3312681450946471970022a977 (diff)
downloadports-12f974ad28b37b69ae565644784623a4a49b1d32.tar.gz
ports-12f974ad28b37b69ae565644784623a4a49b1d32.zip
Resurrect ports depending on devel/openmp.
These ports will transition transparantly to openmp from base once FreeBSD 12.0 reaches end-of-life. Reported by: jbeich [1] [2] [1] https://lists.freebsd.org/pipermail/svn-ports-head/2019-May/210482.html [2] https://lists.freebsd.org/pipermail/svn-ports-head/2019-December/229648.html
Notes
Notes: svn path=/head/; revision=521714
Diffstat (limited to 'science/py-phono3py')
-rw-r--r--science/py-phono3py/Makefile33
-rw-r--r--science/py-phono3py/distinfo3
-rw-r--r--science/py-phono3py/pkg-descr9
3 files changed, 45 insertions, 0 deletions
diff --git a/science/py-phono3py/Makefile b/science/py-phono3py/Makefile
new file mode 100644
index 000000000000..9b776a9e42a3
--- /dev/null
+++ b/science/py-phono3py/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= phono3py
+DISTVERSION= 1.13.3.27
+PORTREVISION= 4
+CATEGORIES= science python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Software to calculate phonon-phonon interaction and related properties
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}h5py>0:science/py-h5py@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>0:math/py-matplotlib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}phonopy>=1.13.2:science/py-phonopy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml@${PY_FLAVOR} \
+ ${LOCALBASE}/include/lapacke.h:math/lapacke \
+ openmp>0:devel/openmp
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}h5py>0:science/py-h5py@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>0:math/py-matplotlib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}phonopy>=1.13.2:science/py-phonopy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml@${PY_FLAVOR} \
+ openmp>0:devel/openmp
+
+USES= blaslapack:openblas localbase python
+USE_PYTHON= distutils cython autoplist
+
+.include <bsd.port.mk>
diff --git a/science/py-phono3py/distinfo b/science/py-phono3py/distinfo
new file mode 100644
index 000000000000..af68f5871daf
--- /dev/null
+++ b/science/py-phono3py/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1536901529
+SHA256 (phono3py-1.13.3.27.tar.gz) = f03cec828b135365bd945cd846dd60b181dc0145792cc07f186b99c9c411a8e4
+SIZE (phono3py-1.13.3.27.tar.gz) = 5477899
diff --git a/science/py-phono3py/pkg-descr b/science/py-phono3py/pkg-descr
new file mode 100644
index 000000000000..2e10c7654608
--- /dev/null
+++ b/science/py-phono3py/pkg-descr
@@ -0,0 +1,9 @@
+This software calculates phonon-phonon interaction and related properties using
+the supercell approach. For example, the following physical properties are
+obtained:
+* Lattice thermal conductivity (RTA and direct solution of LBTE)
+* Phonon lifetime/linewidth
+* Imaginary part of self energy
+* Joint density of states (JDOS) and weighted-JDOS
+
+WWW: https://atztogo.github.io/phono3py/