aboutsummaryrefslogtreecommitdiff
path: root/science/py-pyberny
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-10-16 23:33:48 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-10-16 23:56:19 +0000
commitb57cde219d58fc7e96b13f8baa3ffa9860e1c26c (patch)
tree98e60e6a4234949a90821a4f055c427d04de563e /science/py-pyberny
parent506eb0c26e89549705788b9d79df6227e358f96c (diff)
downloadports-b57cde219d58fc7e96b13f8baa3ffa9860e1c26c.tar.gz
ports-b57cde219d58fc7e96b13f8baa3ffa9860e1c26c.zip
science/py-pyberny: New port: Optimizer of molecular geometries with respect to the total energy
Diffstat (limited to 'science/py-pyberny')
-rw-r--r--science/py-pyberny/Makefile24
-rw-r--r--science/py-pyberny/distinfo3
-rw-r--r--science/py-pyberny/pkg-descr12
3 files changed, 39 insertions, 0 deletions
diff --git a/science/py-pyberny/Makefile b/science/py-pyberny/Makefile
new file mode 100644
index 000000000000..c6a33367dd9c
--- /dev/null
+++ b/science/py-pyberny/Makefile
@@ -0,0 +1,24 @@
+PORTNAME= pyberny
+DISTVERSION= 0.6.3
+CATEGORIES= science # chemistry
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Optimizer of molecular geometries with respect to the total energy
+
+LICENSE= MPL20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYNUMPY}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR}
+
+USES= python:3.5+
+USE_PYTHON= distutils concurrent autoplist
+
+NO_ARCH= yes
+
+do-test: install # no tests run, see https://github.com/jhrmnn/pyberny/issues/36
+ @cd ${WRKSRC} && pytest -rs --pyargs berny
+
+.include <bsd.port.mk>
diff --git a/science/py-pyberny/distinfo b/science/py-pyberny/distinfo
new file mode 100644
index 000000000000..8b9b0eb3b031
--- /dev/null
+++ b/science/py-pyberny/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1634426542
+SHA256 (pyberny-0.6.3.tar.gz) = b4bd9d3d2d58261e8f1d91b8204cc563617044d4b9daf6aae8feee31893cb336
+SIZE (pyberny-0.6.3.tar.gz) = 25628
diff --git a/science/py-pyberny/pkg-descr b/science/py-pyberny/pkg-descr
new file mode 100644
index 000000000000..0de3201f0703
--- /dev/null
+++ b/science/py-pyberny/pkg-descr
@@ -0,0 +1,12 @@
+PyBerny is an optimizer of molecular geometries with respect to the total
+energy, using nuclear gradient information.
+
+In each step, it takes energy and Cartesian gradients as an input, and returns
+a new equilibrium structure estimate.
+
+The package implements a single optimization algorithm, which is an amalgam of
+several techniques, comprising the quasi-Newton method, redundant internal
+coordinates, an iterative Hessian approximation, a trust region scheme, and
+linear search. The algorithm is described in more detailed in the documentation.
+
+WWW: https://github.com/jhrmnn/pyberny