aboutsummaryrefslogtreecommitdiff
path: root/science/py-rmsd
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-01-18 02:03:39 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-01-18 02:03:39 +0000
commit6cee334b3665dc1c703b3d3701148e763dfaab21 (patch)
tree9ba4e94b16cc576ee85b2bf552624d702658e7e8 /science/py-rmsd
parent2fa9296baca94e713991e886c0bb12baa3a081a4 (diff)
downloadports-6cee334b3665dc1c703b3d3701148e763dfaab21.tar.gz
ports-6cee334b3665dc1c703b3d3701148e763dfaab21.zip
New port: science/py-rmsd: Calculate root-mean-square deviation (RMSD) between coordinate sets
Notes
Notes: svn path=/head/; revision=490618
Diffstat (limited to 'science/py-rmsd')
-rw-r--r--science/py-rmsd/Makefile21
-rw-r--r--science/py-rmsd/distinfo3
-rw-r--r--science/py-rmsd/pkg-descr8
3 files changed, 32 insertions, 0 deletions
diff --git a/science/py-rmsd/Makefile b/science/py-rmsd/Makefile
new file mode 100644
index 000000000000..887de0be74f0
--- /dev/null
+++ b/science/py-rmsd/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= rmsd
+DISTVERSION= 1.3.2
+CATEGORIES= science graphics
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Calculate root-mean-square deviation (RMSD) between coordinate sets
+
+LICENSE= APACHE20
+xLICENSE_FILE= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist concurrent
+
+.include <bsd.port.mk>
diff --git a/science/py-rmsd/distinfo b/science/py-rmsd/distinfo
new file mode 100644
index 000000000000..2629438a1473
--- /dev/null
+++ b/science/py-rmsd/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1547775353
+SHA256 (rmsd-1.3.2.tar.gz) = 21c7f16a3f90e036663456f52585e83791eb8566cf1111302c1a8c3465328367
+SIZE (rmsd-1.3.2.tar.gz) = 11843
diff --git a/science/py-rmsd/pkg-descr b/science/py-rmsd/pkg-descr
new file mode 100644
index 000000000000..52e409fd4591
--- /dev/null
+++ b/science/py-rmsd/pkg-descr
@@ -0,0 +1,8 @@
+Calculate Root-mean-square deviation (RMSD) of Two Molecules Using Rotation.
+
+The root-mean-square deviation (RMSD) is calculated, using Kabsch
+algorithm (1976) or Quaternion algorithm (1991) for rotation, between two
+Cartesian coordinates in either .xyz or .pdb format, resulting in the minimal
+RMSD.
+
+WWW: https://github.com/charnley/rmsd