aboutsummaryrefslogtreecommitdiff
path: root/science/py-scikit-learn
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2014-02-18 08:30:53 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2014-02-18 08:30:53 +0000
commit7eed5932e02a3986e8538fc46bb59bf8d8e317b9 (patch)
tree78aea9424e35e3dea1520cc0d6904cd5e8e2ffb9 /science/py-scikit-learn
parentfcdd2c9fbd826b52c0daf69a360f422121ba7ff4 (diff)
downloadports-7eed5932e02a3986e8538fc46bb59bf8d8e317b9.tar.gz
ports-7eed5932e02a3986e8538fc46bb59bf8d8e317b9.zip
Allow to choose between cblas and atlas ports.
Submitted by: glebius
Notes
Notes: svn path=/head/; revision=344840
Diffstat (limited to 'science/py-scikit-learn')
-rw-r--r--science/py-scikit-learn/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/science/py-scikit-learn/Makefile b/science/py-scikit-learn/Makefile
index 43fa8cb3bb46..2b36a0ed4022 100644
--- a/science/py-scikit-learn/Makefile
+++ b/science/py-scikit-learn/Makefile
@@ -12,11 +12,20 @@ MAINTAINER= demon@FreeBSD.org
COMMENT= Machine learning algorithms for python
BUILD_DEPENDS= ${PYNUMPY}
-LIB_DEPENDS= libcblas.so:${PORTSDIR}/math/cblas
RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}scipy>0.8.0:${PORTSDIR}/science/py-scipy
USES= fortran
+
+OPTIONS_SINGLE= BLAS
+OPTIONS_SINGLE_BLAS= CBLAS ATLAS
+OPTIONS_DEFAULT= CBLAS
+CBLAS_DESC= Use math/cblas as BLAS library
+ATLAS_DESC= Use math/atlas as BLAS library
+
+CBLAS_LIB_DEPENDS= libcblas.so:${PORTSDIR}/math/cblas
+ATLAS_LIB_DEPENDS= libcblas.so:${PORTSDIR}/math/atlas
+
LATEST_LINK= py-${PORTNAME}
USE_PYTHON= yes