aboutsummaryrefslogtreecommitdiff
path: root/science/scidavis
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2020-05-27 20:10:56 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2020-05-27 20:10:56 +0000
commit02c6c4246920abfd92c5dbe5acf3c8cb41980a55 (patch)
tree8d3c6e1ac8bc1cf91c1ed15b5f9adfdc65d2a6e1 /science/scidavis
parent388d9e9592ab476d252b62b9246ce37ba57a5a2f (diff)
downloadports-02c6c4246920abfd92c5dbe5acf3c8cb41980a55.tar.gz
ports-02c6c4246920abfd92c5dbe5acf3c8cb41980a55.zip
science/scidavis:
- Update to 2.2.0 - Reformat long lines in the description
Notes
Notes: svn path=/head/; revision=536714
Diffstat (limited to 'science/scidavis')
-rw-r--r--science/scidavis/Makefile3
-rw-r--r--science/scidavis/distinfo6
-rw-r--r--science/scidavis/files/patch-libscidavis_python.pri16
-rw-r--r--science/scidavis/files/patch-libscidavis_src_ApplicationWindow.cpp6
-rw-r--r--science/scidavis/pkg-descr7
-rw-r--r--science/scidavis/pkg-plist2
6 files changed, 21 insertions, 19 deletions
diff --git a/science/scidavis/Makefile b/science/scidavis/Makefile
index ab18ad30d493..5585bce485d9 100644
--- a/science/scidavis/Makefile
+++ b/science/scidavis/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= scidavis
-PORTVERSION= 2.0.1
-PORTREVISION= 3
+PORTVERSION= 2.2.0
CATEGORIES= science
MAINTAINER= makc@FreeBSD.org
diff --git a/science/scidavis/distinfo b/science/scidavis/distinfo
index 83625556e3a9..e3e51a341474 100644
--- a/science/scidavis/distinfo
+++ b/science/scidavis/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1554553663
-SHA256 (highperformancecoder-scidavis-2.0.1_GH0.tar.gz) = dd3afe13a5a73fa7da55bee579db8d996f0054800edf5145290656aa41666f7d
-SIZE (highperformancecoder-scidavis-2.0.1_GH0.tar.gz) = 9715181
+TIMESTAMP = 1589881662
+SHA256 (highperformancecoder-scidavis-2.2.0_GH0.tar.gz) = 58e88a0f538b4bc22376069dccaa343ce2fc179b1d00d6a4f4bd27fbbab8a3f2
+SIZE (highperformancecoder-scidavis-2.2.0_GH0.tar.gz) = 9820993
diff --git a/science/scidavis/files/patch-libscidavis_python.pri b/science/scidavis/files/patch-libscidavis_python.pri
index e9b8e4cc679d..00e07543b571 100644
--- a/science/scidavis/files/patch-libscidavis_python.pri
+++ b/science/scidavis/files/patch-libscidavis_python.pri
@@ -1,11 +1,11 @@
---- libscidavis/python.pri.orig 2018-10-17 03:28:35 UTC
+--- libscidavis/python.pri.orig 2020-05-10 23:27:36 UTC
+++ libscidavis/python.pri
-@@ -27,7 +27,7 @@
- DEFINES += PYTHONHOME=/Applications/scidavis.app/Contents/Resources
+@@ -28,7 +28,7 @@
}
+ SIP_FAILURE = TRUE
system(mkdir -p $${SIP_DIR})
-- system($$system($$PYTHONBIN python-sipcmd.py PyQt$$QT_MAJOR_VERSION) $$system($$PYTHONBIN-config --includes) -c $${SIP_DIR} src/scidavis.sip)
-+ system($$system($$PYTHONBIN python-sipcmd.py PyQt$$QT_MAJOR_VERSION) -I $$PYQT_SIPDIR $$system($$PYTHONBIN-config --includes) -c $${SIP_DIR} src/scidavis.sip)
- }
-
- win32 {
+- system($$system($$PYTHONBIN python-sipcmd.py PyQt$$QT_MAJOR_VERSION) $$system($$PYTHONBIN-config --includes) -c $${SIP_DIR} src/scidavis.sip): SIP_FAILURE = FALSE
++ system($$system($$PYTHONBIN python-sipcmd.py PyQt$$QT_MAJOR_VERSION) -I $$PYQT_SIPDIR $$system($$PYTHONBIN-config --includes) -c $${SIP_DIR} src/scidavis.sip): SIP_FAILURE = FALSE
+ equals(SIP_FAILURE, "TRUE") {
+ error(`$$PYTHONBIN python-sipcmd.py PyQt$$QT_MAJOR_VERSION` `$$PYTHONBIN-config --includes` -c $${SIP_DIR} src/scidavis.sip FAILED in $$PWD)
+ }
diff --git a/science/scidavis/files/patch-libscidavis_src_ApplicationWindow.cpp b/science/scidavis/files/patch-libscidavis_src_ApplicationWindow.cpp
index dac0ebbef5ba..d7a4205ccc4d 100644
--- a/science/scidavis/files/patch-libscidavis_src_ApplicationWindow.cpp
+++ b/science/scidavis/files/patch-libscidavis_src_ApplicationWindow.cpp
@@ -1,4 +1,4 @@
---- libscidavis/src/ApplicationWindow.cpp.orig 2018-10-17 03:28:35 UTC
+--- libscidavis/src/ApplicationWindow.cpp.orig 2020-05-10 23:27:36 UTC
+++ libscidavis/src/ApplicationWindow.cpp
@@ -4253,7 +4253,7 @@ void ApplicationWindow::readSettings()
settings.endGroup(); // Colors
@@ -9,7 +9,7 @@
helpFilePath = settings.value("/HelpFile", "").toString();
#ifdef PLUGIN_PATH
QString defaultFitPluginsPath = PLUGIN_PATH;
-@@ -8209,6 +8209,10 @@ void ApplicationWindow::showWindowTitleB
+@@ -8211,6 +8211,10 @@ void ApplicationWindow::showWindowTitleBarMenu()
void ApplicationWindow::chooseHelpFolder()
{
// TODO: move all paths & location handling to anothor class
@@ -20,7 +20,7 @@
#if defined(Q_OS_WIN)
const QString locateDefaultHelp = qApp->applicationDirPath() +
QDir::toNativeSeparators("/manual/index.html");
-@@ -8216,6 +8220,8 @@ void ApplicationWindow::chooseHelpFolder
+@@ -8218,6 +8222,8 @@ void ApplicationWindow::chooseHelpFolder()
const QString locateDefaultHelp =
QDir::toNativeSeparators("/usr/share/doc/scidavis/manual/index.html");
#endif
diff --git a/science/scidavis/pkg-descr b/science/scidavis/pkg-descr
index d286906d4e44..b98997e3497e 100644
--- a/science/scidavis/pkg-descr
+++ b/science/scidavis/pkg-descr
@@ -1,5 +1,6 @@
-SciDAVis is a free cross-platform program for two- and three-dimensional graphical
-presentation of data sets and for data analysis. It combines easy-to-use graphical
-user interface with powerful features such as Python scripting.
+SciDAVis is a free cross-platform program for two- and three-dimensional
+graphical presentation of data sets and for data analysis. It combines
+easy-to-use graphical user interface with powerful features such as Python
+scripting.
WWW: http://scidavis.sourceforge.net
diff --git a/science/scidavis/pkg-plist b/science/scidavis/pkg-plist
index 3ccdaf85dc13..c58762ba639d 100644
--- a/science/scidavis/pkg-plist
+++ b/science/scidavis/pkg-plist
@@ -50,3 +50,5 @@ share/mime/packages/scidavis.xml
%%NLS%%%%DATADIR%%/translations/scidavis_pt-br.qm
%%NLS%%%%DATADIR%%/translations/scidavis_ru.qm
%%NLS%%%%DATADIR%%/translations/scidavis_sv.qm
+%%NLS%%%%DATADIR%%/translations/scidavis_zh-cn.qm
+%%NLS%%%%DATADIR%%/translations/scidavis_zh-tw.qm