aboutsummaryrefslogtreecommitdiff
path: root/science/sigrok-cli
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2014-01-03 00:13:11 +0000
committerJason Helfman <jgh@FreeBSD.org>2014-01-03 00:13:11 +0000
commit3c2985c7a6c4dc16083dbbbe98ef3762be19c451 (patch)
treea816bc9a80a2b873175bd6e904d0f84db61cd758 /science/sigrok-cli
parente9f1d757ca50462a960c75bb8d0dce8ff8a7e69a (diff)
downloadports-3c2985c7a6c4dc16083dbbbe98ef3762be19c451.tar.gz
ports-3c2985c7a6c4dc16083dbbbe98ef3762be19c451.zip
The sigrok project aims at creating a portable, cross-platform,
Free/Libre/Open-Source signal analysis software suite that supports various device types, such as logic analyzers, MSOs, oscilloscopes, multimeters, LCR meters, sound level meters, thermometers, hygrometers, anemometers, light meters, DAQs, dataloggers, function generators, spectrum analyzers, power supplies, GPIB interfaces, and more. sigrok-cli is a command-line tool written in C, which uses both libsigrok and libsigrokdecode to provide the basic sigrok functionality from the command-line. Among other things, it's useful for scripting purposes. WWW: http://sigrok.org/ PR: ports/179855 Submitted by: Uffe Jakobsen <uffe@uffe.org>
Notes
Notes: svn path=/head/; revision=338510
Diffstat (limited to 'science/sigrok-cli')
-rw-r--r--science/sigrok-cli/Makefile23
-rw-r--r--science/sigrok-cli/distinfo2
-rw-r--r--science/sigrok-cli/pkg-descr13
3 files changed, 38 insertions, 0 deletions
diff --git a/science/sigrok-cli/Makefile b/science/sigrok-cli/Makefile
new file mode 100644
index 000000000000..72c566301f3e
--- /dev/null
+++ b/science/sigrok-cli/Makefile
@@ -0,0 +1,23 @@
+# Created by: Uffe Jakobsen <uffe@uffe.org>
+# $FreeBSD$
+
+PORTNAME= sigrok-cli
+PORTVERSION= 0.4.0
+CATEGORIES= science cad
+MASTER_SITES= http://sigrok.org/download/source/sigrok-cli/
+
+MAINTAINER= uffe@uffe.org
+COMMENT= Framework for hardware logic analyzers, CLI client
+
+LICENSE= GPLv3
+
+LIB_DEPENDS= libsigrok.so:${PORTSDIR}/devel/libsigrok \
+ libsigrokdecode.so:${PORTSDIR}/devel/libsigrokdecode
+
+PLIST_FILES= bin/sigrok-cli man/man1/sigrok-cli.1.gz
+GNU_CONFIGURE= yes
+USES= gmake pkgconfig pathfix
+USE_GNOME= gtk20
+MAKE_JOBS_UNSAFE= yes
+
+.include <bsd.port.mk>
diff --git a/science/sigrok-cli/distinfo b/science/sigrok-cli/distinfo
new file mode 100644
index 000000000000..f5ab3d76efd5
--- /dev/null
+++ b/science/sigrok-cli/distinfo
@@ -0,0 +1,2 @@
+SHA256 (sigrok-cli-0.4.0.tar.gz) = f7a20003e33eaf674c75fdbc10829020b3c92f1a34bf5936eccf2c6f65387496
+SIZE (sigrok-cli-0.4.0.tar.gz) = 362171
diff --git a/science/sigrok-cli/pkg-descr b/science/sigrok-cli/pkg-descr
new file mode 100644
index 000000000000..7ce0be3762a3
--- /dev/null
+++ b/science/sigrok-cli/pkg-descr
@@ -0,0 +1,13 @@
+The sigrok project aims at creating a portable, cross-platform,
+Free/Libre/Open-Source signal analysis software suite that supports
+various device types, such as logic analyzers, MSOs, oscilloscopes,
+multimeters, LCR meters, sound level meters, thermometers,
+hygrometers, anemometers, light meters, DAQs, dataloggers,
+function generators, spectrum analyzers, power supplies,
+GPIB interfaces, and more.
+
+sigrok-cli is a command-line tool written in C, which uses both libsigrok
+and libsigrokdecode to provide the basic sigrok functionality from the
+command-line. Among other things, it's useful for scripting purposes.
+
+WWW: http://sigrok.org/