aboutsummaryrefslogtreecommitdiff
path: root/science/simlib/Makefile
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-07-07 21:09:10 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-07-07 21:09:10 +0000
commit3952f4af1a91aa8557175f5a8eeed713ba9355c2 (patch)
tree152f29e6fefb2a67a36ba42798dd26c987bbdd85 /science/simlib/Makefile
parentc5b2a1cc69b308d586c6e00b618271ca6dc96589 (diff)
downloadports-3952f4af1a91aa8557175f5a8eeed713ba9355c2.tar.gz
ports-3952f4af1a91aa8557175f5a8eeed713ba9355c2.zip
science/simlib: Fix build
- Doesn't build with Clang 6 errors.cc:14:42: error: invalid suffix on literal; C++11 requires a space between literal and identifier [-Wreserved-user-defined-literal] /* 0 */ "SIMLIB/C++ Simulation Library, "SIMLIB_COPYRIGHT"\0" ^ http://beefy12.nyi.freebsd.org/data/head-amd64-default/p473790_s335878/logs/simlib-3.02_1.log - nm crashes during the build on FreeBSD >= 11.1. Use binutils from ports as a workaround. [1] Assertion failed: (ddata->output.size > 0), function cpp_demangle_read_sname, file /usr/src/contrib/elftoolchain/libelftc/libelftc_dem_gnu3.c, line 2137. http://beefy9.nyi.freebsd.org/data/111amd64-default/473790/logs/simlib-3.02_1.log PR: 223333 [1]
Notes
Notes: svn path=/head/; revision=474139
Diffstat (limited to 'science/simlib/Makefile')
-rw-r--r--science/simlib/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/science/simlib/Makefile b/science/simlib/Makefile
index fa3b6d83614c..c960aea1fea4 100644
--- a/science/simlib/Makefile
+++ b/science/simlib/Makefile
@@ -20,6 +20,15 @@ CXXFLAGS+= -fPIC
NOT_FOR_ARCHS= aarch64 armv6 armv7 mips mips64 powerpc powerpc64 sparc64
NOT_FOR_ARCHS_REASON= contains not working ${ARCH}-dependent assembly code
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1101000
+# nm crashes during the build:
+# Assertion failed: (ddata->output.size > 0), function cpp_demangle_read_sname, file /usr/src/contrib/elftoolchain/libelftc/libelftc_dem_gnu3.c, line 2137.
+USE_BINUTILS= yes
+BINARY_ALIAS= nm=${NM}
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|make|gmake|g' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's#%%PREFIX%%#${PREFIX}#g' \