aboutsummaryrefslogtreecommitdiff
path: root/science/spglib
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2022-05-31 03:05:56 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2022-05-31 03:05:56 +0000
commitb381e146488b86fa5fe808fb0d8db2b42a27e935 (patch)
tree2baef8327cc17873bb4a8117298f1a7302e1ba69 /science/spglib
parent1ba955a74ecf71fa1652d35465632256a98cde17 (diff)
downloadports-b381e146488b86fa5fe808fb0d8db2b42a27e935.tar.gz
ports-b381e146488b86fa5fe808fb0d8db2b42a27e935.zip
science/spglib: fix build without libomp
CMake Error at /usr/local/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:230 (message): Could NOT find OpenMP_C (missing: OpenMP_C_FLAGS OpenMP_C_LIB_NAMES) Call Stack (most recent call first): /usr/local/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:594 (_FPHSA_FAILURE_MESSAGE) /usr/local/share/cmake/Modules/FindOpenMP.cmake:596 (find_package_handle_standard_args) CMakeLists.txt:42 (find_package)
Diffstat (limited to 'science/spglib')
-rw-r--r--science/spglib/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/science/spglib/Makefile b/science/spglib/Makefile
index 8b92284b2353..b79425cd2835 100644
--- a/science/spglib/Makefile
+++ b/science/spglib/Makefile
@@ -13,4 +13,8 @@ USES= cmake
USE_GITHUB= yes
USE_LDCONFIG= yes
+.if !exists(/usr/include/omp.h)
+CMAKE_ARGS+= -DUSE_OMP:BOOL=OFF
+.endif
+
.include <bsd.port.mk>