aboutsummaryrefslogtreecommitdiff
path: root/science/v_sim
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2019-02-27 20:48:49 +0000
committerThierry Thomas <thierry@FreeBSD.org>2019-02-27 20:48:49 +0000
commit4b7e9b83415a97c1990583bece4d94cbd89fc46c (patch)
tree183ae2b10a9a92de131c21fedd9a96dedc40f369 /science/v_sim
parent469bbd9f0d6880448704230cebf1aebc030b3376 (diff)
downloadports-4b7e9b83415a97c1990583bece4d94cbd89fc46c.tar.gz
ports-4b7e9b83415a97c1990583bece4d94cbd89fc46c.zip
- Add USES=compiler:c11 to fix build on GCC architectures;
- Add USES=gl gnome localbase:ldflags; - CUSE_GL to gl and glu. PR: 236075 Submitted by: pkubaj (at) anongoth.pl
Notes
Notes: svn path=/head/; revision=494084
Diffstat (limited to 'science/v_sim')
-rw-r--r--science/v_sim/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/science/v_sim/Makefile b/science/v_sim/Makefile
index 883312503ee5..fdd67af718dd 100644
--- a/science/v_sim/Makefile
+++ b/science/v_sim/Makefile
@@ -19,14 +19,14 @@ LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
libftgl.so:graphics/ftgl
-USES= fortran gmake libtool pkgconfig tar:bzip2
+USES= compiler:c11 fortran gl gmake gnome libtool localbase:ldflags \
+ pkgconfig tar:bzip2
USE_XORG= x11
USE_GNOME= gtk20 intltool cairo
-USE_GL= yes
+USE_GL= gl glu
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-gtk-doc --with-html-dir=${PREFIX}/share/doc --disable-python-module
-CPPFLAGS+= ${CFLAGS} -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+CPPFLAGS+= ${CFLAGS}
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
INSTALL_TARGET= install-strip