aboutsummaryrefslogtreecommitdiff
path: root/science/xcrysden/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-07-19 19:19:38 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-07-19 19:19:38 +0000
commit3aa3261c8759cdc04b6657851c1705f2c5ebe24d (patch)
tree8cb4d9f176a81f190d4da050e6b1e03a868378ac /science/xcrysden/Makefile
parent7fd82e7beae4b3ab3358399a812163d7de16cb16 (diff)
downloadports-3aa3261c8759cdc04b6657851c1705f2c5ebe24d.tar.gz
ports-3aa3261c8759cdc04b6657851c1705f2c5ebe24d.zip
New port: science/xcrysden: Crystalline and molecular structure visualisation program
Notes
Notes: svn path=/head/; revision=474971
Diffstat (limited to 'science/xcrysden/Makefile')
-rw-r--r--science/xcrysden/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/science/xcrysden/Makefile b/science/xcrysden/Makefile
new file mode 100644
index 000000000000..516fe32ac48e
--- /dev/null
+++ b/science/xcrysden/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= xcrysden
+DISTVERSION= 1.5.60
+CATEGORIES= science
+MASTER_SITES= http://www.xcrysden.org/download/
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Crystalline and molecular structure visualisation program
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libfftw3.so:math/fftw3
+RUN_DEPENDS= bwidget>0:x11-toolkits/bwidget
+
+USES= fortran gmake localbase:ldflags tcl tk
+USE_GL= gl glu
+USE_XORG= x11 xmu
+
+BINARY_ALIAS= make=gmake gcc=cc gfortran=gfortran${GCC_DEFAULT}
+
+post-patch:
+ @${CP} ${FILESDIR}/Make.sys ${WRKSRC}
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' ${WRKSRC}/Make.sys
+ @${RM} -r ${WRKSRC}/external/src
+
+post-install:
+ @cd ${STAGEDIR}${PREFIX}/lib/${PORTNAME} && ${STRIP_CMD} xcrys xctclsh xsf2xsf
+ @${REINPLACE_CMD} -i '' -e 's|^\.|export LD_PRELOAD=/usr/local/lib/gcc${GCC_DEFAULT}/libgcc_s.so; .|' \
+ ${STAGEDIR}${PREFIX}/bin/xcrysden
+
+.include <bsd.port.mk>