aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2024-01-21 18:21:40 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2024-01-21 18:21:59 +0000
commit1b31dfe05a6f52ecbc1514868d723abb98b99d4f (patch)
tree90f20b87ad6b4b38ea24b8117cd84492f278c96a /science
parent319b2de7f05f71a55f46631a8f01167cbc1ac803 (diff)
downloadports-1b31dfe05a6f52ecbc1514868d723abb98b99d4f.tar.gz
ports-1b31dfe05a6f52ecbc1514868d723abb98b99d4f.zip
science/spheral: update 2023.06.0 → 2024.01.0
Reported by: portscout
Diffstat (limited to 'science')
-rw-r--r--science/spheral/Makefile14
-rw-r--r--science/spheral/distinfo14
-rw-r--r--science/spheral/files/patch-cmake_SetupSpheral.cmake20
-rw-r--r--science/spheral/pkg-plist53
4 files changed, 47 insertions, 54 deletions
diff --git a/science/spheral/Makefile b/science/spheral/Makefile
index 1e86381e304f..c6ca8dd1f126 100644
--- a/science/spheral/Makefile
+++ b/science/spheral/Makefile
@@ -1,7 +1,6 @@
PORTNAME= spheral
DISTVERSIONPREFIX= v
-DISTVERSION= 2023.06.0
-PORTREVISION= 1
+DISTVERSION= 2024.01.0
CATEGORIES= science # physics
MAINTAINER= yuri@FreeBSD.org
@@ -27,7 +26,9 @@ USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= LLNL
-GH_TUPLE= llnl:blt:ddd5a0c:blt/cmake/blt \
+GH_TUPLE= LLNL:PolyClipper:e1fe47c:PolyClipper/extern/PolyClipper \
+ LLNL:PYB11Generator:7160812:PYB11Generator/extern/PYB11Generator \
+ llnl:blt:29eecef:blt/cmake/blt \
llnl:uberenv:126f8de:uberenv/scripts/devtools/uberenv
CMAKE_ARGS= -Daneos_DIR=${LOCALBASE} \
@@ -44,6 +45,7 @@ CMAKE_ARGS= -Daneos_DIR=${LOCALBASE} \
-Dqhull_DIR=${LOCALBASE} \
-Dsilo_DIR=${LOCALBASE} \
-Dzlib_DIR=/usr
+CMAKE_ARGS+= -DPYTHON_EXECUTABLE=${PYTHON_CMD}
CMAKE_OFF= ENABLE_TESTS ENABLE_DOCS \
ENABLE_ANEOS \
ENABLE_CUDA
@@ -53,16 +55,14 @@ CMAKE_TESTING_ON= ENABLE_TESTS # tests fail to build, see https://github.com/LLN
CXXFLAGS+= -I${LOCALBASE}/include/eigen3
-BINARY_ALIAS= git=false python=${PYTHON_CMD}
+BINARY_ALIAS= git=false python=${PYTHON_CMD} python3=${PYTHON_CMD}
post-patch:
@${REINPLACE_CMD} -e 's|\.a|.so|; s|qhullstatic|qhull_r|; s|python2\.7|python${PYTHON_VER}|g' ${WRKSRC}/cmake/tpl/*.cmake
@${CHMOD} +x ${WRKSRC}/src/helpers/InstantiationGenerator.py
post-install:
- # workaround for https://github.com/LLNL/spheral/issues/188
- @${MKDIR} ${STAGEDIR}${PREFIX}/lib/cmake
- @${MV} ${STAGEDIR}${PREFIX}/Spheral/lib/cmake/* ${STAGEDIR}${PREFIX}/lib/cmake
+ # remove the stray file Spheral/mpi.py
@${RM} -r ${STAGEDIR}${PREFIX}/Spheral
.include <bsd.port.mk>
diff --git a/science/spheral/distinfo b/science/spheral/distinfo
index f925bc0442bc..f1b99ad642a6 100644
--- a/science/spheral/distinfo
+++ b/science/spheral/distinfo
@@ -1,7 +1,11 @@
-TIMESTAMP = 1688714848
-SHA256 (LLNL-spheral-v2023.06.0_GH0.tar.gz) = a373d7efb42a75ddaeca70373d1e91a6b655a718ba71879132c7ba7d9554af3f
-SIZE (LLNL-spheral-v2023.06.0_GH0.tar.gz) = 6656691
-SHA256 (llnl-blt-ddd5a0c_GH0.tar.gz) = 5c235a9b160f1cc3f6ce4d7c80bf72772ac10839909f4f96075d08b3edd8f540
-SIZE (llnl-blt-ddd5a0c_GH0.tar.gz) = 1220052
+TIMESTAMP = 1705820099
+SHA256 (LLNL-spheral-v2024.01.0_GH0.tar.gz) = 86ffef944943b5219b69d05aac07f30bc120082f7a73d6ed7aaf3d84181e6e79
+SIZE (LLNL-spheral-v2024.01.0_GH0.tar.gz) = 6693993
+SHA256 (LLNL-PolyClipper-e1fe47c_GH0.tar.gz) = 52b358f32f523e6030ed090411c90f0811db12046b6cb6fa8e4cafe4f8b3567e
+SIZE (LLNL-PolyClipper-e1fe47c_GH0.tar.gz) = 274184
+SHA256 (LLNL-PYB11Generator-7160812_GH0.tar.gz) = 9f257b9a5b2503aaacdba48d785bd349c95849a282e1e181ccee2c0f319135cb
+SIZE (LLNL-PYB11Generator-7160812_GH0.tar.gz) = 75342
+SHA256 (llnl-blt-29eecef_GH0.tar.gz) = 046d39d792883f768da37acb83c27040b4feec1b14c7df95fcc005622ac7c7ba
+SIZE (llnl-blt-29eecef_GH0.tar.gz) = 1271026
SHA256 (llnl-uberenv-126f8de_GH0.tar.gz) = 6a403e722dc023d87dd69f8235fa631ab96a7b1ff328929b9c969e7c113ce9f7
SIZE (llnl-uberenv-126f8de_GH0.tar.gz) = 25345
diff --git a/science/spheral/files/patch-cmake_SetupSpheral.cmake b/science/spheral/files/patch-cmake_SetupSpheral.cmake
index 12531e31d4b8..f61d586ddd96 100644
--- a/science/spheral/files/patch-cmake_SetupSpheral.cmake
+++ b/science/spheral/files/patch-cmake_SetupSpheral.cmake
@@ -1,13 +1,13 @@
- eliminate the need to use git
---- cmake/SetupSpheral.cmake.orig 2023-07-06 16:44:17 UTC
+--- cmake/SetupSpheral.cmake.orig 2024-01-20 00:52:15 UTC
+++ cmake/SetupSpheral.cmake
-@@ -176,7 +176,7 @@ if (ENABLE_TESTS)
-
- # Find the test files we want to install
- execute_process(
-- COMMAND git ls-files tests
-+ COMMAND find tests -type f
- WORKING_DIRECTORY ${SPHERAL_ROOT_DIR}
- OUTPUT_VARIABLE test_files1)
- string(REPLACE "\n" " " test_files ${test_files1})
+@@ -169,7 +169,7 @@ if (ENABLE_TESTS)
+ set(test_files1 "")
+ if (EXISTS "${CMAKE_SOURCE_DIR}/.git")
+ execute_process(
+- COMMAND git ls-files tests
++ COMMAND find tests -type f
+ WORKING_DIRECTORY ${SPHERAL_ROOT_DIR}
+ OUTPUT_VARIABLE test_files1)
+ else()
diff --git a/science/spheral/pkg-plist b/science/spheral/pkg-plist
index f5e92fca5d9a..068e939add0c 100644
--- a/science/spheral/pkg-plist
+++ b/science/spheral/pkg-plist
@@ -74,13 +74,13 @@ include/CRKSPH/detectSurface.hh
include/CRKSPH/editMultimaterialSurfaceTopology.hh
include/CRKSPH/volumeSpacing.hh
include/CRKSPH/zerothOrderSurfaceCorrections.hh
+include/DEM/CircularPlaneSolidBoundary.hh
include/DEM/ContactStorageLocation.hh
+include/DEM/CylinderSolidBoundary.hh
include/DEM/DEMBase.hh
+include/DEM/DEMBoundaryPolicy.hh
include/DEM/DEMDimension.hh
include/DEM/DEMFieldNames.hh
-include/DEM/CircularPlaneSolidBoundary.hh
-include/DEM/CylinderSolidBoundary.hh
-include/DEM/DEMBoundaryPolicy.hh
include/DEM/IncrementPairFieldList.hh
include/DEM/InfinitePlaneSolidBoundary.hh
include/DEM/LinearSpringDEM.hh
@@ -95,8 +95,6 @@ include/Damage/DamageGradientNodeCoupling.hh
include/Damage/DamageGradientPolicy.hh
include/Damage/DamageModel.hh
include/Damage/DamageModelInline.hh
-include/Damage/DamagedPressurePolicy.hh
-include/Damage/DamagedSoundSpeedPolicy.hh
include/Damage/EffectiveTensorDamagePolicy.hh
include/Damage/GradyKippScalarDamage.hh
include/Damage/IvanoviSALEDamageModel.hh
@@ -125,27 +123,24 @@ include/Damage/computeFragmentField.hh
include/Damage/oneMinusDamage.hh
include/Damage/weibullFlawDistributionBenzAsphaug.hh
include/Damage/weibullFlawDistributionOwen.hh
-include/DataBase/CompositeFieldListPolicy.hh
-include/DataBase/CopyFieldList.hh
include/DataBase/CopyState.hh
+include/DataBase/CopyStateInline.hh
include/DataBase/DataBase.hh
include/DataBase/DataBaseInline.hh
-include/DataBase/FieldListUpdatePolicyBase.hh
-include/DataBase/FieldListUpdatePolicyBaseInline.hh
-include/DataBase/FieldUpdatePolicyBase.hh
-include/DataBase/FieldUpdatePolicyBaseInline.hh
-include/DataBase/IncrementBoundedFieldList.hh
-include/DataBase/IncrementBoundedFieldListInline.hh
+include/DataBase/FieldUpdatePolicy.hh
+include/DataBase/FieldUpdatePolicyInline.hh
include/DataBase/IncrementBoundedState.hh
include/DataBase/IncrementBoundedStateInline.hh
-include/DataBase/IncrementFieldList.hh
include/DataBase/IncrementState.hh
-include/DataBase/ReplaceBoundedFieldList.hh
-include/DataBase/ReplaceBoundedFieldListInline.hh
+include/DataBase/IncrementStateInline.hh
+include/DataBase/PureReplaceBoundedState.hh
+include/DataBase/PureReplaceBoundedStateInline.hh
+include/DataBase/PureReplaceState.hh
+include/DataBase/PureReplaceStateInline.hh
include/DataBase/ReplaceBoundedState.hh
include/DataBase/ReplaceBoundedStateInline.hh
-include/DataBase/ReplaceFieldList.hh
include/DataBase/ReplaceState.hh
+include/DataBase/ReplaceStateInline.hh
include/DataBase/State.hh
include/DataBase/StateBase.hh
include/DataBase/StateBaseInline.hh
@@ -205,6 +200,7 @@ include/FSISPH/SolidFSISPHHydroBase.hh
include/FSISPH/SolidFSISPHHydroBaseInline.hh
include/FSISPH/computeFSISPHSumMassDensity.hh
include/FSISPH/computeHWeightedFSISPHSumMassDensity.hh
+include/FSISPH/computeInterfacePressureCorrectedSumMassDensity.hh
include/Field/AggregateField.hh
include/Field/AllNodeIterator.hh
include/Field/AllNodeIteratorInline.hh
@@ -262,7 +258,6 @@ include/GSPH/LimiterBase.hh
include/GSPH/MFMHydroBase.hh
include/GSPH/MinModLimiter.hh
include/GSPH/OspreLimiter.hh
-include/GSPH/PureReplaceFieldList.hh
include/GSPH/ReplaceWithRatioPolicy.hh
include/GSPH/RiemannSolverBase.hh
include/GSPH/SuperbeeLimiter.hh
@@ -356,13 +351,9 @@ include/Gravity/TreeGravityInline.hh
include/Hydro/CompatibleDifferenceSpecificThermalEnergyPolicy.hh
include/Hydro/EntropyPolicy.hh
include/Hydro/GammaPolicy.hh
-include/Hydro/HybridMassDensityPolicyInline.hh
include/Hydro/HydroFieldNames.hh
include/Hydro/HydroInline.hh
-include/Hydro/MashCorrectionPolicy.hh
-include/Hydro/MeshScaledMassDensityPolicy.hh
include/Hydro/NonSymmetricSpecificThermalEnergyPolicy.hh
-include/Hydro/PositionPolicy.hh
include/Hydro/PressurePolicy.hh
include/Hydro/RZNonSymmetricSpecificThermalEnergyPolicy.hh
include/Hydro/SecondMomentHourglassControl.hh
@@ -518,10 +509,14 @@ include/Physics/GenericHydro.hh
include/Physics/GenericHydroInline.hh
include/Physics/Physics.hh
include/Physics/PhysicsInline.hh
+include/Porosity/PalphaPorosity.hh
+include/Porosity/PorosityModel.hh
+include/Porosity/PorosityModelInline.hh
+include/Porosity/StrainPorosity.hh
+include/Porosity/StrainPorosityInline.hh
include/RK/ContinuityVolumePolicy.hh
include/RK/ContinuityVolumePolicyRZ.hh
include/RK/HVolumePolicy.hh
-include/RK/HullVolumePolicy.hh
include/RK/RKCoefficients.hh
include/RK/RKCorrectionParams.hh
include/RK/RKCorrections.hh
@@ -541,7 +536,6 @@ include/RK/computeVoronoiVolume.hh
include/RK/gradientRK.hh
include/RK/hessianRK.hh
include/RK/interpolateRK.hh
-include/SPH/OmegaGradhPolicy.hh
include/SPH/PSPHHydroBase.hh
include/SPH/PSPHHydroBaseInline.hh
include/SPH/SPHHydroBase.hh
@@ -589,17 +583,12 @@ include/SolidMaterial/NullStrength.hh
include/SolidMaterial/OsborneEquationOfState.hh
include/SolidMaterial/OsborneEquationOfStateInline.hh
include/SolidMaterial/PhysicsEvolvingMaterialLibrary.hh
-include/SolidMaterial/PiecewiseLinearPorousStrengthModel.hh
include/SolidMaterial/PolynomialFit.hh
include/SolidMaterial/PolynomialFitInline.hh
-include/SolidMaterial/PorousEquationOfState.hh
-include/SolidMaterial/PorousStrengthModel.hh
include/SolidMaterial/SolidEquationOfState.hh
include/SolidMaterial/SolidEquationOfStateInline.hh
include/SolidMaterial/SteinbergGuinanLundStrength.hh
include/SolidMaterial/SteinbergGuinanStrength.hh
-include/SolidMaterial/StrainPorosity.hh
-include/SolidMaterial/StrainPorosityInline.hh
include/SolidMaterial/StrengthModel.hh
include/SolidMaterial/TillotsonEquationOfState.hh
include/SolidMaterial/TillotsonEquationOfStateInline.hh
@@ -610,7 +599,6 @@ include/Strength/MeltEnergyPolicy.hh
include/Strength/PlasticStrainPolicy.hh
include/Strength/ShearModulusPolicy.hh
include/Strength/SolidFieldNames.hh
-include/Strength/StrengthSoundSpeedPolicy.hh
include/Strength/YieldStrengthPolicy.hh
include/Strength/effectiveKernelVolume.hh
include/Utilities/Bessel.hh
@@ -709,6 +697,7 @@ include/Utilities/testBoxIntersection.hh
include/Utilities/timingUtilities.hh
include/Utilities/uniform_random.hh
include/Utilities/uniform_random_Inline.hh
-lib/cmake/spheral-targets-%%CMAKE_BUILD_TYPE%%.cmake
-lib/cmake/spheral-targets.cmake
+lib/cmake/spheral_cxx-config.cmake
+lib/cmake/spheral_cxx-targets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/spheral_cxx-targets.cmake
lib/libSpheral_CXX.so