aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-12-17 20:36:38 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-12-17 20:36:38 +0000
commit26dc61ce92268aa707ed5522fc52dab518e08d27 (patch)
tree96db1897b95dc9139d0aa37fce95a620c5e0f9f2 /science
parent43d9d79b8c596f1f45e681c4c6c83ac0649dde8b (diff)
downloadports-26dc61ce92268aa707ed5522fc52dab518e08d27.tar.gz
ports-26dc61ce92268aa707ed5522fc52dab518e08d27.zip
- Update from 4.6.4 to 4.6.5 [1]
- Convert some "if's" in options helpers PR: ports/184903 Submitted by: KATO Tsuguru <tkato432@yahoo.com> [1]
Notes
Notes: svn path=/head/; revision=336762
Diffstat (limited to 'science')
-rw-r--r--science/gromacs/Makefile36
-rw-r--r--science/gromacs/distinfo4
2 files changed, 16 insertions, 24 deletions
diff --git a/science/gromacs/Makefile b/science/gromacs/Makefile
index 05651f5cf638..73d404744a7b 100644
--- a/science/gromacs/Makefile
+++ b/science/gromacs/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gromacs
-PORTVERSION= 4.6.4
+PORTVERSION= 4.6.5
CATEGORIES= science
MASTER_SITES= ftp://ftp.gromacs.org/pub/gromacs/
@@ -16,13 +16,15 @@ OPTIONS_DEFAULT= FLOAT GSL X11
OPTIONS_RADIO= MPI
OPTIONS_RADIO_MPI= MPICH OMPI
+OPTIONS_SUB= yes
+
ATLAS_DESC= Use ATLAS for BLAS and LAPACK
FLOAT_DESC= Use single instead of double precision
GSL_DESC= Extra analysis using math/gsl
MPICH_DESC= MPI support using net/mpich2
OMPI_DESC= MPI support using net/openmpi
-USES= cmake pkgconfig shebangfix perl5
+USES= cmake perl5 pkgconfig shebangfix
SHEBANG_FILES= admin/*.pl scripts/*.pl scripts/*.sh src/gmxlib/selection/*.sh
bash_CMD= ${SH}
USE_FORTRAN= yes
@@ -30,6 +32,16 @@ CMAKE_ARGS= -DBLAS_LIBRARIES:FILEPATH="${BLAS_LIBS}" \
-DLAPACK_LIBRARIES:FILEPATH="${LAPACK_LIBS}"
USE_LDCONFIG= yes
+GSL_LIB_DEPENDS= libgsl.so:${PORTSDIR}/math/gsl
+GSL_CMAKE_ON= -DGMX_GSL:BOOL=ON
+GSL_CMAKE_OFF= -DGMX_GSL:BOOL=OFF
+
+SIMD_CMAKE_OFF= -DGMX_CPU_ACCELERATION:STRING="None"
+
+X11_USE= XORG=xext,x11
+X11_CMAKE_ON= -DGMX_X11:BOOL=ON
+X11_CMAKE_OFF= -DGMX_X11:BOOL=OFF
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MATLAS}
@@ -54,26 +66,6 @@ CMAKE_ARGS+= -DGMX_DOUBLE:BOOL=ON
PLIST_SUB+= SUFFIX_D="_d"
.endif
-.if ${PORT_OPTIONS:MGSL}
-LIB_DEPENDS+= libgsl.so:${PORTSDIR}/math/gsl
-CMAKE_ARGS+= -DGMX_GSL:BOOL=ON
-.else
-CMAKE_ARGS+= -DGMX_GSL:BOOL=OFF
-.endif
-
-.if empty(PORT_OPTIONS:MSIMD)
-CMAKE_ARGS+= -DGMX_CPU_ACCELERATION:STRING="None"
-.endif
-
-.if ${PORT_OPTIONS:MX11}
-USE_XORG= xext x11
-CMAKE_ARGS+= -DGMX_X11:BOOL=ON
-PLIST_SUB+= X11=""
-.else
-CMAKE_ARGS+= -DGMX_X11:BOOL=OFF
-PLIST_SUB+= X11="@comment "
-.endif
-
.if ${PORT_OPTIONS:MMPICH} || ${PORT_OPTIONS:MOMPI}
CMAKE_ARGS+= -DGMX_MPI:BOOL=ON \
-DMPI_C_COMPILER:FILEPATH="${MPICC}"
diff --git a/science/gromacs/distinfo b/science/gromacs/distinfo
index 0b5360675957..b2d71293ada3 100644
--- a/science/gromacs/distinfo
+++ b/science/gromacs/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gromacs-4.6.4.tar.gz) = 4d4f15e6d10e97aff7a21d3bb5536283cf8ba669589310c456c1bb22bdfe7d8e
-SIZE (gromacs-4.6.4.tar.gz) = 10990996
+SHA256 (gromacs-4.6.5.tar.gz) = a7242f315963a111e87fd28795696b1e818ac97479788356c4f73a04e9cdef09
+SIZE (gromacs-4.6.5.tar.gz) = 10991576