aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-01-13 05:55:58 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-01-13 05:55:58 +0000
commit32ef6a3133758a32aa8c1cc7992d045c7345092e (patch)
tree5a858d8d96ed06e9ecb1fdbb09f0cce1db0a0085 /science
parent562a8eaddf08cc13fcb3e5255eecef21015c2cff (diff)
downloadports-32ef6a3133758a32aa8c1cc7992d045c7345092e.tar.gz
ports-32ef6a3133758a32aa8c1cc7992d045c7345092e.zip
science/qmcpack: Small corrections
* project uses c++17, not c++11 * project doesn't use devel/catch any more
Diffstat (limited to 'science')
-rw-r--r--science/qmcpack/Makefile5
1 files changed, 1 insertions, 4 deletions
diff --git a/science/qmcpack/Makefile b/science/qmcpack/Makefile
index bdc11b19bb12..f37d479c8d2c 100644
--- a/science/qmcpack/Makefile
+++ b/science/qmcpack/Makefile
@@ -12,7 +12,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN_i386= undefined reference to `__atomic_load'
-BUILD_DEPENDS= catch>0:devel/catch
LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libfftw3.so:math/fftw3 \
libhdf5.so:science/hdf5 \
@@ -20,7 +19,7 @@ LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libopenblas.so:math/openblas \
libsz.so:science/szip
-USES= cmake:testing compiler:c++11-lang fortran gnome localbase:ldflags pkgconfig python:build shebangfix
+USES= cmake:testing compiler:c++17-lang fortran gnome localbase:ldflags pkgconfig python:build shebangfix
USE_GNOME= libxml2
USE_GITHUB= yes
@@ -32,8 +31,6 @@ CMAKE_OFF= BUILD_UNIT_TESTS
CMAKE_ARGS= -DFREEBSD_PYTHON_VER=${PYTHON_VER}
CMAKE_TESTING_ON= BUILD_UNIT_TESTS # at least 3 testcases are known to fail
-CXXFLAGS+= -I${LOCALBASE}/include/catch2
-
PROGS= convert4qmc convertpw4qmc qmc-check-affinity qmc-extract-eshdf-kvectors qmc-get-supercell qmcfinitesize qmcpack qmcpack.settings
PLIST_FILES= ${PROGS:C/^/bin\//}