aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2006-09-15 05:45:32 +0000
committerThierry Thomas <thierry@FreeBSD.org>2006-09-15 05:45:32 +0000
commit3652f10ed1a6f3e9f08523620954e61ef63a9ea7 (patch)
tree070873bc4de14914d4289ae7c57cdeb874f21378 /science
parent0ac35f5deb8ea1ccac77e8a9c945c7a8fd75cf48 (diff)
downloadports-3652f10ed1a6f3e9f08523620954e61ef63a9ea7.tar.gz
ports-3652f10ed1a6f3e9f08523620954e61ef63a9ea7.zip
Fix the build with mpich2.
Reported by: pointyhat via Kris
Notes
Notes: svn path=/head/; revision=173094
Diffstat (limited to 'science')
-rw-r--r--science/openfoam/Makefile2
-rw-r--r--science/openfoam/files/patch-wmake_rules_FreeBSD_mplibMPICH7
2 files changed, 8 insertions, 1 deletions
diff --git a/science/openfoam/Makefile b/science/openfoam/Makefile
index ff2d0e64e6fc..503420a3583e 100644
--- a/science/openfoam/Makefile
+++ b/science/openfoam/Makefile
@@ -154,7 +154,7 @@ pre-configure:
-e "s|2\.3\.11|${MICO_VER}|" \
-e "s|\$$MICO_PATH/platforms/\$$WM_OPTIONS|${LOCALBASE}|" \
-e "s|1\.2\.4|${MPICH_VER}|" \
- -e "s|\$$MPICH_PATH/platforms/\$$WM_OPTIONS|${LOCALBASE}/mpich|"\
+ -e "s|\$$MPICH_PATH/platforms/\$$WM_OPTIONS|${LOCALBASE}/mpich2|"\
-e "s|7\.1\.1|${LAM_VER}|" \
-e "s|\$$LAMHOME/platforms/\$$WM_OPTIONS|${LOCALBASE}|" \
-e "s|^SOURCE |source |" \
diff --git a/science/openfoam/files/patch-wmake_rules_FreeBSD_mplibMPICH b/science/openfoam/files/patch-wmake_rules_FreeBSD_mplibMPICH
new file mode 100644
index 000000000000..6097418d6fb1
--- /dev/null
+++ b/science/openfoam/files/patch-wmake_rules_FreeBSD_mplibMPICH
@@ -0,0 +1,7 @@
+--- wmake/rules/FreeBSD/mplibMPICH.orig Mon Nov 22 18:30:37 2004
++++ wmake/rules/FreeBSD/mplibMPICH Thu Sep 14 22:48:09 2006
+@@ -1,3 +1,3 @@
+-PFLAGS =
++PFLAGS = -DMPICH_SKIP_MPICXX
+ PINC = -I$(MPICH_ARCH_PATH)/include
+ PLIBS = -L$(MPICH_ARCH_PATH)/lib -lmpich