aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-07-16 01:03:43 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-07-20 19:27:08 +0000
commit3cb48e478564abe85103a46357e7bbb007e542b2 (patch)
tree029afac64103c9e14a9eb737ea0b1da0abe398a1 /science
parent646c52f1f70e3a543381584b9577e3e8f4c23e87 (diff)
downloadports-3cb48e478564abe85103a46357e7bbb007e542b2.tar.gz
ports-3cb48e478564abe85103a46357e7bbb007e542b2.zip
science/gabedit: Limit BROKEN_riscv64 to pre-13.1 systems
(cherry picked from commit 7f2c0ee00df82ca1d759d35405f7904b98de8028)
Diffstat (limited to 'science')
-rw-r--r--science/gabedit/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/science/gabedit/Makefile b/science/gabedit/Makefile
index ac07138217d5..72ec14c27b70 100644
--- a/science/gabedit/Makefile
+++ b/science/gabedit/Makefile
@@ -14,7 +14,6 @@ LICENSE_FILE= ${WRKSRC}/License
BROKEN_armv6= fatal error: 'omp.h' file not found
BROKEN_armv7= fatal error: 'omp.h' file not found
BROKEN_i386= undefined reference to `__atomic_load'
-BROKEN_riscv64= fatal error: 'omp.h' file not found
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
@@ -42,6 +41,12 @@ OPTIONS_DEFINE= OPENMP
OPTIONS_DEFAULT= OPENMP
OPTIONS_EXCLUDE_powerpc= OPENMP
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 1301000
+BROKEN_riscv64= fatal error: 'omp.h' file not found
+.endif
+
post-patch:
@${REINPLACE_CMD} 's|/usr/|${PREFIX}/|; s| -O2| ${CFLAGS}|; s|gcc|${CC}|' ${WRKSRC}/CONFIG
@@ -56,4 +61,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/icons/Gabedit${SZ}.png ${STAGEDIR}${PREFIX}/share/icons/hicolor/${SZ}x${SZ}/apps/${PORTNAME}.png
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>