aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-09-30 10:14:18 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-09-30 10:14:18 +0000
commit4844133c9dcf892b0712bde51934cb4ef7701b47 (patch)
treeb235be0c1e263f42fe27bfcfca496aaf75c86d52 /science
parent5a8f64b8add12420fbafb1358062fe1046dcb8aa (diff)
downloadports-4844133c9dcf892b0712bde51934cb4ef7701b47.tar.gz
ports-4844133c9dcf892b0712bde51934cb4ef7701b47.zip
science/InsightToolkit: fix build with GCC-based architectures
Compiling with GCC requires changes in pkg-plist. Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D21428
Notes
Notes: svn path=/head/; revision=513342
Diffstat (limited to 'science')
-rw-r--r--science/InsightToolkit/Makefile12
-rw-r--r--science/InsightToolkit/pkg-plist2
2 files changed, 10 insertions, 4 deletions
diff --git a/science/InsightToolkit/Makefile b/science/InsightToolkit/Makefile
index 37a167c9e0b2..f833eecf6c52 100644
--- a/science/InsightToolkit/Makefile
+++ b/science/InsightToolkit/Makefile
@@ -14,8 +14,6 @@ COMMENT= Insight Toolkit
LICENSE= APACHE20
-BROKEN_powerpc64= fails to package: ITK_COMPILER_INFO_Clang_CXX.h:No such file or directory
-
BUILD_DEPENDS= googletest>=0:devel/googletest
LIB_DEPENDS= libgdcmCommon.so:devel/gdcm \
libexpat.so:textproc/expat2 \
@@ -56,8 +54,16 @@ TESTING_DESC= Build testing programs (very time consuming)
EXAMPLES_CMAKE_ON= -DBUILD_EXAMPLES:BOOL=ON
TESTING_CMAKE_ON= -DBUILD_TESTING:BOOL=ON
+.include <bsd.port.pre.mk>
+
+.if ${CHOSEN_COMPILER_TYPE} == gcc
+PLIST_SUB+= CHOSEN_COMPILER_TYPE="GNU"
+.else
+PLIST_SUB+= CHOSEN_COMPILER_TYPE="Clang"
+.endif
+
post-extract:
${MV} ${WRKDIR}/${PORTNAME}-${PORTVERSION}/.ExternalData/* ${WRKSRC}/.ExternalData/
${RM} -r ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/science/InsightToolkit/pkg-plist b/science/InsightToolkit/pkg-plist
index edf7335063eb..acbc5d6b3a9e 100644
--- a/science/InsightToolkit/pkg-plist
+++ b/science/InsightToolkit/pkg-plist
@@ -138,7 +138,7 @@ include/ITK-%%ITK_VER%%/blas/ztrmm.h
include/ITK-%%ITK_VER%%/blas/ztrmv.h
include/ITK-%%ITK_VER%%/blas/ztrsv.h
include/ITK-%%ITK_VER%%/cached-powers.h
-include/ITK-%%ITK_VER%%/compilers/ITK_COMPILER_INFO_Clang_CXX.h
+include/ITK-%%ITK_VER%%/compilers/ITK_COMPILER_INFO_%%CHOSEN_COMPILER_TYPE%%_CXX.h
include/ITK-%%ITK_VER%%/compilers/VXL_COMPILER_INFO_AppleClang_CXX.h
include/ITK-%%ITK_VER%%/compilers/VXL_COMPILER_INFO_Clang_CXX.h
include/ITK-%%ITK_VER%%/compilers/VXL_COMPILER_INFO_GNU_CXX.h