aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-10-30 15:51:04 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-10-30 15:51:04 +0000
commit4c49ebcd4d98f2d7b2cd38872d1cc7c097ed7021 (patch)
tree0435e5dece721e8c0816c1a9cb4b1b0b999f8bdd /science
parent347120e2c1c5c16b9b9ad501d2264a0b77a0b2d5 (diff)
downloadports-4c49ebcd4d98f2d7b2cd38872d1cc7c097ed7021.tar.gz
ports-4c49ebcd4d98f2d7b2cd38872d1cc7c097ed7021.zip
science/py-pydap: Implementation of the Opendap/DODS protocol
Pydap is an implementation of the Opendap/DODS protocol, written from scratch. You can use Pydap to access scientific data on the internet without having to download it; instead, you work with special array and iterable objects that download data on-the-fly as necessary, saving bandwidth and time. The module also comes with a robust-but-lightweight Opendap server, implemented as a WSGI application. WWW: https://pypi.python.org/pypi/Pydap PR: ports/181687 Submitted by: Johannes Meixner <xmj chaot.net>
Notes
Notes: svn path=/head/; revision=332132
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/py-pydap/Makefile24
-rw-r--r--science/py-pydap/distinfo2
-rw-r--r--science/py-pydap/files/patch-pavement.py11
-rw-r--r--science/py-pydap/pkg-descr8
5 files changed, 46 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index d67e96ee73fb..7c5b83aef953 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -157,6 +157,7 @@
SUBDIR += py-obspy
SUBDIR += py-paida
SUBDIR += py-pupynere
+ SUBDIR += py-pydap
SUBDIR += py-pydicom
SUBDIR += py-scikit-learn
SUBDIR += py-scimath
diff --git a/science/py-pydap/Makefile b/science/py-pydap/Makefile
new file mode 100644
index 000000000000..bb40c1141dce
--- /dev/null
+++ b/science/py-pydap/Makefile
@@ -0,0 +1,24 @@
+# Created by: Johannes Meixner <xmj@chaot.net>
+# $FreeBSD$
+
+PORTNAME= pydap
+PORTVERSION= 3.1
+CATEGORIES= science python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= Pydap-${PORTVERSION}
+
+MAINTAINER= xmj@chaot.net
+COMMENT= Implementation of the Opendap/DODS protocol
+
+LICENSE= MIT
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}distribute>=0:${PORTSDIR}/devel/py-distribute \
+ paver:${PORTSDIR}/devel/py-paver
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_AUTOPLIST= yes
+PYDISTUTILS_PKGNAME= Pydap
+
+.include <bsd.port.mk>
diff --git a/science/py-pydap/distinfo b/science/py-pydap/distinfo
new file mode 100644
index 000000000000..0af3c10f4373
--- /dev/null
+++ b/science/py-pydap/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Pydap-3.1.tar.gz) = 0e37ebb7755134689d34c7221a140b0b7fb8a76b213e3975e85fec3fe0c2d5f1
+SIZE (Pydap-3.1.tar.gz) = 3098212
diff --git a/science/py-pydap/files/patch-pavement.py b/science/py-pydap/files/patch-pavement.py
new file mode 100644
index 000000000000..abcd03e79c80
--- /dev/null
+++ b/science/py-pydap/files/patch-pavement.py
@@ -0,0 +1,11 @@
+--- ./pavement.py.orig 2013-08-30 15:00:07.469952201 +0300
++++ ./pavement.py 2013-08-30 15:00:24.309518177 +0300
+@@ -9,7 +9,7 @@
+ try:
+ from pydap.lib import __version__
+ except ImportError:
+- __version__ = ('unknown',)
++ __version__ = ('3.1',)
+
+ options = environment.options
+ setup(**setup_meta)
diff --git a/science/py-pydap/pkg-descr b/science/py-pydap/pkg-descr
new file mode 100644
index 000000000000..b34de7974240
--- /dev/null
+++ b/science/py-pydap/pkg-descr
@@ -0,0 +1,8 @@
+Pydap is an implementation of the Opendap/DODS protocol, written from scratch.
+You can use Pydap to access scientific data on the internet without having to
+download it; instead, you work with special array and iterable objects that
+download data on-the-fly as necessary, saving bandwidth and time. The module
+also comes with a robust-but-lightweight Opendap server, implemented as a WSGI
+application.
+
+WWW: https://pypi.python.org/pypi/Pydap