aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2010-02-16 05:51:43 +0000
committerMaho Nakata <maho@FreeBSD.org>2010-02-16 05:51:43 +0000
commit4c5f9cfbc3e8208c6904389d88131377879aa355 (patch)
tree806c76f56b3ae0c2dae2ab313fff6209d3647723 /science
parentcfb8e54b4d628559f0fa42535ca4128c71d07c09 (diff)
downloadports-4c5f9cfbc3e8208c6904389d88131377879aa355.tar.gz
ports-4c5f9cfbc3e8208c6904389d88131377879aa355.zip
Fix build with recent update of gotoblas(2).
Feature safe: yes
Notes
Notes: svn path=/head/; revision=249914
Diffstat (limited to 'science')
-rw-r--r--science/gamess/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/science/gamess/Makefile b/science/gamess/Makefile
index e0de4eda7577..f08eec449944 100644
--- a/science/gamess/Makefile
+++ b/science/gamess/Makefile
@@ -34,7 +34,7 @@ MANUAL_PACKAGE_BUILD=You must manually get the source distribution from master s
USE_BLAS?= reference
-.if exists(${LOCALBASE}/lib/libgoto.so)
+.if exists(${LOCALBASE}/lib/libgoto2.so)
USE_BLAS= gotoblas
.elif exists(${LOCALBASE}/lib/libatlas_r.so)
USE_BLAS= atlas
@@ -46,10 +46,9 @@ LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
BLAS= -lblas
LAPACK= -llapack
.elif ${USE_BLAS} == gotoblas
-LIB_DEPENDS+= goto:${PORTSDIR}/math/gotoblas
-LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
-BLAS= -lgotop
-LAPACK= -lgotop -llapack
+LIB_DEPENDS+= goto2:${PORTSDIR}/math/gotoblas
+BLAS= -lgoto2p
+LAPACK= -lgoto2p
.elif ${USE_BLAS} == atlas
LIB_DEPENDS+= atlas:${PORTSDIR}/math/atlas
BLAS= -lptf77blas -lptcblas -latlas_r