aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-06-22 01:15:19 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-06-22 01:15:19 +0000
commit4cb19e7f8736e7bc55f9efa09ac868abbe116836 (patch)
tree0c07443b478fb33416592bf0cae1d18b5907dd27 /science
parent145e894e6883a8b63b5589242af55a01e36236d4 (diff)
downloadports-4cb19e7f8736e7bc55f9efa09ac868abbe116836.tar.gz
ports-4cb19e7f8736e7bc55f9efa09ac868abbe116836.zip
Mark these ports as broken on aarch64, and, where appropriate, on armvX.
While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=473012
Diffstat (limited to 'science')
-rw-r--r--science/mpqc/Makefile2
-rw-r--r--science/py-dlib/Makefile4
2 files changed, 6 insertions, 0 deletions
diff --git a/science/mpqc/Makefile b/science/mpqc/Makefile
index cf0b995531dc..842cca794463 100644
--- a/science/mpqc/Makefile
+++ b/science/mpqc/Makefile
@@ -10,6 +10,8 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Massively Parallel Quantum Chemistry Program
+BROKEN_aarch64= fails to compile: lapack.h:2:10: 'chemistry/qc/mbptr12/f77sym.h' file not found
+
LIB_DEPENDS= libint.so:science/libint
GNU_CONFIGURE= yes
diff --git a/science/py-dlib/Makefile b/science/py-dlib/Makefile
index 3e2ee49cb3b7..9065966acd24 100644
--- a/science/py-dlib/Makefile
+++ b/science/py-dlib/Makefile
@@ -12,6 +12,10 @@ COMMENT= Machine learning framework written in C++ (python bindings)
LICENSE= BSL
LICENSE_FILE= ${WRKSRC}/dlib/LICENSE.txt
+BROKEN_aarch64= fails to build: CMake Error at test_for_avx/CMakeLists.txt:17 (if): if given arguments: "EQUAL" "0" "AND" "compile_result": Unknown arguments specified
+BROKEN_armv6= fails to build: CMake Error at test_for_avx/CMakeLists.txt:17 (if): if given arguments: "EQUAL" "0" "AND" "compile_result": Unknown arguments specified
+BROKEN_armv7= fails to build: CMake Error at test_for_avx/CMakeLists.txt:17 (if): if given arguments: "EQUAL" "0" "AND" "compile_result": Unknown arguments specified
+
BUILD_DEPENDS= cmake:devel/cmake
LIB_DEPENDS= ${PY_BOOST}