aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-06-16 00:37:35 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-06-16 00:37:35 +0000
commit53cdab2eb4db804ef4a555ba5ba4e2068a4c9584 (patch)
tree4995632953bec1275a0cddee4c5e9e3c5e4fc0c1 /science
parent6a70d66ccf9aac0ad310c3b7dbadc9f434f32bc4 (diff)
downloadports-53cdab2eb4db804ef4a555ba5ba4e2068a4c9584.tar.gz
ports-53cdab2eb4db804ef4a555ba5ba4e2068a4c9584.zip
New port: science/py-abipy: Library for analyzing the results produced by ABINIT
Notes
Notes: svn path=/head/; revision=472505
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/py-abipy/Makefile36
-rw-r--r--science/py-abipy/distinfo3
-rw-r--r--science/py-abipy/pkg-descr9
4 files changed, 49 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index e26d02fd63f1..c45e28d6ea42 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -165,6 +165,7 @@
SUBDIR += py-MDAnalysis
SUBDIR += py-MDAnalysisTests
SUBDIR += py-OpenFermion
+ SUBDIR += py-abipy
SUBDIR += py-cdo
SUBDIR += py-coards
SUBDIR += py-dlib
diff --git a/science/py-abipy/Makefile b/science/py-abipy/Makefile
new file mode 100644
index 000000000000..2a413a86a630
--- /dev/null
+++ b/science/py-abipy/Makefile
@@ -0,0 +1,36 @@
+# $FreeBSD$
+
+PORTNAME= abipy
+DISTVERSION= 0.5.0
+CATEGORIES= science python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Library for analyzing the results produced by ABINIT
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}apscheduler>=2.1.0:devel/py-apscheduler@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}html2text>0:textproc/py-html2text@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>0:math/py-matplotlib@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}netCDF4>0:science/py-netCDF4@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pandas>0:math/py-pandas@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}prettytable>0:devel/py-prettytable@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pydispatcher>=2.0.5:devel/py-pydispatcher@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pymatgen>=2018.6.11:science/py-pymatgen@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}seaborn>0:math/py-seaborn@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}spglib>0:science/py-spglib@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tabulate>0:devel/py-tabulate@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tqdm>0:misc/py-tqdm@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yaml>=3.11:devel/py-yaml@${FLAVOR}
+
+USES= python shebangfix
+USE_GITHUB= yes
+GH_ACCOUNT= abinit
+SHEBANG_GLOB= *.py
+USE_PYTHON= distutils concurrent autoplist
+
+.include <bsd.port.mk>
diff --git a/science/py-abipy/distinfo b/science/py-abipy/distinfo
new file mode 100644
index 000000000000..0924b6eb3d4c
--- /dev/null
+++ b/science/py-abipy/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1529082784
+SHA256 (abinit-abipy-0.5.0_GH0.tar.gz) = 4566f1330e484cb7a552f41a9ca73720d80c408361c5df31e8deec934ff7f17a
+SIZE (abinit-abipy-0.5.0_GH0.tar.gz) = 15845254
diff --git a/science/py-abipy/pkg-descr b/science/py-abipy/pkg-descr
new file mode 100644
index 000000000000..b60011b7d472
--- /dev/null
+++ b/science/py-abipy/pkg-descr
@@ -0,0 +1,9 @@
+AbiPy is a Python library to analyze the results produced by ABINIT, an
+open-source program for the ab-initio calculations of the physical properties
+of materials within Density Functional Theory and Many-Body perturbation theory.
+AbiPy also provides tools to generate input files and workflows to automate
+ab-initio calculations and typical convergence studies. AbiPy is interfaced with
+Pymatgen allowing users to benefit from the different tools and python objects
+available in the pymatgen ecosystem.
+
+WWW: https://pythonhosted.org/abipy/