aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-07-21 22:40:43 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-07-21 22:41:57 +0000
commit5d5af2d3df6974680062029173b8e54884420f0c (patch)
tree423d468b26a17b3dc1121ae7a2402db0c15387c8 /science
parent2e9291f27e6cd7f6442a90392e71176fc3ced0b8 (diff)
downloadports-5d5af2d3df6974680062029173b8e54884420f0c.tar.gz
ports-5d5af2d3df6974680062029173b8e54884420f0c.zip
science/kplib: Remove -march=native to fix build on some architectures
Reported by: fallout (cherry picked from commit d5465238b2e5d217a614d348d8ad37e2c0b4eac7)
Diffstat (limited to 'science')
-rw-r--r--science/kplib/files/patch-CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/science/kplib/files/patch-CMakeLists.txt b/science/kplib/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..99cbeca9ee61
--- /dev/null
+++ b/science/kplib/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2022-07-21 22:39:52 UTC
++++ CMakeLists.txt
+@@ -4,7 +4,7 @@ project(kplib)
+
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wall -Werror -fPIC")
+ set(CMAKE_CXX_FLAGS_DEBUG "-O0 -g") # Debug mode.
+-set(CMAKE_CXX_FLAGS_RELEASE "-O3 -march=native") # Default optimization.
++set(CMAKE_CXX_FLAGS_RELEASE "-O3") # Default optimization.
+ if(NOT CMAKE_BUILD_TYPE)
+ set(CMAKE_BUILD_TYPE Release)
+ endif(NOT CMAKE_BUILD_TYPE)