aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2019-04-24 19:35:06 +0000
committerThierry Thomas <thierry@FreeBSD.org>2019-04-24 19:35:06 +0000
commit77c8d5230f81b567a83c32dd5c3d5d39b327790f (patch)
tree2873e75d3650964fc044ad67ff580acce8f594e6 /science
parent88a9eed5e9f168418cb8bc8bf4c7478449f477c1 (diff)
downloadports-77c8d5230f81b567a83c32dd5c3d5d39b327790f.tar.gz
ports-77c8d5230f81b567a83c32dd5c3d5d39b327790f.zip
Fix on head by setting LLD_UNSAFE:
ld: error: /usr/lib/libpmc.so: undefined reference to std::__1::__basic_string_common<true>::__throw_length_error() const ld: error: /usr/lib/libpmc.so: undefined reference to std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char> >::append(char const*, unsigned long) cc: error: linker command failed with exit code 1 (use -v to see invocation) Since I'm here, add USES=gl.
Notes
Notes: svn path=/head/; revision=499899
Diffstat (limited to 'science')
-rw-r--r--science/medit/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/science/medit/Makefile b/science/medit/Makefile
index ccbdbbd3e588..47861d04abd7 100644
--- a/science/medit/Makefile
+++ b/science/medit/Makefile
@@ -21,12 +21,13 @@ BUILD_DEPENDS= ${LOCALBASE}/include/cfortran.h:lang/cfortran
USE_XORG= x11 xmu xext
USE_GL= glut
-USES= gmake tar:tgz
+USES= gl gmake tar:tgz
MAKEFILE= makefile
ALL_TARGET= ${OPSYS}
MAKE_ENV= WRKSRC="${WRKSRC}" ARCHI=${OPSYS} ARCH=${ARCH} OSREL=${OSREL}
NO_WRKSUBDIR= yes
MAKE_JOBS_UNSAFE= yes
+LLD_UNSAFE= yes
LIBVERSION= ${PORTVERSION}
SOURCETARB= ${PORTNAME}.${PORTVERSION}${EXTRACT_SUFX}