aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-08-25 20:06:37 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-08-25 20:28:24 +0000
commit7890177363343a64e52af7a50dc9366d8eb837a0 (patch)
tree39029007bf01d508d94df8b00a5a481d690976cd /science
parentcc5fdc14d94309a7dbae28f96689202781c1e299 (diff)
downloadports-7890177363343a64e52af7a50dc9366d8eb837a0.tar.gz
ports-7890177363343a64e52af7a50dc9366d8eb837a0.zip
science/siconos: Add test target (currently broken)
Diffstat (limited to 'science')
-rw-r--r--science/siconos/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/science/siconos/Makefile b/science/siconos/Makefile
index 93c6ec53b009..86658b453d59 100644
--- a/science/siconos/Makefile
+++ b/science/siconos/Makefile
@@ -18,12 +18,14 @@ LIB_DEPENDS= libcxsparse.so:math/suitesparse-cxsparse \
libgmp.so:math/gmp \
libldl.so:math/suitesparse-ldl \
libopenblas.so:math/openblas
+TEST_DEPENDS= cppunit>0:devel/cppunit
-USES= cmake compiler:c++17-lang fortran pkgconfig
+USES= cmake:testing compiler:c++17-lang fortran pkgconfig
USE_GITHUB= yes
USE_LDCONFIG= yes
CMAKE_ARGS= -DFREEBSD_PYTHON_VER=${PYTHON_VER}
+CMAKE_TESTING_ON= WITH_TESTING # tests are broken, see https://github.com/siconos/siconos/issues/415
CFLAGS+= -DCLOCKTIME -DCLOCKS_PER_SEC=128 # workaround for 'Undefined symbol "ftime"', see https://github.com/siconos/siconos/issues/411