aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-12-29 08:50:40 +0000
committerWen Heping <wen@FreeBSD.org>2010-12-29 08:50:40 +0000
commit7aaaa71110ab9fdfdcd1d8c1573aac9f02523368 (patch)
treed23302ae5cb557901b76a3cc93231a8cbb69c3b6 /science
parent355c12589c7b41ae814cc3c4bf5860301798ecdf (diff)
downloadports-7aaaa71110ab9fdfdcd1d8c1573aac9f02523368.tar.gz
ports-7aaaa71110ab9fdfdcd1d8c1573aac9f02523368.zip
Geo::Coordinates::Converter is a simple converter of geo coordinates, the
format and datum of geo coordinates are simply converted. when it is insufficient in the coordinate system and the format of the standard, it is possible to add it easily. WWW: http://search.cpan.org/dist/Geo-Coordinates-Converter/
Notes
Notes: svn path=/head/; revision=267121
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/p5-Geo-Coordinates-Converter/Makefile31
-rw-r--r--science/p5-Geo-Coordinates-Converter/distinfo2
-rw-r--r--science/p5-Geo-Coordinates-Converter/pkg-descr6
-rw-r--r--science/p5-Geo-Coordinates-Converter/pkg-plist21
5 files changed, 61 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 9bf16afb2938..121bc7feeedf 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -130,6 +130,7 @@
SUBDIR += p5-Chemistry-Pattern
SUBDIR += p5-Chemistry-Reaction
SUBDIR += p5-Chemistry-Ring
+ SUBDIR += p5-Geo-Coordinates-Converter
SUBDIR += p5-Geo-ReadGRIB
SUBDIR += p5-Geo-WebService-Elevation-USGS
SUBDIR += p5-PerlMol
diff --git a/science/p5-Geo-Coordinates-Converter/Makefile b/science/p5-Geo-Coordinates-Converter/Makefile
new file mode 100644
index 000000000000..0935a46a6a53
--- /dev/null
+++ b/science/p5-Geo-Coordinates-Converter/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Geo-Coordinates-Converter
+# Date created: Dec 29, 2010
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Geo-Coordinates-Converter
+PORTVERSION= 0.06
+CATEGORIES= science geography perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/Y/YA/YAPPO
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Simple converter of geo coordinates
+
+BUILD_DEPENDS= p5-Class-Accessor>0:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-Readonly>0:${PORTSDIR}/devel/p5-Readonly \
+ p5-String-CamelCase>0:${PORTSDIR}/textproc/p5-String-CamelCase \
+ p5-UNIVERSAL-require>0:${PORTSDIR}/devel/p5-UNIVERSAL-require
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Geo::Coordinates::Converter::Datum.3 \
+ Geo::Coordinates::Converter.3 \
+ Geo::Coordinates::Converter::Point.3 \
+ Geo::Coordinates::Converter::Format.3
+
+.include <bsd.port.mk>
diff --git a/science/p5-Geo-Coordinates-Converter/distinfo b/science/p5-Geo-Coordinates-Converter/distinfo
new file mode 100644
index 000000000000..b90615468b44
--- /dev/null
+++ b/science/p5-Geo-Coordinates-Converter/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Geo-Coordinates-Converter-0.06.tar.gz) = 67da6cbedbcad505427f6d241a4bcc8f83160c8a7a532774c504b3b80225d984
+SIZE (Geo-Coordinates-Converter-0.06.tar.gz) = 53848
diff --git a/science/p5-Geo-Coordinates-Converter/pkg-descr b/science/p5-Geo-Coordinates-Converter/pkg-descr
new file mode 100644
index 000000000000..8b39d30e7a5b
--- /dev/null
+++ b/science/p5-Geo-Coordinates-Converter/pkg-descr
@@ -0,0 +1,6 @@
+Geo::Coordinates::Converter is a simple converter of geo coordinates, the
+format and datum of geo coordinates are simply converted. when it is
+insufficient in the coordinate system and the format of the standard, it
+is possible to add it easily.
+
+WWW: http://search.cpan.org/dist/Geo-Coordinates-Converter/
diff --git a/science/p5-Geo-Coordinates-Converter/pkg-plist b/science/p5-Geo-Coordinates-Converter/pkg-plist
new file mode 100644
index 000000000000..844e351175f7
--- /dev/null
+++ b/science/p5-Geo-Coordinates-Converter/pkg-plist
@@ -0,0 +1,21 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Coordinates/Converter/.packlist
+%%SITE_PERL%%/Geo/Coordinates/Converter/Datum/Wgs84.pm
+%%SITE_PERL%%/Geo/Coordinates/Converter/Datum/Tokyo.pm
+%%SITE_PERL%%/Geo/Coordinates/Converter/Datum/Grs67.pm
+%%SITE_PERL%%/Geo/Coordinates/Converter/Datum/Jgd2000.pm
+%%SITE_PERL%%/Geo/Coordinates/Converter/Datum/Grs80.pm
+%%SITE_PERL%%/Geo/Coordinates/Converter/Datum/Wgs72.pm
+%%SITE_PERL%%/Geo/Coordinates/Converter/Format/Dms.pm
+%%SITE_PERL%%/Geo/Coordinates/Converter/Format/Degree.pm
+%%SITE_PERL%%/Geo/Coordinates/Converter/Point.pm
+%%SITE_PERL%%/Geo/Coordinates/Converter/Datum.pm
+%%SITE_PERL%%/Geo/Coordinates/Converter/Format.pm
+%%SITE_PERL%%/Geo/Coordinates/Converter.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Coordinates/Converter
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Coordinates
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo
+@dirrm %%SITE_PERL%%/Geo/Coordinates/Converter/Datum
+@dirrm %%SITE_PERL%%/Geo/Coordinates/Converter/Format
+@dirrmtry %%SITE_PERL%%/Geo/Coordinates/Converter
+@dirrmtry %%SITE_PERL%%/Geo/Coordinates
+@dirrmtry %%SITE_PERL%%/Geo