aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-07-23 20:24:58 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-07-23 20:26:08 +0000
commit7c6753bb87e10384f87a36b9a59820ba519bdafd (patch)
tree692cfcc1b31976f45c53ac7f255d0f2b07918014 /science
parent45d270dc854f49f149b2b109db9eb30bc76e3819 (diff)
downloadports-7c6753bb87e10384f87a36b9a59820ba519bdafd.tar.gz
ports-7c6753bb87e10384f87a36b9a59820ba519bdafd.zip
science/kplib: Remove -march=native to fix build on some architectures
Reported by: fallout (cherry picked from commit 9da256a46aa0dd84a5605dcc4defcbbe4b855548)
Diffstat (limited to 'science')
-rw-r--r--science/kplib/files/patch-demo__kplib_CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/science/kplib/files/patch-demo__kplib_CMakeLists.txt b/science/kplib/files/patch-demo__kplib_CMakeLists.txt
new file mode 100644
index 000000000000..f36f906feb5b
--- /dev/null
+++ b/science/kplib/files/patch-demo__kplib_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- demo_kplib/CMakeLists.txt.orig 2022-07-23 20:23:38 UTC
++++ demo_kplib/CMakeLists.txt
+@@ -3,7 +3,7 @@ project(demo_kplib)
+
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wall -Werror -fPIC")
+ set(CMAKE_CXX_FLAGS_DEBUG "-O0 -g") # Debug mode.
+-set(CMAKE_CXX_FLAGS_RELEASE "-O3 -march=native") # Default optimization.
++set(CMAKE_CXX_FLAGS_RELEASE "-O3") # Default optimization.
+
+ if(NOT CMAKE_BUILD_TYPE)
+ set(CMAKE_BUILD_TYPE Release)