aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-04-02 15:36:26 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-04-02 15:36:26 +0000
commit83e3ba00ba042aa1a47da802e2113e97ef18b850 (patch)
tree11fc30647272349fac6a0c98005921a84e8c9606 /science
parenta6af1d634fea23d1f0cdef58f7510437e7108c6a (diff)
downloadports-83e3ba00ba042aa1a47da802e2113e97ef18b850.tar.gz
ports-83e3ba00ba042aa1a47da802e2113e97ef18b850.zip
Perl modules for molecular chemistry
WWW: http://search.cpan.org/dist/PerlMol/ PR: ports/145143 Submitted by: Steve Wills <steve at mouf.net>
Notes
Notes: svn path=/head/; revision=252060
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/p5-PerlMol/Makefile69
-rw-r--r--science/p5-PerlMol/distinfo3
-rw-r--r--science/p5-PerlMol/files/patch-Makefile.PL37
-rw-r--r--science/p5-PerlMol/pkg-descr3
-rw-r--r--science/p5-PerlMol/pkg-plist3
6 files changed, 116 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 3c80f50a905b..4ac63bed6de9 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -126,6 +126,7 @@
SUBDIR += p5-Chemistry-Ring
SUBDIR += p5-Geo-ReadGRIB
SUBDIR += p5-Geo-WebService-Elevation-USGS
+ SUBDIR += p5-PerlMol
SUBDIR += paje
SUBDIR += paraview
SUBDIR += pcp
diff --git a/science/p5-PerlMol/Makefile b/science/p5-PerlMol/Makefile
new file mode 100644
index 000000000000..1e5216b366b6
--- /dev/null
+++ b/science/p5-PerlMol/Makefile
@@ -0,0 +1,69 @@
+# New ports collection makefile for: p5-PerlMol
+# Date created: 2010-03-04
+# Whom: Steve Wills <steve@mouf.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= PerlMol
+PORTVERSION= 0.3500
+CATEGORIES= science perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/I/IT/ITUB
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= steve@mouf.net
+COMMENT= Perl modules for molecular chemistry
+
+BUILD_DEPENDS= ${SITE_PERL}/Chemistry/Mol.pm:${PORTSDIR}/science/p5-Chemistry-Mol \
+ ${SITE_PERL}/Chemistry/MacroMol.pm:${PORTSDIR}/science/p5-Chemistry-MacroMol \
+ ${SITE_PERL}/Parse/Yapp/Parse.pm:${PORTSDIR}/devel/p5-Parse-Yapp \
+ ${SITE_PERL}/Chemistry/File/SMILES.pm:${PORTSDIR}/science/p5-Chemistry-File-SMILES \
+ ${SITE_PERL}/Chemistry/File/SMARTS.pm:${PORTSDIR}/science/p5-Chemistry-File-SMARTS \
+ ${SITE_PERL}/Chemistry/InternalCoords.pm:${PORTSDIR}/science/p5-Chemistry-InternalCoords \
+ ${SITE_PERL}/Chemistry/Pattern.pm:${PORTSDIR}/science/p5-Chemistry-Pattern \
+ ${SITE_PERL}/Chemistry/Ring.pm:${PORTSDIR}/science/p5-Chemistry-Ring \
+ ${SITE_PERL}/Chemistry/Isotope.pm:${PORTSDIR}/science/p5-Chemistry-Isotope \
+ ${SITE_PERL}/Chemistry/3DBuilder.pm:${PORTSDIR}/science/p5-Chemistry-3DBuilder \
+ ${SITE_PERL}/Chemistry/Bond/Find.pm:${PORTSDIR}/science/p5-Chemistry-Bond-Find \
+ ${SITE_PERL}/Chemistry/Canonicalize.pm:${PORTSDIR}/science/p5-Chemistry-Canonicalize \
+ ${SITE_PERL}/Chemistry/File/PDB.pm:${PORTSDIR}/science/p5-Chemistry-File-PDB \
+ ${SITE_PERL}/Chemistry/File/XYZ.pm:${PORTSDIR}/science/p5-Chemistry-File-XYZ \
+ ${SITE_PERL}/Chemistry/File/VRML.pm:${PORTSDIR}/science/p5-Chemistry-File-VRML \
+ ${SITE_PERL}/Chemistry/File/SLN.pm:${PORTSDIR}/science/p5-Chemistry-File-SLN \
+ ${SITE_PERL}/Chemistry/File/Mopac.pm:${PORTSDIR}/science/p5-Chemistry-File-Mopac \
+ ${SITE_PERL}/Chemistry/File/MDLMol.pm:${PORTSDIR}/science/p5-Chemistry-File-MDLMol \
+ ${SITE_PERL}/Chemistry/Reaction.pm:${PORTSDIR}/science/p5-Chemistry-Reaction \
+ ${SITE_PERL}/Chemistry/FormulaPattern.pm:${PORTSDIR}/science/p5-Chemistry-FormulaPattern \
+ ${SITE_PERL}/Chemistry/MidasPattern.pm:${PORTSDIR}/science/p5-Chemistry-MidasPattern \
+ ${SITE_PERL}/Chemistry/Mok.pm:${PORTSDIR}/science/p5-Chemistry-Mok \
+ ${SITE_PERL}/Statistics/Regression.pm:${PORTSDIR}/math/p5-Statistics-Regression
+BUILD_DEPENDS= ${SITE_PERL}/Chemistry/Mol.pm:${PORTSDIR}/science/p5-Chemistry-Mol \
+ ${SITE_PERL}/Chemistry/MacroMol.pm:${PORTSDIR}/science/p5-Chemistry-MacroMol \
+ ${SITE_PERL}/Parse/Yapp/Parse.pm:${PORTSDIR}/devel/p5-Parse-Yapp \
+ ${SITE_PERL}/Chemistry/File/SMILES.pm:${PORTSDIR}/science/p5-Chemistry-File-SMILES \
+ ${SITE_PERL}/Chemistry/File/SMARTS.pm:${PORTSDIR}/science/p5-Chemistry-File-SMARTS \
+ ${SITE_PERL}/Chemistry/InternalCoords.pm:${PORTSDIR}/science/p5-Chemistry-InternalCoords \
+ ${SITE_PERL}/Chemistry/Pattern.pm:${PORTSDIR}/science/p5-Chemistry-Pattern \
+ ${SITE_PERL}/Chemistry/Ring.pm:${PORTSDIR}/science/p5-Chemistry-Ring \
+ ${SITE_PERL}/Chemistry/Isotope.pm:${PORTSDIR}/science/p5-Chemistry-Isotope \
+ ${SITE_PERL}/Chemistry/3DBuilder.pm:${PORTSDIR}/science/p5-Chemistry-3DBuilder \
+ ${SITE_PERL}/Chemistry/Bond/Find.pm:${PORTSDIR}/science/p5-Chemistry-Bond-Find \
+ ${SITE_PERL}/Chemistry/Canonicalize.pm:${PORTSDIR}/science/p5-Chemistry-Canonicalize \
+ ${SITE_PERL}/Chemistry/File/PDB.pm:${PORTSDIR}/science/p5-Chemistry-File-PDB \
+ ${SITE_PERL}/Chemistry/File/XYZ.pm:${PORTSDIR}/science/p5-Chemistry-File-XYZ \
+ ${SITE_PERL}/Chemistry/File/VRML.pm:${PORTSDIR}/science/p5-Chemistry-File-VRML \
+ ${SITE_PERL}/Chemistry/File/SLN.pm:${PORTSDIR}/science/p5-Chemistry-File-SLN \
+ ${SITE_PERL}/Chemistry/File/Mopac.pm:${PORTSDIR}/science/p5-Chemistry-File-Mopac \
+ ${SITE_PERL}/Chemistry/File/MDLMol.pm:${PORTSDIR}/science/p5-Chemistry-File-MDLMol \
+ ${SITE_PERL}/Chemistry/Reaction.pm:${PORTSDIR}/science/p5-Chemistry-Reaction \
+ ${SITE_PERL}/Chemistry/FormulaPattern.pm:${PORTSDIR}/science/p5-Chemistry-FormulaPattern \
+ ${SITE_PERL}/Chemistry/MidasPattern.pm:${PORTSDIR}/science/p5-Chemistry-MidasPattern \
+ ${SITE_PERL}/Chemistry/Mok.pm:${PORTSDIR}/science/p5-Chemistry-Mok \
+ ${SITE_PERL}/Statistics/Regression.pm:${PORTSDIR}/math/p5-Statistics-Regression
+
+PERL_CONFIGURE= yes
+
+MAN3= PerlMol.3
+
+.include <bsd.port.mk>
diff --git a/science/p5-PerlMol/distinfo b/science/p5-PerlMol/distinfo
new file mode 100644
index 000000000000..8dfcf3720933
--- /dev/null
+++ b/science/p5-PerlMol/distinfo
@@ -0,0 +1,3 @@
+MD5 (PerlMol-0.3500.tar.gz) = 0af1b556c09245772446577f4e6308ed
+SHA256 (PerlMol-0.3500.tar.gz) = a0795bc7f1ea30dff1559b03b74671910fbbce02601e8dda8ebee32186bd91a5
+SIZE (PerlMol-0.3500.tar.gz) = 337781
diff --git a/science/p5-PerlMol/files/patch-Makefile.PL b/science/p5-PerlMol/files/patch-Makefile.PL
new file mode 100644
index 000000000000..7bd72c04b2f5
--- /dev/null
+++ b/science/p5-PerlMol/files/patch-Makefile.PL
@@ -0,0 +1,37 @@
+--- Makefile.PL.orig 2010-03-11 02:51:47.000000000 -0500
++++ Makefile.PL 2010-03-11 02:52:00.000000000 -0500
+@@ -17,34 +17,6 @@
+ Text::Balanced 1.89
+ ));
+
+-bundle(qw(
+- Chemistry::File::VRML 0.10
+- Chemistry::3DBuilder 0.10
+- Chemistry::Mol 0.35
+- Chemistry::Mok 0.25
+- Chemistry::File::SMILES 0.44
+- Chemistry::File::SMARTS 0.22
+- Chemistry::File::PDB 0.21
+- Chemistry::Pattern 0.26
+- Chemistry::MidasPattern 0.11
+- Chemistry::File::MDLMol 0.20
+- Chemistry::InternalCoords 0.18
+- Chemistry::MacroMol 0.06
+- Chemistry::Ring 0.18
+- Chemistry::Canonicalize 0.10
+- Chemistry::Bond::Find 0.21
+- Chemistry::File::SLN 0.10
+- Chemistry::FormulaPattern 0.10
+- Chemistry::File::Mopac 0.15
+- Chemistry::File::XYZ 0.11
+- Chemistry::Isotope 0.11
+- Chemistry::Reaction 0.02
+- Math::VectorReal 1.00
+- Statistics::Regression 0.15
+- Parse::Yapp::Driver 1.05
+-
+-));
+-
+ check_nmake();
+
+ &WriteAll();
diff --git a/science/p5-PerlMol/pkg-descr b/science/p5-PerlMol/pkg-descr
new file mode 100644
index 000000000000..c80ab5453065
--- /dev/null
+++ b/science/p5-PerlMol/pkg-descr
@@ -0,0 +1,3 @@
+Perl modules for molecular chemistry
+
+WWW: http://search.cpan.org/dist/PerlMol/
diff --git a/science/p5-PerlMol/pkg-plist b/science/p5-PerlMol/pkg-plist
new file mode 100644
index 000000000000..28ab912610e4
--- /dev/null
+++ b/science/p5-PerlMol/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/mach/auto/PerlMol/.packlist
+%%SITE_PERL%%/PerlMol.pm
+@dirrmtry %%SITE_PERL%%/mach/auto/PerlMol