aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-06-18 02:34:02 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-06-18 02:34:02 +0000
commit9502930cb1866d3bd638b6fe23b4279e310163d6 (patch)
tree1d0a0657971afafbc7c9b39a5c6e24896f84f9df /science
parenta875dccebcac794a948177cd39e626259b5946ce (diff)
downloadports-9502930cb1866d3bd638b6fe23b4279e310163d6.tar.gz
ports-9502930cb1866d3bd638b6fe23b4279e310163d6.zip
New port: science/py-SimpleSpectral: Simplified scipy.signal.spectral module with only pyFFTW support
Notes
Notes: svn path=/head/; revision=472666
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/py-SimpleSpectral/Makefile21
-rw-r--r--science/py-SimpleSpectral/distinfo3
-rw-r--r--science/py-SimpleSpectral/pkg-descr13
4 files changed, 38 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index fa18a8ccf1af..f1336eb60505 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -167,6 +167,7 @@
SUBDIR += py-MDAnalysisTests
SUBDIR += py-OpenFermion
SUBDIR += py-PyQuante
+ SUBDIR += py-SimpleSpectral
SUBDIR += py-abipy
SUBDIR += py-cdo
SUBDIR += py-coards
diff --git a/science/py-SimpleSpectral/Makefile b/science/py-SimpleSpectral/Makefile
new file mode 100644
index 000000000000..9bd2066b19e0
--- /dev/null
+++ b/science/py-SimpleSpectral/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= SimpleSpectral
+DISTVERSION= 1.0.0
+CATEGORIES= science python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Simplified scipy.signal.spectral module with only pyFFTW support
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYNUMPY}
+
+USES= python:3.4+
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/science/py-SimpleSpectral/distinfo b/science/py-SimpleSpectral/distinfo
new file mode 100644
index 000000000000..9b6f2fd89684
--- /dev/null
+++ b/science/py-SimpleSpectral/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1529288885
+SHA256 (SimpleSpectral-1.0.0.tar.gz) = 869326949870faed82bf21890603569e5c834a8599be5d55c38cb3b41bef0362
+SIZE (SimpleSpectral-1.0.0.tar.gz) = 6116
diff --git a/science/py-SimpleSpectral/pkg-descr b/science/py-SimpleSpectral/pkg-descr
new file mode 100644
index 000000000000..f452bb7338ed
--- /dev/null
+++ b/science/py-SimpleSpectral/pkg-descr
@@ -0,0 +1,13 @@
+You can use scipy.signal tutorial and reference guide in most cases, but
+there are some important differences:
+* input data is assumed to be complex and two-sided spectrum is always returned
+ (return_onesided argument is not implemented)
+* length of FFT is always same as length of segment (nfft argument is not
+ implemented)
+* functions work always over last axis of array (axis argument is not
+ implemented)
+* if you want to have best FFT performance with pyFFTW, you should create arrays
+ with empty, zeros or ones functions from SimpleSpectral instead of generic
+ versions from NumPy (arrays will be byte aligned for your CPU)
+
+WWW: https://github.com/xmikos/simplespectral