aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-06-29 08:34:18 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-06-29 08:34:18 +0000
commit9674ab63a630baccffbad353337d7b95ea6a7cc6 (patch)
tree43e66c26e81d1aef2fe4e7103f75e3c349c4e0c9 /science
parentcd99f437e25aff39fc9098cafa83754f69de185c (diff)
downloadports-9674ab63a630baccffbad353337d7b95ea6a7cc6.tar.gz
ports-9674ab63a630baccffbad353337d7b95ea6a7cc6.zip
New port: science/py-ScientificPython: Various Python modules for scientific computing
Notes
Notes: svn path=/head/; revision=473533
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/py-ScientificPython/Makefile24
-rw-r--r--science/py-ScientificPython/distinfo3
-rw-r--r--science/py-ScientificPython/pkg-descr9
4 files changed, 37 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 562db2f4cd1b..b12b4061e09a 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -168,6 +168,7 @@
SUBDIR += py-MDAnalysisTests
SUBDIR += py-OpenFermion
SUBDIR += py-PyQuante
+ SUBDIR += py-ScientificPython
SUBDIR += py-SimpleSpectral
SUBDIR += py-abipy
SUBDIR += py-cdo
diff --git a/science/py-ScientificPython/Makefile b/science/py-ScientificPython/Makefile
new file mode 100644
index 000000000000..9eaffec6bdba
--- /dev/null
+++ b/science/py-ScientificPython/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= ScientificPython
+DISTVERSION= 2.9.4
+CATEGORIES= science python
+MASTER_SITES= https://sourcesup.renater.fr/frs/download.php/file/4570/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Various Python modules for scientific computing
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYNUMPY}
+LIB_DEPENDS= libnetcdf.so:science/netcdf
+RUN_DEPENDS= ${PYNUMPY}
+
+USES= python:2.7
+USE_PYTHON= distutils cython concurrent autoplist
+
+MAKE_ENV= COMPILE_CYTHON=1
+
+.include <bsd.port.mk>
diff --git a/science/py-ScientificPython/distinfo b/science/py-ScientificPython/distinfo
new file mode 100644
index 000000000000..d5768447845b
--- /dev/null
+++ b/science/py-ScientificPython/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1530259842
+SHA256 (ScientificPython-2.9.4.tar.gz) = c397fedf76500dc4c010785a82204a45ee51a04a54fabfb6142d594de14f8639
+SIZE (ScientificPython-2.9.4.tar.gz) = 688704
diff --git a/science/py-ScientificPython/pkg-descr b/science/py-ScientificPython/pkg-descr
new file mode 100644
index 000000000000..9fa4c33061cc
--- /dev/null
+++ b/science/py-ScientificPython/pkg-descr
@@ -0,0 +1,9 @@
+ScientificPython is a collection of Python modules that are useful for
+scientific computing. In this collection you will find modules that cover
+basic geometry (vectors, tensors, transformations, vector and tensor fields),
+quaternions, automatic derivatives, (linear) interpolation, polynomials,
+elementary statistics, nonlinear least-squares fits, unit calculations,
+Fortran-compatible text formatting, 3D visualization via VRML, and two Tk
+widgets for simple line plots and 3D wireframe models.
+
+WWW: https://pypi.org/project/ScientificPython/