aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-06-12 07:39:34 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-06-12 07:39:34 +0000
commitb5e2bb3b11c2c5815b54f8dda642f40c42584b39 (patch)
tree8370cc7e86a2cc727e42da2e437d185bf670ae28 /science
parent80b90892bead3d4c4d1cfeac64415eeee5772eab (diff)
downloadports-b5e2bb3b11c2c5815b54f8dda642f40c42584b39.tar.gz
ports-b5e2bb3b11c2c5815b54f8dda642f40c42584b39.zip
science/openbabel: Take maintainership; Add the GUI option using wxWidgets-3.0
GUI is "on" by default because that's what CMakeLists.txt suggests as default. Also improve helpers use.
Notes
Notes: svn path=/head/; revision=472233
Diffstat (limited to 'science')
-rw-r--r--science/openbabel/Makefile20
-rw-r--r--science/openbabel/pkg-descr2
-rw-r--r--science/openbabel/pkg-plist1
3 files changed, 14 insertions, 9 deletions
diff --git a/science/openbabel/Makefile b/science/openbabel/Makefile
index 1ad6002c358a..9933f74c4aed 100644
--- a/science/openbabel/Makefile
+++ b/science/openbabel/Makefile
@@ -3,11 +3,12 @@
PORTNAME= openbabel
PORTVERSION= 2.4.1
+PORTREVISION= 1
CATEGORIES= science
MASTER_SITES= SF
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Chemistry file translation program
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Chemical toolbox designed to speak the many languages of chemical data
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
@@ -16,24 +17,27 @@ BROKEN_powerpc64= Does not build: relocation truncated to fit: R_PPC64_TOC16_DS
CONFLICTS_INSTALL= babel-*
+USES= cmake:outsource eigen:3
USE_CXXSTD= gnu++98
USE_GNOME= libxml2
-USES= cmake:outsource eigen:3
-CMAKE_ARGS= -DBUILD_GUI=off
USE_LDCONFIG= yes
PLIST_SUB= VERSION="${PORTVERSION}"
-OPTIONS_DEFINE= CAIRO PYTHON
-OPTIONS_DEFAULT= PYTHON
+OPTIONS_DEFINE= CAIRO PYTHON GUI
+OPTIONS_DEFAULT= PYTHON GUI
OPTIONS_SUB= yes
CAIRO_DESC= PNG support via cairo library
-CAIRO_LIB_DEPENDS= libcairo.so:graphics/cairo
CAIRO_USES= pkgconfig
+CAIRO_USE= GNOME=cairo
PYTHON_USES= python
-PYTHON_CMAKE_ON= -DPYTHON_BINDINGS=on
+PYTHON_CMAKE_BOOL= PYTHON_BINDINGS
+
+GUI_CMAKE_BOOL= BUILD_GUI
+GUI_CMAKE_ON= -DwxWidgets_CONFIG_EXECUTABLE:STRING=${WX_CONFIG}
+GUI_USE= WX=3.0
post-patch:
${REINPLACE_CMD} -e '/pkgconfig/s,$${LIB_INSTALL_DIR},libdata,' \
diff --git a/science/openbabel/pkg-descr b/science/openbabel/pkg-descr
index 11a1956c6806..68e3acf3559d 100644
--- a/science/openbabel/pkg-descr
+++ b/science/openbabel/pkg-descr
@@ -16,4 +16,4 @@ Features currently include:
* Open-source/Free Software under the GNU General Public License
* Cross platform (Windows, Linux, Mac OS X, SGI, Solaris, Dreamcast...)
-WWW: http://openbabel.sourceforge.net/
+WWW: https://openbabel.org/wiki/Main_Page
diff --git a/science/openbabel/pkg-plist b/science/openbabel/pkg-plist
index 284689c5f9db..73374f17b471 100644
--- a/science/openbabel/pkg-plist
+++ b/science/openbabel/pkg-plist
@@ -7,6 +7,7 @@ bin/obenergy
bin/obfit
bin/obgen
bin/obgrep
+%%GUI%%bin/obgui
bin/obminimize
bin/obprobe
bin/obprop