aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-04-02 15:25:12 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-04-02 15:25:12 +0000
commitb9c5628b0dfc9ce9a87c582dcc17488585174029 (patch)
treeca3f46d9ebcb065756df304e2771aca0216c2297 /science
parent5fd8c153ed529eeafe9b06c4e13cfb4c13cb3f1a (diff)
downloadports-b9c5628b0dfc9ce9a87c582dcc17488585174029.tar.gz
ports-b9c5628b0dfc9ce9a87c582dcc17488585174029.zip
Perl module which provides functions for "canonicalizing" a molecular
structure; that is, to number the atoms in a unique way regardless of the input order. WWW: http://search.cpan.org/dist/Chemistry-Canonicalize/ PR: ports/145143 Submitted by: Steve Wills <steve at mouf.net>
Notes
Notes: svn path=/head/; revision=252043
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/p5-Chemistry-Canonicalize/Makefile25
-rw-r--r--science/p5-Chemistry-Canonicalize/distinfo3
-rw-r--r--science/p5-Chemistry-Canonicalize/pkg-descr5
-rw-r--r--science/p5-Chemistry-Canonicalize/pkg-plist4
5 files changed, 38 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 4d1916a8266f..44bd2c09c983 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -103,6 +103,7 @@
SUBDIR += ovt
SUBDIR += p5-Algorithm-SVMLight
SUBDIR += p5-Chemistry-Bond-Find
+ SUBDIR += p5-Chemistry-Canonicalize
SUBDIR += p5-Chemistry-Elements
SUBDIR += p5-Chemistry-File-PDB
SUBDIR += p5-Chemistry-MacroMol
diff --git a/science/p5-Chemistry-Canonicalize/Makefile b/science/p5-Chemistry-Canonicalize/Makefile
new file mode 100644
index 000000000000..53a4fad2807d
--- /dev/null
+++ b/science/p5-Chemistry-Canonicalize/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Chemistry-Canonicalize
+# Date created: 2010-03-10
+# Whom: Steve Wills <steve@mouf.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Chemistry-Canonicalize
+PORTVERSION= 0.11
+CATEGORIES= science perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/I/IT/ITUB
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= steve@mouf.net
+COMMENT= Number the atoms in a molecule in a unique way
+
+BUILD_DEPENDS= ${SITE_PERL}/Chemistry/Mol.pm:${PORTSDIR}/science/p5-Chemistry-Mol
+RUN_DEPENDS= ${SITE_PERL}/Chemistry/Mol.pm:${PORTSDIR}/science/p5-Chemistry-Mol
+
+MAN3= Chemistry::Canonicalize.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/science/p5-Chemistry-Canonicalize/distinfo b/science/p5-Chemistry-Canonicalize/distinfo
new file mode 100644
index 000000000000..9467e0833421
--- /dev/null
+++ b/science/p5-Chemistry-Canonicalize/distinfo
@@ -0,0 +1,3 @@
+MD5 (Chemistry-Canonicalize-0.11.tar.gz) = 760833add7e5bafde702faa3db3b7990
+SHA256 (Chemistry-Canonicalize-0.11.tar.gz) = 535d854eed040d4fe96c93bb78454b22a96436a761ab9ea799590a2d3462ad08
+SIZE (Chemistry-Canonicalize-0.11.tar.gz) = 4908
diff --git a/science/p5-Chemistry-Canonicalize/pkg-descr b/science/p5-Chemistry-Canonicalize/pkg-descr
new file mode 100644
index 000000000000..0b5592796627
--- /dev/null
+++ b/science/p5-Chemistry-Canonicalize/pkg-descr
@@ -0,0 +1,5 @@
+Perl module which provides functions for "canonicalizing" a molecular
+structure; that is, to number the atoms in a unique way regardless of the
+input order.
+
+WWW: http://search.cpan.org/dist/Chemistry-Canonicalize/
diff --git a/science/p5-Chemistry-Canonicalize/pkg-plist b/science/p5-Chemistry-Canonicalize/pkg-plist
new file mode 100644
index 000000000000..9295230575cf
--- /dev/null
+++ b/science/p5-Chemistry-Canonicalize/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/Chemistry/Canonicalize.pm
+%%SITE_PERL%%/mach/auto/Chemistry/Canonicalize/.packlist
+@dirrmtry %%SITE_PERL%%/mach/auto/Chemistry/Canonicalize
+@dirrmtry %%SITE_PERL%%/mach/auto/Chemistry