aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2022-04-27 13:22:20 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2022-04-27 13:22:20 +0000
commitccbaef928e39056825d63efcba5dc850f5154a18 (patch)
treec7c3c3a0562e6a5c811eac7865a9f89bcf35e754 /science
parent1dc59ad02cde480a1b5a0c5fd5f40e12f74ce747 (diff)
downloadports-ccbaef928e39056825d63efcba5dc850f5154a18.tar.gz
ports-ccbaef928e39056825d63efcba5dc850f5154a18.zip
science/nest: check for omp.h on all architectures
Diffstat (limited to 'science')
-rw-r--r--science/nest/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/science/nest/Makefile b/science/nest/Makefile
index 5c3f17e9cebf..13cc59729854 100644
--- a/science/nest/Makefile
+++ b/science/nest/Makefile
@@ -34,18 +34,16 @@ PYTHON_CMAKE_ON= -DFREEBSD_PYTHON_VER:STRING=${PYTHON_VER} -DCYTHON_EXECUTABLE:S
PORTDOCS= *
+.if !exists(/usr/include/omp.h)
+USES+= compiler:gcc-c++11-lib
+.else
+USES+= compiler:c++11-lang
+.endif
+
# 2 tests are known to fail, see https://github.com/nest/nest-simulator/issues/2190
# tests require the port to be installed with DOCS=ON, see https://github.com/nest/nest-simulator/issues/2191
post-install:
@${REINPLACE_CMD} -i '' -e 's|^python3 |${PYTHON_CMD} |' ${STAGEDIR}${PREFIX}/share/nest/testsuite/do_tests.sh
-.include <bsd.port.options.mk>
-
-.if ${ARCH} == powerpc
-USES+= compiler:gcc-c++11-lib
-.else
-USES+= compiler:c++11-lang
-.endif
-
.include <bsd.port.mk>