aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorFelix Palmen <zirias@FreeBSD.org>2022-09-11 10:20:14 +0000
committerFelix Palmen <zirias@FreeBSD.org>2022-09-11 10:20:14 +0000
commitddae4e92d8313a1461145e3b4f0232fe463feaee (patch)
treee84ab3fcfdf00dbf560f8ef9ae031d0c2ed252f5 /science
parent51a360b7fe98be99d21134e5fe624ba12d596dd9 (diff)
downloadports-ddae4e92d8313a1461145e3b4f0232fe463feaee.tar.gz
ports-ddae4e92d8313a1461145e3b4f0232fe463feaee.zip
Mk/Uses: always use colon for build/run suffix
Most USES use a colon for build/run(/test) suffixes. Change kde.mk, qt.mk and pyqt.mk to do the same, and update all ports using that. Document in CHANGES. PR: 266034 Exp-run by: antoine Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D36349
Diffstat (limited to 'science')
-rw-r--r--science/avogadro2/Makefile2
-rw-r--r--science/avogadrolibs/Makefile2
-rw-r--r--science/elmerfem/Makefile4
-rw-r--r--science/iboview/Makefile2
-rw-r--r--science/kalzium/Makefile4
-rw-r--r--science/kst2/Makefile2
-rw-r--r--science/liggghts/Makefile2
-rw-r--r--science/massxpert/Makefile4
-rw-r--r--science/molsketch/Makefile2
-rw-r--r--science/paraview/Makefile2
-rw-r--r--science/pulseview/Makefile2
-rw-r--r--science/py-pymol/Makefile2
-rw-r--r--science/py-veusz/Makefile2
-rw-r--r--science/scidavis/Makefile2
-rw-r--r--science/shelxle/Makefile2
-rw-r--r--science/step/Makefile4
-rw-r--r--science/vipster/Makefile2
-rw-r--r--science/xdrawchem/Makefile2
18 files changed, 22 insertions, 22 deletions
diff --git a/science/avogadro2/Makefile b/science/avogadro2/Makefile
index bedc48281854..59499185dd91 100644
--- a/science/avogadro2/Makefile
+++ b/science/avogadro2/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libAvogadroCore.so:science/avogadrolibs \
libMoleQueueClient.so:misc/molequeue
USES= cmake compiler:c++11-lang desktop-file-utils gl libarchive qt:5
-USE_QT= core concurrent gui network widgets buildtools_build qmake_build
+USE_QT= core concurrent gui network widgets buildtools:build qmake:build
USE_GL= gl glew glu
USE_LDCONFIG= yes
diff --git a/science/avogadrolibs/Makefile b/science/avogadrolibs/Makefile
index 9ad02d76245c..582ad40e44c9 100644
--- a/science/avogadrolibs/Makefile
+++ b/science/avogadrolibs/Makefile
@@ -51,7 +51,7 @@ OPENGL_USE= GL=gl,glew,glu
QT5_CMAKE_BOOL= USE_QT
QT5_USES= qt:5
-QT5_USE= QT=core,concurrent,gui,network,svg,widgets,buildtools_build,qmake_build
+QT5_USE= QT=core,concurrent,gui,network,svg,widgets,buildtools:build,qmake:build
QT5_IMPLIES= OPENGL
SPGLIB_DESC= Enable optional features using spglib
diff --git a/science/elmerfem/Makefile b/science/elmerfem/Makefile
index e28d39ab3582..30a7b9adef4a 100644
--- a/science/elmerfem/Makefile
+++ b/science/elmerfem/Makefile
@@ -69,8 +69,8 @@ OCC_CMAKE_ON= -DVTK_DIR=${LOCALBASE}/lib/cmake/vtk-9.0 \
_LIBSTAGEDIR= ${STAGEDIR}/${PREFIX}/lib/elmersolver
_PYVERSION= ${PYTHON_VER}${PYTHON_ABIVER}
-_QT5_LIBS= buildtools_build concurrent core declarative gui location \
- network opengl printsupport qmake_build script sensors \
+_QT5_LIBS= buildtools:build concurrent core declarative gui location \
+ network opengl printsupport qmake:build script sensors \
sql svg webchannel webkit widgets xml
.include <bsd.port.pre.mk>
diff --git a/science/iboview/Makefile b/science/iboview/Makefile
index ef39b8c58428..766a460f6ebd 100644
--- a/science/iboview/Makefile
+++ b/science/iboview/Makefile
@@ -19,7 +19,7 @@ ONLY_FOR_ARCHS= amd64
USES= blaslapack:openblas fortran gl qmake:outsource qt:5 tar:bz2
USE_GL= gl glu
-USE_QT= buildtools_build core gui widgets opengl script svg
+USE_QT= buildtools:build core gui widgets opengl script svg
PLIST_FILES= bin/iboview
diff --git a/science/kalzium/Makefile b/science/kalzium/Makefile
index c8c86f84505d..3b6ee7652626 100644
--- a/science/kalzium/Makefile
+++ b/science/kalzium/Makefile
@@ -24,12 +24,12 @@ USE_KDE= auth archive attica bookmarks codecs completion config configwidgets \
khtml kio newstuff notifications parts plotting service solid \
sonnet textwidgets unitconversion widgetsaddons windowsystem \
xmlgui \
- ecm_build
+ ecm:build
USE_OCAML= yes
NO_OCAML_RUNDEPENDS= yes
USE_QT= concurrent core dbus declarative gui network opengl printsupport script svg \
widgets xml \
- buildtools_build qmake_build
+ buildtools:build qmake:build
USE_XORG= x11
USE_LDCONFIG= yes
diff --git a/science/kst2/Makefile b/science/kst2/Makefile
index 70391638d64e..2074f7dc4790 100644
--- a/science/kst2/Makefile
+++ b/science/kst2/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libgsl.so:math/gsl \
USES= cmake compiler:c++11-lang desktop-file-utils kde:5 pkgconfig \
qt:5 shared-mime-info
USE_QT= concurrent core gui network printsupport svg widgets xml \
- buildtools_build linguisttools_build qmake_build
+ buildtools:build linguisttools:build qmake:build
USE_LDCONFIG= yes
KST_VERSION= 2.0.8
diff --git a/science/liggghts/Makefile b/science/liggghts/Makefile
index 0804f65620a0..f82dddcb90a7 100644
--- a/science/liggghts/Makefile
+++ b/science/liggghts/Makefile
@@ -23,7 +23,7 @@ LIB_DEPENDS= libexpat.so:textproc/expat2 \
USES= compiler:c++17-lang cmake fortran gl jpeg python qt:5 xorg
USE_XORG= ice sm x11 xext xt
-USE_QT= core declarative gui network opengl sql widgets qmake_build buildtools_build
+USE_QT= core declarative gui network opengl sql widgets qmake:build buildtools:build
USE_GL= gl
USE_LDCONFIG= yes
diff --git a/science/massxpert/Makefile b/science/massxpert/Makefile
index 695c763c27fe..caadb75a9cea 100644
--- a/science/massxpert/Makefile
+++ b/science/massxpert/Makefile
@@ -21,8 +21,8 @@ GL_SITE= https://salsa.debian.org/
GL_ACCOUNT= debichem-team
GL_COMMIT= a21ad33eee0314df202146392023dfb3868b7d84
USE_GNOME= glib20
-USE_QT= core gui printsupport svg widgets xml buildtools_build \
- qmake_build
+USE_QT= core gui printsupport svg widgets xml buildtools:build \
+ qmake:build
USE_XORG= ice sm x11 xau xcb xdmcp xext xrender
.include <bsd.port.mk>
diff --git a/science/molsketch/Makefile b/science/molsketch/Makefile
index 7f7824fe9e9d..7f4aeb71af13 100644
--- a/science/molsketch/Makefile
+++ b/science/molsketch/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libopenbabel.so:science/openbabel
USES= cmake:noninja compiler:c++14-lang desktop-file-utils localbase:ldflags \
pkgconfig qt:5 shared-mime-info # build fails with ninja, see https://sourceforge.net/p/molsketch/bugs/41/
-USE_QT= core gui network printsupport svg widgets buildtools_build linguisttools_build qmake_build
+USE_QT= core gui network printsupport svg widgets buildtools:build linguisttools:build qmake:build
USE_LDCONFIG= ${PREFIX}/lib/molsketch
CMAKE_ARGS= -DMSK_PREFIX:STRING=${PREFIX}
diff --git a/science/paraview/Makefile b/science/paraview/Makefile
index b6e3f60930a5..6493a3ce5c59 100644
--- a/science/paraview/Makefile
+++ b/science/paraview/Makefile
@@ -63,7 +63,7 @@ USES= alias cmake compiler:c11 eigen:3 fortran gl gnome jpeg localbase \
pkgconfig python qt:5 shebangfix tar:xz xorg
USE_GL= gl glew glu glut
USE_GNOME= libxml2
-USE_QT= buildtools_build core gui help network opengl qmake_build sql svg \
+USE_QT= buildtools:build core gui help network opengl qmake:build sql svg \
widgets x11extras xmlpatterns
USE_XORG= ice sm x11 xau xcb xcursor xdamage xdmcp xext xfixes xorgproto xrender \
xxf86vm
diff --git a/science/pulseview/Makefile b/science/pulseview/Makefile
index c636f77ba17d..95c488f726e2 100644
--- a/science/pulseview/Makefile
+++ b/science/pulseview/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
USES= cmake compiler:c++14-lang desktop-file-utils gnome pkgconfig qt:5
USE_GNOME= glibmm glib20 libsigc++20
-USE_QT= buildtools_build core gui linguisttools_build qmake_build svg widgets
+USE_QT= buildtools:build core gui linguisttools:build qmake:build svg widgets
CMAKE_ARGS+= -DCMAKE_INSTALL_MANDIR:PATH=${MANPREFIX}/man \
-DDISABLE_WERROR:BOOL=TRUE
diff --git a/science/py-pymol/Makefile b/science/py-pymol/Makefile
index 0c1a7ad8a18f..557a96a73151 100644
--- a/science/py-pymol/Makefile
+++ b/science/py-pymol/Makefile
@@ -41,7 +41,7 @@ OPTIONS_SINGLE_GUI= QT5 TK
OPTIONS_DEFAULT= QT5
QT5_USES= pyqt:5
-QT5_USE= PYQT=pyqt5_run
+QT5_USE= PYQT=pyqt5:run
post-patch-TK-on:
@${REINPLACE_CMD} -e ' \
diff --git a/science/py-veusz/Makefile b/science/py-veusz/Makefile
index 54276771619d..33b24d000ecd 100644
--- a/science/py-veusz/Makefile
+++ b/science/py-veusz/Makefile
@@ -19,7 +19,7 @@ USES= compiler:c++11-lang python:3.5+ pyqt:5 qt:5 shebangfix
USE_GITHUB= yes
USE_PYQT= pyqt5 sip
USE_PYTHON= distutils concurrent autoplist
-USE_QT= core gui xml widgets qmake_build
+USE_QT= core gui xml widgets qmake:build
SHEBANG_FILES= examples/embedexample.py
post-install:
diff --git a/science/scidavis/Makefile b/science/scidavis/Makefile
index 7696ac3f56b8..203845f00e39 100644
--- a/science/scidavis/Makefile
+++ b/science/scidavis/Makefile
@@ -20,7 +20,7 @@ USES= cmake compiler:c++17-lang desktop-file-utils gl pkgconfig \
qt:5 shared-mime-info
USE_GL= gl glu
USE_QT= core gui opengl printsupport svg widgets xml \
- buildtools_build linguisttools_build qmake_build
+ buildtools:build linguisttools:build qmake:build
USE_GITHUB= yes
GH_ACCOUNT= highperformancecoder
diff --git a/science/shelxle/Makefile b/science/shelxle/Makefile
index d156d2c4f8bf..9cb85ddf906a 100644
--- a/science/shelxle/Makefile
+++ b/science/shelxle/Makefile
@@ -12,7 +12,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
USES= compiler:c++11-lang dos2unix gl qmake qt:5 tar:bz2
DOS2UNIX_FILES= shelXle.pro
-USE_QT= core gui network opengl widgets buildtools_build
+USE_QT= core gui network opengl widgets buildtools:build
USE_GL= gl
PLIST_FILES= bin/shelxle \
diff --git a/science/step/Makefile b/science/step/Makefile
index 7db083b0caba..f49105d0f5c9 100644
--- a/science/step/Makefile
+++ b/science/step/Makefile
@@ -18,10 +18,10 @@ USE_KDE= attica auth bookmarks codecs completion config configwidgets \
kdelibs4support khtml kio newstuff notifications parts \
plotting service solid sonnet textwidgets unitconversion \
widgetsaddons windowsystem xmlgui \
- ecm_build
+ ecm:build
USE_QT= concurrent core dbus declarative gui network opengl printsupport svg \
widgets xml \
- buildtools_build qmake_build
+ buildtools:build qmake:build
USE_XORG= x11
CXXFLAGS_sparc64= -Wno-error=return-type
diff --git a/science/vipster/Makefile b/science/vipster/Makefile
index 26405e2fb1f1..a755d0f21c06 100644
--- a/science/vipster/Makefile
+++ b/science/vipster/Makefile
@@ -33,7 +33,7 @@ CMAKE_OFF= VIPSTER_DOWNLOAD_DEPENDENCIES
DESKTOP_DESC= Build QT-based desktop app
DESKTOP_CMAKE_BOOL= VIPSTER_DESKTOP
DESKTOP_USES= qt:5
-DESKTOP_USE= QT=core,gui,widgets,buildtools_build,qmake_build
+DESKTOP_USE= QT=core,gui,widgets,buildtools:build,qmake:build
LAMMPS_DESC= Interactive LAMMPS in desktop app
LAMMPS_CMAKE_BOOL= VIPSTER_LAMMPS
diff --git a/science/xdrawchem/Makefile b/science/xdrawchem/Makefile
index 69fa9e399fdf..b2462ab9dec3 100644
--- a/science/xdrawchem/Makefile
+++ b/science/xdrawchem/Makefile
@@ -13,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
LIB_DEPENDS= libopenbabel.so:science/openbabel
USES= compiler:c++11-lang gl qmake qt:5
-USE_QT= core gui network printsupport svg widgets xml buildtools_build
+USE_QT= core gui network printsupport svg widgets xml buildtools:build
USE_GL= gl
USE_GITLAB= yes