aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-04-02 15:35:23 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-04-02 15:35:23 +0000
commite57640859268f987b6934fbb4fddea9de870de8d (patch)
tree2b0944ae1023eda61bc79f1f81107c5dd6d7eaf4 /science
parent4af115e4ea20b1f53a8b031d031876bc65b98199 (diff)
downloadports-e57640859268f987b6934fbb4fddea9de870de8d.tar.gz
ports-e57640859268f987b6934fbb4fddea9de870de8d.zip
Perl module implements an object class for representing internal
coordinates and provides methods for converting them to Cartesian coordinates. WWW: http://search.cpan.org/dist/Chemistry-InternalCoords/ PR: ports/145143 Submitted by: Steve Wills <steve at mouf.net>
Notes
Notes: svn path=/head/; revision=252058
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/p5-Chemistry-InternalCoords/Makefile29
-rw-r--r--science/p5-Chemistry-InternalCoords/distinfo3
-rw-r--r--science/p5-Chemistry-InternalCoords/pkg-descr5
-rw-r--r--science/p5-Chemistry-InternalCoords/pkg-plist7
5 files changed, 45 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 7edf638a7847..2655c9b6bbcb 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -114,6 +114,7 @@
SUBDIR += p5-Chemistry-File-VRML
SUBDIR += p5-Chemistry-File-XYZ
SUBDIR += p5-Chemistry-FormulaPattern
+ SUBDIR += p5-Chemistry-InternalCoords
SUBDIR += p5-Chemistry-Isotope
SUBDIR += p5-Chemistry-MacroMol
SUBDIR += p5-Chemistry-MidasPattern
diff --git a/science/p5-Chemistry-InternalCoords/Makefile b/science/p5-Chemistry-InternalCoords/Makefile
new file mode 100644
index 000000000000..861287983d8a
--- /dev/null
+++ b/science/p5-Chemistry-InternalCoords/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-Chemistry-InternalCoords
+# Date created: 2010-03-10
+# Whom: Steve Wills <steve@mouf.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Chemistry-InternalCoords
+PORTVERSION= 0.18
+CATEGORIES= science perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/I/IT/ITUB
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= steve@mouf.net
+COMMENT= Represent the position of an atom using internal coordinates
+
+BUILD_DEPENDS= ${SITE_PERL}/Chemistry/Mol.pm:${PORTSDIR}/science/p5-Chemistry-Mol \
+ ${SITE_PERL}/Chemistry/Bond/Find.pm:${PORTSDIR}/science/p5-Chemistry-Bond-Find \
+ ${SITE_PERL}/Chemistry/Canonicalize.pm:${PORTSDIR}/science/p5-Chemistry-Canonicalize
+RUN_DEPENDS= ${SITE_PERL}/Chemistry/Mol.pm:${PORTSDIR}/science/p5-Chemistry-Mol \
+ ${SITE_PERL}/Chemistry/Bond/Find.pm:${PORTSDIR}/science/p5-Chemistry-Bond-Find \
+ ${SITE_PERL}/Chemistry/Canonicalize.pm:${PORTSDIR}/science/p5-Chemistry-Canonicalize
+
+MAN3= Chemistry::InternalCoords.3 Chemistry::InternalCoords::Builder.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/science/p5-Chemistry-InternalCoords/distinfo b/science/p5-Chemistry-InternalCoords/distinfo
new file mode 100644
index 000000000000..3ef4b3340fbe
--- /dev/null
+++ b/science/p5-Chemistry-InternalCoords/distinfo
@@ -0,0 +1,3 @@
+MD5 (Chemistry-InternalCoords-0.18.tar.gz) = 11f683ef486a1245eae7306f15b90cb7
+SHA256 (Chemistry-InternalCoords-0.18.tar.gz) = bd9ea0785e9d520443cc970e68f3ae10cb24173f3da8589f4ab06ff483989a49
+SIZE (Chemistry-InternalCoords-0.18.tar.gz) = 9454
diff --git a/science/p5-Chemistry-InternalCoords/pkg-descr b/science/p5-Chemistry-InternalCoords/pkg-descr
new file mode 100644
index 000000000000..5c8ac06f3353
--- /dev/null
+++ b/science/p5-Chemistry-InternalCoords/pkg-descr
@@ -0,0 +1,5 @@
+Perl module implements an object class for representing internal
+coordinates and provides methods for converting them to Cartesian
+coordinates.
+
+WWW: http://search.cpan.org/dist/Chemistry-InternalCoords/
diff --git a/science/p5-Chemistry-InternalCoords/pkg-plist b/science/p5-Chemistry-InternalCoords/pkg-plist
new file mode 100644
index 000000000000..853a67d3391d
--- /dev/null
+++ b/science/p5-Chemistry-InternalCoords/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/mach/auto/Chemistry/InternalCoords/.packlist
+%%SITE_PERL%%/Chemistry/InternalCoords/Builder.pm
+%%SITE_PERL%%/Chemistry/InternalCoords.pm
+@dirrmtry %%SITE_PERL%%/Chemistry/InternalCoords
+@dirrmtry %%SITE_PERL%%/Chemistry
+@dirrmtry %%SITE_PERL%%/mach/auto/Chemistry/InternalCoords
+@dirrmtry %%SITE_PERL%%/mach/auto/Chemistry