aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-06-27 17:54:40 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-06-27 17:58:02 +0000
commite5b105c24e65d7f8cffbcae80ea988394129730b (patch)
treecdde44a560950011129158ae96f2e2b9a4c90f60 /science
parent64b2298a6d98dfcc467c328b18293f558fa92c59 (diff)
downloadports-e5b105c24e65d7f8cffbcae80ea988394129730b.tar.gz
ports-e5b105c24e65d7f8cffbcae80ea988394129730b.zip
science/libgetar: New port: Library to read and write GEneric Trajectory ARchives
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/libgetar/Makefile19
-rw-r--r--science/libgetar/distinfo3
-rw-r--r--science/libgetar/pkg-descr5
-rw-r--r--science/libgetar/pkg-plist11
5 files changed, 39 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 95ea1b1a91a7..ea02b0ff8404 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -133,6 +133,7 @@
SUBDIR += libecpint
SUBDIR += libefp
SUBDIR += libgeodecomp
+ SUBDIR += libgetar
SUBDIR += libghemical
SUBDIR += libgridxc
SUBDIR += libint
diff --git a/science/libgetar/Makefile b/science/libgetar/Makefile
new file mode 100644
index 000000000000..533bd4452b88
--- /dev/null
+++ b/science/libgetar/Makefile
@@ -0,0 +1,19 @@
+PORTNAME= libgetar
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.1.3
+CATEGORIES= science # physics
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Library to read and write GEneric Trajectory ARchives
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= cmake
+
+USE_GITHUB= yes
+GH_ACCOUNT= glotzerlab
+
+CMAKE_ON= LIBGETAR_SHARED
+
+.include <bsd.port.mk>
diff --git a/science/libgetar/distinfo b/science/libgetar/distinfo
new file mode 100644
index 000000000000..b98256b19831
--- /dev/null
+++ b/science/libgetar/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1656349194
+SHA256 (glotzerlab-libgetar-v1.1.3_GH0.tar.gz) = 04ec2e9107920018771e43e8db3b53970e39fb6006c821f6fdb30b658eab43ba
+SIZE (glotzerlab-libgetar-v1.1.3_GH0.tar.gz) = 2603015
diff --git a/science/libgetar/pkg-descr b/science/libgetar/pkg-descr
new file mode 100644
index 000000000000..8739c7f63419
--- /dev/null
+++ b/science/libgetar/pkg-descr
@@ -0,0 +1,5 @@
+libgetar is a library to read and write GEneric Trajectory ARchives,
+a binary data format designed for efficient, extensible storage of
+trajectory data.
+
+WWW: https://github.com/glotzerlab/libgetar
diff --git a/science/libgetar/pkg-plist b/science/libgetar/pkg-plist
new file mode 100644
index 000000000000..fba2b69b4862
--- /dev/null
+++ b/science/libgetar/pkg-plist
@@ -0,0 +1,11 @@
+include/getar/Archive.hpp
+include/getar/DirArchive.hpp
+include/getar/GTAR.hpp
+include/getar/Record.hpp
+include/getar/SharedArray.hpp
+include/getar/SqliteArchive.hpp
+include/getar/TarArchive.hpp
+include/getar/ZipArchive.hpp
+include/getar/miniz.h
+include/getar/sqlite3.h
+lib/libgetar.so