aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-06-15 23:49:36 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-06-15 23:49:36 +0000
commite80a83df0ab3f8bd5766a30eb778855ab58b5769 (patch)
treee3b0424fda194acec491a7c8396b2185f8402d84 /science
parent90c2cbf7f10053994a21c3945dafde7bfe5456b8 (diff)
downloadports-e80a83df0ab3f8bd5766a30eb778855ab58b5769.tar.gz
ports-e80a83df0ab3f8bd5766a30eb778855ab58b5769.zip
New port: science/py-pymatgen: Python Materials Genomics is a robust materials analysis code
Notes
Notes: svn path=/head/; revision=472503
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/py-pymatgen/Makefile33
-rw-r--r--science/py-pymatgen/distinfo3
-rw-r--r--science/py-pymatgen/pkg-descr14
4 files changed, 51 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index c71f260530fa..e26d02fd63f1 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -181,6 +181,7 @@
SUBDIR += py-pupynere
SUBDIR += py-pyaixi
SUBDIR += py-pydicom
+ SUBDIR += py-pymatgen
SUBDIR += py-pymol
SUBDIR += py-pyosf
SUBDIR += py-pysal
diff --git a/science/py-pymatgen/Makefile b/science/py-pymatgen/Makefile
new file mode 100644
index 000000000000..3ee2b2cf0528
--- /dev/null
+++ b/science/py-pymatgen/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= pymatgen
+DISTVERSION= 2018.6.11
+CATEGORIES= science python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Python Materials Genomics is a robust materials analysis code
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.rst
+
+BUILD_DEPENDS= ${PYNUMPY}
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>=1.5:math/py-matplotlib@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}monty>=0.9.6:devel/py-monty@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}palettable>=2.1.1:misc/py-palettable@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pandas>0:math/py-pandas@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pydispatcher>=2.0.5:devel/py-pydispatcher@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}ruamel.yaml>=0.15.6:devel/py-ruamel.yaml@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=1.0.1:science/py-scipy@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}spglib>=1.9.9.44:science/py-spglib@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sympy>0:math/py-sympy@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tabulate>0:devel/py-tabulate@${FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/science/py-pymatgen/distinfo b/science/py-pymatgen/distinfo
new file mode 100644
index 000000000000..22211c9b2be2
--- /dev/null
+++ b/science/py-pymatgen/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1529101902
+SHA256 (pymatgen-2018.6.11.tar.gz) = be1b2f101abf6477b5388b3112c5e4d0ff8f0f6cefb7f9d3d509a88882c515ed
+SIZE (pymatgen-2018.6.11.tar.gz) = 1740814
diff --git a/science/py-pymatgen/pkg-descr b/science/py-pymatgen/pkg-descr
new file mode 100644
index 000000000000..e40803f58457
--- /dev/null
+++ b/science/py-pymatgen/pkg-descr
@@ -0,0 +1,14 @@
+Pymatgen (Python Materials Genomics) is a robust, open-source Python library
+for materials analysis. These are some of the main features:
+* Highly flexible classes for the representation of Element, Site, Molecule,
+ Structure objects.
+* Extensive input/output support, including support for VASP
+ (http://cms.mpi.univie.ac.at/vasp/), ABINIT (http://www.abinit.org/), CIF,
+ Gaussian, XYZ, and many other file formats.
+* Powerful analysis tools, including generation of phase diagrams, Pourbaix
+ diagrams, diffusion analyses, reactions, etc.
+* Electronic structure analyses, such as density of states and band structure.
+* Integration with the Materials Project REST API, Crystallography Open
+ Database.
+
+WWW: http://pymatgen.org/