aboutsummaryrefslogtreecommitdiff
path: root/security/Makefile
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2019-03-06 13:56:23 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2019-03-06 13:56:23 +0000
commitd72c87d49e96632d47b1bb5aa5604c7486badc83 (patch)
tree4b7bfc0abd27f9912fd536f97f571a7649e2ea4a /security/Makefile
parentd7dc04cb1a9638f655de2f1fbfb8f13e4e8cfdbc (diff)
downloadports-d72c87d49e96632d47b1bb5aa5604c7486badc83.tar.gz
ports-d72c87d49e96632d47b1bb5aa5604c7486badc83.zip
[NEW] security/sslproxy: Transparent and scalable SSL/TLS interception
SSLproxy is a proxy for SSL/TLS encrypted network connections. It is intended to be used for decrypting and diverting network traffic to other programs, such as UTM services, for deep SSL inspection. SSLproxy is designed to transparently terminate connections that are redirected to it using a network address translation engine. SSLproxy then terminates SSL/TLS and initiates a new SSL/TLS connection to the original destination address. Packets received on the client side are decrypted and sent to the program listening on a port given in the proxy specification. SSLproxy inserts in the first packet the address and port it is expecting to receive the packets back from the program. Upon receiving the packets back, SSLproxy re-encrypts and sends them to their original destination. The return traffic follows the same path back to the client in reverse order. WWW: https://github.com/sonertari/SSLproxy Please note that the sslproxy deleted and sslproxy created are not the same application.
Notes
Notes: svn path=/head/; revision=494801
Diffstat (limited to 'security/Makefile')
-rw-r--r--security/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 3eee7e850403..865449d3dd86 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -1277,6 +1277,7 @@
SUBDIR += sshpass
SUBDIR += ssl-admin
SUBDIR += ssllabs-scan
+ SUBDIR += sslproxy
SUBDIR += sslscan
SUBDIR += sslsniffer
SUBDIR += sslsplit