aboutsummaryrefslogtreecommitdiff
path: root/security/afterglow
diff options
context:
space:
mode:
authorSahil Tandon <sahil@FreeBSD.org>2010-07-29 01:41:05 +0000
committerSahil Tandon <sahil@FreeBSD.org>2010-07-29 01:41:05 +0000
commit06701fd8ef966618c67df9d1699e3dddf506f0de (patch)
treeda1cbc147e1725d906ed678bf4412d6e22528948 /security/afterglow
parent94b23b9fc1d230f559db549e7435d5388183e0a7 (diff)
downloadports-06701fd8ef966618c67df9d1699e3dddf506f0de.tar.gz
ports-06701fd8ef966618c67df9d1699e3dddf506f0de.zip
- Update to 1.6.0
PR: ports/148971 Submitted by: Paul Schmehl <pauls@utdallas.edu> (maintainer)
Notes
Notes: svn path=/head/; revision=258410
Diffstat (limited to 'security/afterglow')
-rw-r--r--security/afterglow/Makefile28
-rw-r--r--security/afterglow/distinfo6
-rw-r--r--security/afterglow/pkg-plist39
3 files changed, 42 insertions, 31 deletions
diff --git a/security/afterglow/Makefile b/security/afterglow/Makefile
index 1445aa1bd6fc..b6f18fefd4fe 100644
--- a/security/afterglow/Makefile
+++ b/security/afterglow/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= afterglow
-PORTVERSION= 1.5
-PORTREVISION= 3
+PORTVERSION= 1.6.0
CATEGORIES= security graphics
MASTER_SITES= SF/${PORTNAME}/AfterGlow%201.x/${PORTVERSION}
@@ -20,29 +19,32 @@ NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
-DB_SCRIPTS= attackchains.pl deltacalc2.pl deltacalc.pl iptolong.pl \
- snortalert.pl snortdirection.pl snortservice.pl subquery.pl \
- tcpdump2sql.pl
-GRAPH_SCRIPTS= afterglow-lgl.pl afterglow-lgl2.pl afterglow-walrus.pl afterglow.pl
-PARSERS= pf2csv.pl sendmail_parser.pl tcpdump2csv.pl
+CHARTS_SCRIPTS= bar.pl bar2.pl boxplot.pl bubble.pl scatter.pl trendline.pl trendline2.pl
+GRAPH_SCRIPTS= afterglow.pl afterglow-lgl.pl
+LOGANALYSIS_SCRIPTS= anonymize.pl capper.pl merge_logs.pl overview.sh random_logs.pl
+PARSERS= argus2csv.pl ipfw2csv.pl pf2csv.pl sendmail_parser.pl snortalert2csv.pl tcpdump2csv.pl
do-install:
- ${MKDIR} ${DATADIR}
${MKDIR} ${DATADIR}/data
- ${MKDIR} ${DATADIR}/database
- ${MKDIR} ${DATADIR}/graph
+ ${MKDIR} ${DATADIR}/charts
+ ${MKDIR} ${DATADIR}/graph/Text
+ ${MKDIR} ${DATADIR}/loganalysis
${MKDIR} ${DATADIR}/parsers
(cd ${WRKSRC}/data/ && ${COPYTREE_SHARE} \* ${DATADIR}/data "! -name generate.pl")
- (cd ${WRKSRC}/src/perl/database/ && ${COPYTREE_SHARE} \* ${DATADIR}/database "! -name *\.pl")
+ (cd ${WRKSRC}/src/perl/charts/ && ${COPYTREE_SHARE} \* ${DATADIR}/charts "! -name *\.pl")
(cd ${WRKSRC}/src/perl/graph/ && ${COPYTREE_SHARE} \* ${DATADIR}/graph "! -name *\.pl")
+ (cd ${WRKSRC}/src/perl/loganalysis/ && ${COPYTREE_SHARE} \* ${DATADIR}/loganalysis "! ( -name *\.pl -or -name *\.sh )")
(cd ${WRKSRC}/src/perl/parsers/ && ${COPYTREE_SHARE} \* ${DATADIR}/parsers "! -name *\.pl")
${INSTALL_SCRIPT} ${WRKSRC}/data/generate.pl ${DATADIR}/data/
-.for f in ${DB_SCRIPTS}
- ${INSTALL_SCRIPT} ${WRKSRC}/src/perl/database/${f} ${DATADIR}/database/${f}
+.for f in ${CHARTS_SCRIPTS}
+ ${INSTALL_SCRIPT} ${WRKSRC}/src/perl/charts/${f} ${DATADIR}/charts/${f}
.endfor
.for f in ${GRAPH_SCRIPTS}
${INSTALL_SCRIPT} ${WRKSRC}/src/perl/graph/${f} ${DATADIR}/graph/${f}
.endfor
+.for f in ${LOGANALYSIS_SCRIPTS}
+ ${INSTALL_SCRIPT} ${WRKSRC}/src/perl/loganalysis/${f} ${DATADIR}/loganalysis/${f}
+.endfor
.for f in ${PARSERS}
${INSTALL_SCRIPT} ${WRKSRC}/src/perl/parsers/${f} ${DATADIR}/parsers/${f}
.endfor
diff --git a/security/afterglow/distinfo b/security/afterglow/distinfo
index d7743fccc610..0b8ca5d7976e 100644
--- a/security/afterglow/distinfo
+++ b/security/afterglow/distinfo
@@ -1,3 +1,3 @@
-MD5 (afterglow-1.5.tar.gz) = 9482ea9dcf0e1dad984084cadf97b653
-SHA256 (afterglow-1.5.tar.gz) = cba1ad5a9529d8cf54d0c1fbeb672051ac3e8e87567e05887d722959a6c1f618
-SIZE (afterglow-1.5.tar.gz) = 35619
+MD5 (afterglow-1.6.0.tar.gz) = 7270ba7e26bc2f102e9488c68b73e852
+SHA256 (afterglow-1.6.0.tar.gz) = 14feec9e943a4223c53e06fb9df2bffdeb29f88482020f600c2794c685e6e17e
+SIZE (afterglow-1.6.0.tar.gz) = 74194
diff --git a/security/afterglow/pkg-plist b/security/afterglow/pkg-plist
index 7c974ee81698..de491d9f6c44 100644
--- a/security/afterglow/pkg-plist
+++ b/security/afterglow/pkg-plist
@@ -1,3 +1,10 @@
+%%DATADIR%%/charts/bar.pl
+%%DATADIR%%/charts/bar2.pl
+%%DATADIR%%/charts/boxplot.pl
+%%DATADIR%%/charts/bubble.pl
+%%DATADIR%%/charts/scatter.pl
+%%DATADIR%%/charts/trendline.pl
+%%DATADIR%%/charts/trendline2.pl
%%DATADIR%%/data/example.dot
%%DATADIR%%/data/firewall.count.csv
%%DATADIR%%/data/firewall.count.tm3
@@ -9,31 +16,33 @@
%%DATADIR%%/data/vulnerabilities.2.csv
%%DATADIR%%/data/vulnerabilities.csv
%%DATADIR%%/data/vulnerabilities.list
-%%DATADIR%%/database/README
-%%DATADIR%%/database/attackchains.pl
-%%DATADIR%%/database/createDB.sql
-%%DATADIR%%/database/deltacalc.pl
-%%DATADIR%%/database/deltacalc2.pl
-%%DATADIR%%/database/iptolong.pl
-%%DATADIR%%/database/snortalert.pl
-%%DATADIR%%/database/snortdirection.pl
-%%DATADIR%%/database/snortservice.pl
-%%DATADIR%%/database/subquery.pl
-%%DATADIR%%/database/tcpdump2sql.pl
%%DATADIR%%/graph/README
+%%DATADIR%%/graph/Text/CSV.pm
+%%DATADIR%%/graph/Text/CSV_PP.pm
%%DATADIR%%/graph/afterglow-lgl.pl
-%%DATADIR%%/graph/afterglow-lgl2.pl
-%%DATADIR%%/graph/afterglow-walrus.pl
%%DATADIR%%/graph/afterglow.pl
-%%DATADIR%%/graph/color.properties
+%%DATADIR%%/graph/color.tcpspy
+%%DATADIR%%/graph/sample.properties
+%%DATADIR%%/loganalysis/Anonymous.pm
+%%DATADIR%%/loganalysis/README
+%%DATADIR%%/loganalysis/anonymize.pl
+%%DATADIR%%/loganalysis/capper.pl
+%%DATADIR%%/loganalysis/merge_logs.pl
+%%DATADIR%%/loganalysis/overview.sh
+%%DATADIR%%/loganalysis/random_logs.pl
%%DATADIR%%/parsers/README
+%%DATADIR%%/parsers/argus2csv.pl
%%DATADIR%%/parsers/color.properties
%%DATADIR%%/parsers/color.sendmail.properties
+%%DATADIR%%/parsers/ipfw2csv.pl
%%DATADIR%%/parsers/pf2csv.pl
%%DATADIR%%/parsers/sendmail_parser.pl
+%%DATADIR%%/parsers/snortalert2csv.pl
%%DATADIR%%/parsers/tcpdump2csv.pl
@dirrm %%DATADIR%%/parsers
+@dirrm %%DATADIR%%/loganalysis
+@dirrm %%DATADIR%%/graph/Text
@dirrm %%DATADIR%%/graph
-@dirrm %%DATADIR%%/database
@dirrm %%DATADIR%%/data
+@dirrm %%DATADIR%%/charts
@dirrm %%DATADIR%%