aboutsummaryrefslogtreecommitdiff
path: root/security/afterglow
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2012-12-17 18:23:30 +0000
committerWesley Shields <wxs@FreeBSD.org>2012-12-17 18:23:30 +0000
commitb7ba40e01eb3b8d62fe4ceec68d78a217f760cb5 (patch)
treeb150ec896312f05a6240b6ee1fdc2bb743b4790a /security/afterglow
parentea4597d4eeefdd4e4ea0026817862b650ca1ea7c (diff)
downloadports-b7ba40e01eb3b8d62fe4ceec68d78a217f760cb5.tar.gz
ports-b7ba40e01eb3b8d62fe4ceec68d78a217f760cb5.zip
Update to 1.6.2.
PR: ports/173674 Submitted by: Paul Schmehl <pauls@utdallas.edu> (maintainer)
Notes
Notes: svn path=/head/; revision=309117
Diffstat (limited to 'security/afterglow')
-rw-r--r--security/afterglow/Makefile33
-rw-r--r--security/afterglow/distinfo4
-rw-r--r--security/afterglow/pkg-descr2
-rw-r--r--security/afterglow/pkg-message7
-rw-r--r--security/afterglow/pkg-plist11
5 files changed, 30 insertions, 27 deletions
diff --git a/security/afterglow/Makefile b/security/afterglow/Makefile
index 9cb71127c951..25cbb16f3acb 100644
--- a/security/afterglow/Makefile
+++ b/security/afterglow/Makefile
@@ -6,51 +6,40 @@
#
PORTNAME= afterglow
-PORTVERSION= 1.6.0
-PORTREVISION= 1
-CATEGORIES= security graphics
+PORTVERSION= 1.6.2
+CATEGORIES= security graphics net-mgmt
MASTER_SITES= SF/${PORTNAME}/AfterGlow%201.x/${PORTVERSION}
MAINTAINER= pauls@utdallas.edu
COMMENT= A collection of graph-generating scripts
+LICENSE= GPLv2
+
RUN_DEPENDS= dot:${PORTSDIR}/graphics/graphviz \
p5-Text-CSV>=0:${PORTSDIR}/textproc/p5-Text-CSV \
p5-Crypt-Rijndael>=0:${PORTSDIR}/security/p5-Crypt-Rijndael \
p5-IP-Anonymous>=0:${PORTSDIR}/net/p5-IP-Anonymous
NO_BUILD= yes
+USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
-CHARTS_SCRIPTS= bar.pl bar2.pl boxplot.pl bubble.pl scatter.pl trendline.pl trendline2.pl
-GRAPH_SCRIPTS= afterglow.pl afterglow-lgl.pl
-LOGANALYSIS_SCRIPTS= anonymize.pl capper.pl merge_logs.pl overview.sh random_logs.pl
-PARSERS= argus2csv.pl ipfw2csv.pl pf2csv.pl sendmail_parser.pl snortalert2csv.pl tcpdump2csv.pl
-
do-install:
${MKDIR} ${DATADIR}/data
${MKDIR} ${DATADIR}/charts
- ${MKDIR} ${DATADIR}/graph/Text
+ ${MKDIR} ${DATADIR}/graph
${MKDIR} ${DATADIR}/loganalysis
${MKDIR} ${DATADIR}/parsers
(cd ${WRKSRC}/data/ && ${COPYTREE_SHARE} \* ${DATADIR}/data "! -name generate.pl")
+ (cd ${WRKSRC}/data/ && ${COPYTREE_BIN} \* ${DATADIR}/data "-name generate.pl")
(cd ${WRKSRC}/src/perl/charts/ && ${COPYTREE_SHARE} \* ${DATADIR}/charts "! -name *\.pl")
+ (cd ${WRKSRC}/src/perl/charts/ && ${COPYTREE_BIN} \* ${DATADIR}/charts "-name *\.pl")
(cd ${WRKSRC}/src/perl/graph/ && ${COPYTREE_SHARE} \* ${DATADIR}/graph "! -name *\.pl")
+ (cd ${WRKSRC}/src/perl/graph/ && ${COPYTREE_BIN} \* ${DATADIR}/graph "-name *\.pl")
(cd ${WRKSRC}/src/perl/loganalysis/ && ${COPYTREE_SHARE} \* ${DATADIR}/loganalysis "! ( -name *\.pl -or -name *\.sh )")
+ (cd ${WRKSRC}/src/perl/loganalysis/ && ${COPYTREE_BIN} \* ${DATADIR}/loganalysis "( -name *\.pl -or -name *\.sh )")
(cd ${WRKSRC}/src/perl/parsers/ && ${COPYTREE_SHARE} \* ${DATADIR}/parsers "! -name *\.pl")
- ${INSTALL_SCRIPT} ${WRKSRC}/data/generate.pl ${DATADIR}/data/
-.for f in ${CHARTS_SCRIPTS}
- ${INSTALL_SCRIPT} ${WRKSRC}/src/perl/charts/${f} ${DATADIR}/charts/${f}
-.endfor
-.for f in ${GRAPH_SCRIPTS}
- ${INSTALL_SCRIPT} ${WRKSRC}/src/perl/graph/${f} ${DATADIR}/graph/${f}
-.endfor
-.for f in ${LOGANALYSIS_SCRIPTS}
- ${INSTALL_SCRIPT} ${WRKSRC}/src/perl/loganalysis/${f} ${DATADIR}/loganalysis/${f}
-.endfor
-.for f in ${PARSERS}
- ${INSTALL_SCRIPT} ${WRKSRC}/src/perl/parsers/${f} ${DATADIR}/parsers/${f}
-.endfor
+ (cd ${WRKSRC}/src/perl/parsers/ && ${COPYTREE_BIN} \* ${DATADIR}/parsers "-name *\.pl")
.include <bsd.port.mk>
diff --git a/security/afterglow/distinfo b/security/afterglow/distinfo
index 670fbe30cee0..737f47736e44 100644
--- a/security/afterglow/distinfo
+++ b/security/afterglow/distinfo
@@ -1,2 +1,2 @@
-SHA256 (afterglow-1.6.0.tar.gz) = 14feec9e943a4223c53e06fb9df2bffdeb29f88482020f600c2794c685e6e17e
-SIZE (afterglow-1.6.0.tar.gz) = 74194
+SHA256 (afterglow-1.6.2.tar.gz) = f40c562c2c849b42ed8c44c88d9a1018a8e33024e4fd368490790f55810589d8
+SIZE (afterglow-1.6.2.tar.gz) = 103662
diff --git a/security/afterglow/pkg-descr b/security/afterglow/pkg-descr
index f519d0c65891..a48c4d53fe3e 100644
--- a/security/afterglow/pkg-descr
+++ b/security/afterglow/pkg-descr
@@ -2,6 +2,6 @@ AfterGlow is a collection of scripts which facilitate the process of
generating event graphs and treemaps. AfterGlow 1.x is written in Perl
and generates output that can be read by GraphViz or LGL.
All the scripts and other files for afterglow are installed in
-${DATADIR}
+%%DATADIR%%
WWW: http://sourceforge.net/projects/afterglow
diff --git a/security/afterglow/pkg-message b/security/afterglow/pkg-message
new file mode 100644
index 000000000000..5fd282bde254
--- /dev/null
+++ b/security/afterglow/pkg-message
@@ -0,0 +1,7 @@
+AfterGlow is a collection of scripts which facilitate
+the process of generating graphs. It is the most downloaded
+security visualization tool of all times.
+
+Afterglow documentation may be found online at
+http://afterglow.sourceforge.net/ including a FAQ, manual
+and screenshots. Be sure to read the documentation carefully.
diff --git a/security/afterglow/pkg-plist b/security/afterglow/pkg-plist
index de491d9f6c44..1a1d368903da 100644
--- a/security/afterglow/pkg-plist
+++ b/security/afterglow/pkg-plist
@@ -19,12 +19,16 @@
%%DATADIR%%/graph/README
%%DATADIR%%/graph/Text/CSV.pm
%%DATADIR%%/graph/Text/CSV_PP.pm
-%%DATADIR%%/graph/afterglow-lgl.pl
%%DATADIR%%/graph/afterglow.pl
%%DATADIR%%/graph/color.tcpspy
+%%DATADIR%%/graph/gdf.properties
%%DATADIR%%/graph/sample.properties
-%%DATADIR%%/loganalysis/Anonymous.pm
+%%DATADIR%%/loganalysis/Crypt/Rijndael.pm
+%%DATADIR%%/loganalysis/IP/Anonymous.pm
%%DATADIR%%/loganalysis/README
+%%DATADIR%%/loganalysis/Text/CSV.pm
+%%DATADIR%%/loganalysis/Text/CSV_PP.pm
+%%DATADIR%%/loganalysis/anon.pl
%%DATADIR%%/loganalysis/anonymize.pl
%%DATADIR%%/loganalysis/capper.pl
%%DATADIR%%/loganalysis/merge_logs.pl
@@ -40,6 +44,9 @@
%%DATADIR%%/parsers/snortalert2csv.pl
%%DATADIR%%/parsers/tcpdump2csv.pl
@dirrm %%DATADIR%%/parsers
+@dirrm %%DATADIR%%/loganalysis/Text
+@dirrm %%DATADIR%%/loganalysis/IP
+@dirrm %%DATADIR%%/loganalysis/Crypt
@dirrm %%DATADIR%%/loganalysis
@dirrm %%DATADIR%%/graph/Text
@dirrm %%DATADIR%%/graph