aboutsummaryrefslogtreecommitdiff
path: root/security/aide
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2001-02-06 13:17:01 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2001-02-06 13:17:01 +0000
commit58b7e36a58b05f3db6437bb1956e7df79dab7669 (patch)
tree60b7fbb4ad5da1ca6ab3d5fe7df51bc6ab27d391 /security/aide
parentb00f6ee930d8b60f95b348d7cd2e6d780dac33d9 (diff)
downloadports-58b7e36a58b05f3db6437bb1956e7df79dab7669.tar.gz
ports-58b7e36a58b05f3db6437bb1956e7df79dab7669.zip
Misc. port cleanups and some manpage fixes (correct FILES section).
PR: 20997 (slightly modified for new port layout) Submitted by: olgeni Approved by: maintainer
Notes
Notes: svn path=/head/; revision=38035
Diffstat (limited to 'security/aide')
-rw-r--r--security/aide/Makefile18
-rw-r--r--security/aide/files/aide.conf.freebsd7
-rw-r--r--security/aide/files/patch-doc_aide.123
-rw-r--r--security/aide/pkg-message10
-rw-r--r--security/aide/pkg-plist8
5 files changed, 53 insertions, 13 deletions
diff --git a/security/aide/Makefile b/security/aide/Makefile
index cb2dd41569f2..f1e6619d739c 100644
--- a/security/aide/Makefile
+++ b/security/aide/Makefile
@@ -27,16 +27,16 @@ MAN1= aide.1
MAN5= aide.conf.5
post-install:
- ${INSTALL_DATA} ${FILESDIR}/aide.conf.freebsd ${PREFIX}/etc/aide.conf.sample
+ @${INSTALL_DATA} ${FILESDIR}/aide.conf.freebsd ${PREFIX}/etc/aide.conf.sample
+ @${MKDIR} /var/adm/aide/databases
+ @if [ ! -f /var/adm/aide/aide.conf ]; then \
+ ${CHOWN} root:wheel /var/adm/aide ; \
+ ${CHOWN} root:wheel /var/adm/aide/databases ; \
+ ${CHMOD} 0700 /var/adm/aide ; \
+ ${CHMOD} 0700 /var/adm/aide/databases ; \
+ fi
@${ECHO}
- @${ECHO} "If you want to finish setting up AIDE, don't forget to make"
- @${ECHO} "a new directory called /var/adm/aide and then create your own"
- @${ECHO} "aide.conf based on ${PREFIX}/etc/aide.conf.sample and then"
- @${ECHO} "copy it to that directory. You will also need to make the"
- @${ECHO} "databases directory, /var/adm/aide/databases, and run the"
- @${ECHO} "following command:"
- @${ECHO}
- @${ECHO} " cd /var/adm/aide;aide --init;mv databases/aide.db.new databases/aide.db"
+ @${CAT} ${PKGMESSAGE}
@${ECHO}
.if defined(AIDE_FLOPPY)
@disklabel -w -B /dev/rfd0c fd1440
diff --git a/security/aide/files/aide.conf.freebsd b/security/aide/files/aide.conf.freebsd
index 1e481db85e84..d6c88e2e217a 100644
--- a/security/aide/files/aide.conf.freebsd
+++ b/security/aide/files/aide.conf.freebsd
@@ -67,14 +67,13 @@
#
#
# Tripwire running slowly? Modify your tripwire.config entries to
-# ignore the (signature 2) attribute when this computationally-exorbita
-nt
+# ignore the (signature 2) attribute when this computationally-exorbitant
# protection is not needed. (See README and design document for further
# details.)
#
-database=file:///var/log/aide/databases/aide.db
-database_out=file:///var/log/aide/databases/aide.db.new
+database=file:///var/adm/aide/databases/aide.db
+database_out=file:///var/adm/aide/databases/aide.db.new
# First, root's traditional "home". Note that FreeBSD's root's home (/root)
diff --git a/security/aide/files/patch-doc_aide.1 b/security/aide/files/patch-doc_aide.1
new file mode 100644
index 000000000000..b016612768a3
--- /dev/null
+++ b/security/aide/files/patch-doc_aide.1
@@ -0,0 +1,23 @@
+--- doc/aide.1.orig Wed Jan 19 12:11:36 2000
++++ doc/aide.1 Sat Sep 2 13:00:57 2000
+@@ -45,11 +45,17 @@
+ Prints out the standard help message.
+ .PP
+ .SH FILES
+-.B <prefix>/etc/aide.conf
++.TP
++.BI PREFIX/etc/aide.conf.sample
++Example aide configuration file.
++.TP
++.BI /var/adm/aide/aide.conf
+ Default aide configuration file.
+-.B <prefix>/etc/aide.db
++.TP
++.BI /var/adm/aide/databases/aide.db
+ Default aide database.
+-.B <prefix>/etc/aide.db.new
++.TP
++.BI /var/adm/aide/databases/aide.db.new
+ Default aide output database.
+ .SH SEE ALSO
+ .BR aide.conf (5)
diff --git a/security/aide/pkg-message b/security/aide/pkg-message
new file mode 100644
index 000000000000..f6d510fe8117
--- /dev/null
+++ b/security/aide/pkg-message
@@ -0,0 +1,10 @@
+If you want to finish setting up AIDE, don't forget to create your own
+aide.conf based on ${PREFIX}/etc/aide.conf.sample and then copy it to
+the /var/adm/aide/ directory. You will also need to run the following
+commands:
+
+ cd /var/adm/aide
+ aide --init
+ mv databases/aide.db.new databases/aide.db
+
+You may want to change the permissions of the /var/adm/aide/ directory tree.
diff --git a/security/aide/pkg-plist b/security/aide/pkg-plist
index 43580109d04b..83b0bfee2521 100644
--- a/security/aide/pkg-plist
+++ b/security/aide/pkg-plist
@@ -1,2 +1,10 @@
bin/aide
etc/aide.conf.sample
+@exec /bin/mkdir -p /var/adm/aide/databases
+@exec [ -f /var/adm/aide/aide.conf ] || /usr/sbin/chown root:wheel /var/adm/aide
+@exec [ -f /var/adm/aide/aide.conf ] || /usr/sbin/chown root:wheel /var/adm/aide/databases
+@exec [ -f /var/adm/aide/aide.conf ] || /usr/sbin/chmod 0700 /var/adm/aide
+@exec [ -f /var/adm/aide/aide.conf ] || /usr/sbin/chmod 0700 /var/adm/aide/databases
+@unexec rmdir /var/adm/aide/databases 2>/dev/null || true
+@unexec rmdir /var/adm/aide 2>/dev/null || true
+@unexec rmdir /var/adm 2>/dev/null || true