aboutsummaryrefslogtreecommitdiff
path: root/security/amavisd-new
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2019-01-14 22:08:45 +0000
committerFlorian Smeets <flo@FreeBSD.org>2019-01-14 22:08:45 +0000
commit51575fa18ea77a8d4d77da32db867d2dfbee681b (patch)
treeb9a0bb7dccda21139a0a6ac2eb93c777555785bf /security/amavisd-new
parente788982b150a536e0c9ef9da8d755961c7a0d2cc (diff)
downloadports-51575fa18ea77a8d4d77da32db867d2dfbee681b.tar.gz
ports-51575fa18ea77a8d4d77da32db867d2dfbee681b.zip
Add a missing backslash-escape to left brace in a regexp
Perl 5.28 introduced a warning about unescaped left brace in a regexp, resulting in a warning issued during amavisd startup: Unescaped left brace in regex is deprecated here (and will be fatal in Perl 5.32), passed through in regex; marked by <-- HERE in m/ ( { <-- HERE } (?: / \* )? | \* ) / at (eval 112) line 830. Currently the warning is harmless although annoying, but will become a fatal error with the next version of perl. PR: 234173 Submitted by: Mark.Martinec@ijs.si
Notes
Notes: svn path=/head/; revision=490317
Diffstat (limited to 'security/amavisd-new')
-rw-r--r--security/amavisd-new/Makefile1
-rw-r--r--security/amavisd-new/files/patch-amavisd11
2 files changed, 11 insertions, 1 deletions
diff --git a/security/amavisd-new/Makefile b/security/amavisd-new/Makefile
index bdf05909b2f0..f13f3e587962 100644
--- a/security/amavisd-new/Makefile
+++ b/security/amavisd-new/Makefile
@@ -2,6 +2,7 @@
PORTNAME= amavisd-new
PORTVERSION= 2.11.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= security
MASTER_SITES= http://www.ijs.si/software/amavisd/ \
diff --git a/security/amavisd-new/files/patch-amavisd b/security/amavisd-new/files/patch-amavisd
index 9708825d686a..d965f6a8976e 100644
--- a/security/amavisd-new/files/patch-amavisd
+++ b/security/amavisd-new/files/patch-amavisd
@@ -1,4 +1,4 @@
---- amavisd.orig 2016-12-10 16:31:50 UTC
+--- amavisd.orig 2019-01-14 21:47:08 UTC
+++ amavisd
@@ -22814,6 +22814,7 @@ sub process_smtp_request($$$$) {
}
@@ -8,6 +8,15 @@
$msginfo->client_addr($cl_ip); # ADDR
$msginfo->client_port($cl_port); # PORT
+@@ -28857,7 +28857,7 @@ sub run_av(@) {
+ my $f = $bare_fnames->[$k]; my $multi = 0;
+ if ($one_at_a_time) { # glob templates may be substrings anywhere
+ local($1); @query_expanded = @query_template; # start afresh
+- s{ ( {} (?: / \* )? | \* ) }
++ s{ ( \{\} (?: / \* )? | \* ) }
+ { $1 eq '{}' ? "$tempdir/parts"
+ : $1 eq '{}/*' ? ($multi=1,"$tempdir/parts/$f")
+ : $1 eq '*' ? ($multi=1,$f) : $1
@@ -34357,6 +34358,7 @@ sub collect_some_dkim_info($) {
$sig_ind++;
}