aboutsummaryrefslogtreecommitdiff
path: root/security/aolserver-nsencrypt
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2007-07-02 22:43:31 +0000
committerMartin Matuska <mm@FreeBSD.org>2007-07-02 22:43:31 +0000
commitd7fa652b2c94207da8a897a03f719c75d9c1726a (patch)
tree81631c19bfff04f9f5e8f79b3183a1cc9a53aecd /security/aolserver-nsencrypt
parent37281f769a2e336e48416d7d7d466a65a8ca49e8 (diff)
downloadports-d7fa652b2c94207da8a897a03f719c75d9c1726a.tar.gz
ports-d7fa652b2c94207da8a897a03f719c75d9c1726a.zip
- fix build of libns*.so
- move AOLSERVERBASE under PREFIX - move small pkg-plist to PLIST_FILES - bump PORTREVISION Approved by: garga (mentor)
Notes
Notes: svn path=/head/; revision=194732
Diffstat (limited to 'security/aolserver-nsencrypt')
-rw-r--r--security/aolserver-nsencrypt/Makefile20
-rw-r--r--security/aolserver-nsencrypt/pkg-plist3
2 files changed, 16 insertions, 7 deletions
diff --git a/security/aolserver-nsencrypt/Makefile b/security/aolserver-nsencrypt/Makefile
index 9c70d49eaa14..28b1aec0dfea 100644
--- a/security/aolserver-nsencrypt/Makefile
+++ b/security/aolserver-nsencrypt/Makefile
@@ -7,6 +7,7 @@
PORTNAME= aolserver-nsencrypt
PORTVERSION= 0.4
+PORTREVISION= 1
CATEGORIES= security www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= aolserver
@@ -18,20 +19,31 @@ COMMENT= OpenSSL data encryption module for AOLserver
WRKSRC= ${WRKDIR}/nsencrypt-${PORTVERSION}
-AOLSERVERBASE?= ${PREFIX}/aolserver
-BUILD_DEPENDS+= ${AOLSERVERBASE}/bin/nsd:${PORTSDIR}/www/aolserver
+AOLSERVERBASE?= aolserver
+BUILD_DEPENDS+= ${LOCALBASE}/${AOLSERVERBASE}/bin/nsd:${PORTSDIR}/www/aolserver
RUN_DEPENDS+= ${BUILD_DEPENDS}
-PLIST_SUB+= AOLSERVERBASE=${AOLSERVERBASE:S/${PREFIX}\///}
+PLIST_SUB+= AOLSERVERBASE=${AOLSERVERBASE}
USE_OPENSSL= yes
USE_GMAKE= yes
-MAKE_ARGS= AOLSERVER=${AOLSERVERBASE} OPENSSL=${OPENSSLBASE}
+MAKE_ARGS= AOLSERVER="${LOCALBASE}/${AOLSERVERBASE}" \
+ OPENSSL="${OPENSSLBASE}"
+
+PLIST_FILES= ${AOLSERVERBASE}/bin/nsencrypt.so \
+ ${AOLSERVERBASE}/lib/libnsencrypt.a \
+ ${AOLSERVERBASE}/lib/libnsencrypt.so
.if !defined(NOPORTDOCS)
PORTDOCS= ChangeLog readme.txt
.endif
+post-patch:
+ @${REINPLACE_CMD} \
+ -e '/^MODOBJS =.*/{p;s/MODOBJS =/OBJS +=/g;}' \
+ -e '/^MODLIBS =.*/{p;s/MODLIBS =/DLLLIBS +=/g;}' \
+ ${WRKSRC}/Makefile
+
post-install:
.if !defined(NOPORTDOCS)
@ ${MKDIR} ${DOCSDIR}
diff --git a/security/aolserver-nsencrypt/pkg-plist b/security/aolserver-nsencrypt/pkg-plist
deleted file mode 100644
index ba4ce9d6dc8f..000000000000
--- a/security/aolserver-nsencrypt/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-%%AOLSERVERBASE%%/bin/nsencrypt.so
-%%AOLSERVERBASE%%/lib/libnsencrypt.a
-%%AOLSERVERBASE%%/lib/libnsencrypt.so