aboutsummaryrefslogtreecommitdiff
path: root/security/audit
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2004-11-03 23:51:15 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2004-11-03 23:51:15 +0000
commit451cac29b5579c994b33cc6411570ae8855f0b1e (patch)
tree31d9a7c5c8d265c8fdfe0f5a154ccca2c626e422 /security/audit
parent07dc48f0e31091a7f2cba324d90309ff7c5bfaf9 (diff)
downloadports-451cac29b5579c994b33cc6411570ae8855f0b1e.tar.gz
ports-451cac29b5579c994b33cc6411570ae8855f0b1e.zip
- add patch files and unbreak this port
- utilize PORTDOCS and USE_MYSQL
Notes
Notes: svn path=/head/; revision=120733
Diffstat (limited to 'security/audit')
-rw-r--r--security/audit/Makefile9
-rw-r--r--security/audit/files/patch-src::audit::audit.c10
-rw-r--r--security/audit/files/patch-src::auditd::audconf.c10
-rw-r--r--security/audit/pkg-plist4
4 files changed, 25 insertions, 8 deletions
diff --git a/security/audit/Makefile b/security/audit/Makefile
index 61c51eeda54e..b3a73abc43bb 100644
--- a/security/audit/Makefile
+++ b/security/audit/Makefile
@@ -17,10 +17,11 @@ DISTNAME= ${PORTNAME}-v${PORTVERSION}beta-src
MAINTAINER= ports@FreeBSD.org
COMMENT= Tools for remote and centralized audit data collection
-BROKEN= Broken pkg-plist
+OPTIONS= MYSQL "With MySQL support" off \
+ PGSQL "With PostGreSQL support" off
.if defined(WITH_MYSQL)
-LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
+USE_MYSQL= yes
.endif
.if defined(WITH_PGSQL)
POSTGRESQL_PORT?= databases/postgresql7
@@ -56,7 +57,7 @@ MANCOMPRESSED= yes
MAN1= audit.1
MAN8= auditd.8
-DOCS= COPYING README TODO
+PORTDOCS= COPYING README TODO
FIXPREFIX_CONF= src/include/audconf.h src/auditd/auditd.8
LIBVERSION= 1
@@ -82,7 +83,7 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/auditd.conf ${PREFIX}/etc/auditd.conf.sample
.if !defined(NOPORTDOCS)
${INSTALL} -d -o root -g wheel -m 0755 ${DOCSDIR}
-.for f in ${DOCS}
+.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
.endfor
.endif
diff --git a/security/audit/files/patch-src::audit::audit.c b/security/audit/files/patch-src::audit::audit.c
new file mode 100644
index 000000000000..0bd030d92b75
--- /dev/null
+++ b/security/audit/files/patch-src::audit::audit.c
@@ -0,0 +1,10 @@
+--- src/audit/audit.c.orig Thu Nov 4 07:24:04 2004
++++ src/audit/audit.c Thu Nov 4 07:25:17 2004
+@@ -143,6 +143,7 @@
+ case SIGABRT:
+ fatal(-1, "");
+ default:
++ break;
+ }
+ errno = old_errno;
+ }
diff --git a/security/audit/files/patch-src::auditd::audconf.c b/security/audit/files/patch-src::auditd::audconf.c
new file mode 100644
index 000000000000..150a58c57097
--- /dev/null
+++ b/security/audit/files/patch-src::auditd::audconf.c
@@ -0,0 +1,10 @@
+--- src/auditd/audconf.c.orig Thu Nov 4 07:25:36 2004
++++ src/auditd/audconf.c Thu Nov 4 07:25:45 2004
+@@ -295,6 +295,7 @@
+ strlcpy(options->resmodule, value, sizeof(options->resmodule));
+ return (0);
+ default:
++ break;
+ }
+
+ errno = EINVAL;
diff --git a/security/audit/pkg-plist b/security/audit/pkg-plist
index 12d578fe620b..29c6a08aeb1f 100644
--- a/security/audit/pkg-plist
+++ b/security/audit/pkg-plist
@@ -10,8 +10,4 @@ lib/alat/libauth_raw.so.1
lib/alat/libia_syslog.so.1
lib/alat/libres_local.so.1
sbin/auditd
-%%PORTDOCS%%share/doc/audit/COPYING
-%%PORTDOCS%%share/doc/audit/README
-%%PORTDOCS%%share/doc/audit/TODO
-%%PORTDOCS%%@dirrm share/doc/audit
@unexec rmdir %D/lib/alat 2>/dev/null || true