aboutsummaryrefslogtreecommitdiff
path: root/security/barnyard2/Makefile
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-02-14 23:03:03 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-02-14 23:03:03 +0000
commit4ac0cb79abd0a2e4cde270e7e265f7541d0677e3 (patch)
tree8650db9f135c5073360af6ee9bc3205e8a231f9c /security/barnyard2/Makefile
parent93b14ee241fc949186a52e9b28277ab3c2c04c29 (diff)
downloadports-4ac0cb79abd0a2e4cde270e7e265f7541d0677e3.tar.gz
ports-4ac0cb79abd0a2e4cde270e7e265f7541d0677e3.zip
- update PGSQL option, as only version 9.2 has the correct libraries to build
- rename option MYSQL-SSL -> MYSQL_SSL - fix incorrectly defined option of OPTIONS_DEFAULT within MYSQL_SSL - use ${CP} in favor of cp PR: 176124 Submitted by: maintainer, pauls@utdallas.edu
Notes
Notes: svn path=/head/; revision=312249
Diffstat (limited to 'security/barnyard2/Makefile')
-rw-r--r--security/barnyard2/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/security/barnyard2/Makefile b/security/barnyard2/Makefile
index 484e4292be8d..1887c64dae4c 100644
--- a/security/barnyard2/Makefile
+++ b/security/barnyard2/Makefile
@@ -15,14 +15,14 @@ GH_PROJECT= ${PORTNAME}
GH_TAGNAME= v2-${PORTVERSION}
GH_COMMIT= 4dfdc80
-OPTIONS_DEFINE= 64BIT ARUBA BRO GRE IPV6 MPLS MYSQL MYSQL-SSL ODBC PRELUDE PGSQL
+OPTIONS_DEFINE= 64BIT ARUBA BRO GRE IPV6 MPLS MYSQL MYSQL_SSL ODBC PRELUDE PGSQL
NO_OPTIONS_SORT=yes
64BIT_DESC= Enable 64bit compilation (experimental)
ARUBA_DESC= Enable aruba support
BRO_DESC= Enable bro support (libbroccoli)
GRE_DESC= Enable gre support
-MYSQL-SSL_DESC= Enable mysql ssl support (experimental)
+MYSQL_SSL_DESC= Enable mysql ssl support (experimental)
PRELUDE_DESC= Enable prelude support
.if defined(SLAVE)
@@ -96,8 +96,8 @@ CONFIGURE_ARGS+= --with-mysql \
CONFIGURE_ARGS+= --without-mysql
.endif
-.if ${PORT_OPTIONS:MMYSQL-SSL}
-OPTIONS_DEFAULT+= MYSQL
+.if ${PORT_OPTIONS:MMYSQL_SSL}
+USE_MYSQL= yes
CONFIGURE_ARGS+= --enable-mysql-ssl-support
.else
CONFIGURE_ARGS+= --disable-mysql-ssl-support
@@ -119,6 +119,7 @@ CONFIGURE_ARGS+= --disable-prelude
.if ${PORT_OPTIONS:MPGSQL}
USE_PGSQL= yes
+WANT_PGSQL_VER= 92+
CONFIGURE_ARGS+= --with-postgresql=${LOCALBASE}/bin/pg_config --with-pgsql-includes=${LOCALBASE}/include/postgresql/server
.else
CONFIGURE_ARGS+= --without-postgresql
@@ -136,7 +137,7 @@ post-patch:
${WRKSRC}/etc/barnyard2.conf
post-install:
- @cp ${WRKSRC}/etc/barnyard2.conf ${PREFIX}/etc/barnyard2.conf.sample
+ @${CP} ${WRKSRC}/etc/barnyard2.conf ${PREFIX}/etc/barnyard2.conf.sample
if [ ! -f ${PREFIX}/etc/barnyard2.conf ]; then \
${CP} -p ${PREFIX}/etc/barnyard2.conf.sample ${PREFIX}/etc/barnyard2.conf; \
fi