aboutsummaryrefslogtreecommitdiff
path: root/security/beecrypt/Makefile
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2014-04-27 21:37:13 +0000
committerMikhail Teterin <mi@FreeBSD.org>2014-04-27 21:37:13 +0000
commit29f724f79f540a961ecb9d5c55018bc9e171e648 (patch)
treedd69176d026baa71790f7302772b94482e07d8a5 /security/beecrypt/Makefile
parent9aab20fca04df1be1107bd21be883bf272feb060 (diff)
downloadports-29f724f79f540a961ecb9d5c55018bc9e171e648.tar.gz
ports-29f724f79f540a961ecb9d5c55018bc9e171e648.zip
When -march=FOO happens to be among CFLAGS, unexpected things could
occur (for example, -march=core2 used to break build). Not a FreeBSD problem even -- Linux crowd was bitten by this too (and misdiagnosed it). Our package-building does not include the flag, which is why we haven't seen this before. Attempt to help configure better detect the architecture and CPU-capabilities -- and use assembler-implementations of various routines, where possible. ("make check" is almost 30% faster now) Ensure, SSE2-specific code builds properly with clang as well as gcc. Ensure, the author's "make check" runs as regression-test. Add another patch found on SourceForge. (Attempt to) unbreak on PowerPC -- untested. Bump PORTREVISION. Take maintainership for the time being, to deal with any fallout.
Notes
Notes: svn path=/head/; revision=352464
Diffstat (limited to 'security/beecrypt/Makefile')
-rw-r--r--security/beecrypt/Makefile21
1 files changed, 14 insertions, 7 deletions
diff --git a/security/beecrypt/Makefile b/security/beecrypt/Makefile
index 1ffb40d475b5..948339154d2d 100644
--- a/security/beecrypt/Makefile
+++ b/security/beecrypt/Makefile
@@ -1,12 +1,14 @@
# Created by: Ying-Chieh Liao <ijliao@FreeBSD.org>
# $FreeBSD$
-
PORTNAME= beecrypt
PORTVERSION= 4.2.1
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= SF
+PATCHFILES= mpntrbits.patch
+PATCH_SITES= http://sourceforge.net/p/beecrypt/patches/_discuss/thread/bff89ba1/5387/attachment/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= mi@aldan.algebra.com
COMMENT= BeeCrypt is an open source cryptography library
USE_AUTOTOOLS= libtool
@@ -25,10 +27,15 @@ CONFIGURE_ARGS+= --enable-openmp
CONFIGURE_ARGS+= --disable-openmp
.endif
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "powerpc"
-BROKEN= Does not compile on powerpc
+# Configure tries to guess our CPU-features using Linux-centric logic.
+# Help it here:
+.for o in sse3 sse2 sse mmx
+.if ${MACHINE_CPU:M$o} != ""
+CPPFLAGS+= -DOPTIMIZE_${o:U}
.endif
+.endfor
+
+regression-test test check: build
+ ${MAKE} -C ${WRKSRC} check
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>