aboutsummaryrefslogtreecommitdiff
path: root/security/bro
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2003-10-14 14:50:58 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2003-10-14 14:50:58 +0000
commit7dcf6505129928e12536fefd9ef89670bb7bbaa7 (patch)
tree881f4649867859edb0723519f8714a697bd69f21 /security/bro
parentc79a2978da172e4dce4bb52ad9044a7b2884e837 (diff)
downloadports-7dcf6505129928e12536fefd9ef89670bb7bbaa7.tar.gz
ports-7dcf6505129928e12536fefd9ef89670bb7bbaa7.zip
Update to 0.8, fix RESTRICTED.
Notes
Notes: svn path=/head/; revision=91207
Diffstat (limited to 'security/bro')
-rw-r--r--security/bro/Makefile56
-rw-r--r--security/bro/distinfo2
-rw-r--r--security/bro/files/patch-Makefile.in27
-rw-r--r--security/bro/files/patch-Obj.cc11
-rw-r--r--security/bro/files/patch-libedit::configure19
-rw-r--r--security/bro/files/patch-patricia.c22
-rw-r--r--security/bro/files/patch-patricia.h11
-rw-r--r--security/bro/pkg-plist96
8 files changed, 204 insertions, 40 deletions
diff --git a/security/bro/Makefile b/security/bro/Makefile
index c90fce11a03d..10120d82896b 100644
--- a/security/bro/Makefile
+++ b/security/bro/Makefile
@@ -7,43 +7,51 @@
#
PORTNAME= bro
-PORTVERSION= 0.5a
+PORTVERSION= 0.8
CATEGORIES= security
-#MASTER_SITES= ftp://ee.lbl.gov/
-#see http://www-nrg.ee.lbl.gov/bro-info.html
-DISTNAME= vp-bro-0.5-alpha
+MASTER_SITES= ftp://ftp.ee.lbl.gov/
+DISTNAME= ${PORTNAME}-pub-${PORTVERSION}-current
MAINTAINER= ports@FreeBSD.org
COMMENT= System for detecting Network Intruders in real-time
-RESTRICTED= "Author wishes Alpha releases not to be distrubted."
+WRKSRC= ${WRKDIR}/${PORTNAME}-pub-${PORTVERSION}a37
-.include <bsd.port.pre.mk>
-
-.if !exists(${DISTDIR}/vp-bro-0.5-alpha${EXTRACT_SUFX})
-IGNORE=is still in alpha test. Please contact Vern Paxson <vern@ee.lbl.gov> to obtain the obtain the Bro source. Put it in ${DISTDIR} as ${DISTFILES} and run make again
-.endif
-
-IS_INTERACTIVE= "manual fetch"
-WRKSRC= ${WRKDIR}/bro-pub-0.5a1
-CONFIGURE_ARGS= --libdir=${PREFIX}/share
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
+MAKE_ENV+= CC="${CC}" CFLAGS="${CFLAGS}"
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --libdir=${PREFIX}/share
+USE_BISON= yes
+USE_PERL5= yes
+
+post-extract:
+ @(cd ${WRKSRC} && ${TAR} xfvz libedit.src.tar.gz > /dev/null)
post-patch:
- @${MV} ${WRKSRC}/util.cc ${WRKSRC}/util.cc.in
- @${SED} -e "s|/usr/src/rtsg/bro/policy:/usr/local/lib/bro|${PREFIX}/share/bro|" \
- ${WRKSRC}/util.cc.in >${WRKSRC}/util.cc
+ @${REINPLACE_CMD} -e 's|CFLAGS+=-g -O0||g; \
+ s|CC=gcc||' \
+ ${WRKSRC}/libedit/Makefile.in \
+ ${WRKSRC}/libedit/Makefile
+
+pre-configure:
+ @${ECHO_CMD} "Configure libedit..."
+ @(cd ${WRKSRC}/libedit && ${MAKE_ENV} ./configure)
+
+pre-build:
+ @${ECHO_CMD} "Building libedit..."
+ @(cd ${WRKSRC}/libedit && ${MAKE})
+
pre-install:
- @${MKDIR} ${PREFIX}/share/bro
+ @${MKDIR} ${DATADIR}
post-install:
@${STRIP_CMD} ${PREFIX}/sbin/bro
- @${INSTALL_DATA} ${WRKSRC}/policy/*.* ${PREFIX}/share/bro
+ @${INSTALL_DATA} ${WRKSRC}/policy/*.* ${DATADIR}
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/bro
- ${INSTALL_MAN} ${WRKSRC}/doc/bro-usenix98-revised.ps \
- ${PREFIX}/share/doc/bro
- @${GZIP_CMD} ${PREFIX}/share/doc/bro/bro-usenix98-revised.ps
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/doc/bro-CN99.ps ${DOCSDIR}
+ @${GZIP_CMD} ${DOCSDIR}/bro-CN99.ps
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/bro/distinfo b/security/bro/distinfo
index 920abb5dc368..27b6d27740dd 100644
--- a/security/bro/distinfo
+++ b/security/bro/distinfo
@@ -1 +1 @@
-MD5 (vp-bro-0.5-alpha.tar.gz) = 122eef8bb0a5aba87ac56c1e1d149f97
+MD5 (bro-pub-0.8-current.tar.gz) = abf9ddc6e7086639130f2e792eca4ab3
diff --git a/security/bro/files/patch-Makefile.in b/security/bro/files/patch-Makefile.in
new file mode 100644
index 000000000000..ed829223ea40
--- /dev/null
+++ b/security/bro/files/patch-Makefile.in
@@ -0,0 +1,27 @@
+--- Makefile.in.orig Sun Aug 31 04:39:14 2003
++++ Makefile.in Tue Oct 14 12:08:51 2003
+@@ -52,13 +52,13 @@
+ LIBS = $(LIBEDIT_LIBS) @LIBS@ -lm
+
+ # Purify barfs when c++ is used for $(CPLUS).
+-PURIFY_CPLUS = g++
++PURIFY_CPLUS = @CC@
+ PURE_FLAGS = -chain-length=20
+
+ YACC = @YACC@
+ YFLAGS = -d -t -v
+ LEX = @LEX@
+-INSTALL = @INSTALL@ -d
++INSTALL = @INSTALL_PROGRAM@
+ INSTALL_DATA = @INSTALL_DATA@
+ @SET_MAKE@
+ COMPRESS = @COMPRESS@
+@@ -121,7 +121,7 @@
+
+ all: $(PKG)
+
+-$(PKG): $(LIBEDIT_LIB) $(OBJ)
++$(PKG): $(OBJ)
+ $(CPLUS) -o $(EXEC) $(OBJ) $(LDFLAGS) $(LIBS)
+ opt:
+ @$(MAKE) $(MFLAGS) CCOPT="`echo $(CCOPT) | sed -e 's/-O2//;s/$$/ -O3/'`"
diff --git a/security/bro/files/patch-Obj.cc b/security/bro/files/patch-Obj.cc
new file mode 100644
index 000000000000..295affb0d446
--- /dev/null
+++ b/security/bro/files/patch-Obj.cc
@@ -0,0 +1,11 @@
+--- Obj.cc.orig Sun Oct 5 18:27:31 2003
++++ Obj.cc Sun Oct 5 18:27:44 2003
+@@ -47,7 +47,7 @@
+ delete_data = true;
+
+ int tmp;
+- return s->Read(&(char*) filename, &tmp) &&
++ return s->Read((char**) &filename, &tmp) &&
+ s->Read(&first_line) && s->Read(&last_line) &&
+ s->Read(&first_column) && s->Read(&last_column);
+ }
diff --git a/security/bro/files/patch-libedit::configure b/security/bro/files/patch-libedit::configure
new file mode 100644
index 000000000000..fe37b4aeec1c
--- /dev/null
+++ b/security/bro/files/patch-libedit::configure
@@ -0,0 +1,19 @@
+--- libedit/configure.orig Tue Oct 14 12:30:58 2003
++++ libedit/configure Tue Oct 14 12:31:54 2003
+@@ -733,13 +733,13 @@
+ CFLAGS="$ac_save_CFLAGS"
+ elif test $ac_cv_prog_cc_g = yes; then
+ if test "$GCC" = yes; then
+- CFLAGS="-g -O2"
++ CFLAGS=""
+ else
+- CFLAGS="-g"
++ CFLAGS=""
+ fi
+ else
+ if test "$GCC" = yes; then
+- CFLAGS="-O2"
++ CFLAGS=""
+ else
+ CFLAGS=
+ fi
diff --git a/security/bro/files/patch-patricia.c b/security/bro/files/patch-patricia.c
new file mode 100644
index 000000000000..b3db5ede01f0
--- /dev/null
+++ b/security/bro/files/patch-patricia.c
@@ -0,0 +1,22 @@
+--- patricia.c.orig Tue Oct 7 15:06:56 2003
++++ patricia.c Tue Oct 7 15:07:19 2003
+@@ -52,6 +52,11 @@
+ "This product includes software developed by the University of Michigan, Merit"
+ "Network, Inc., and their contributors.";
+
++#include <sys/types.h>
++#include <sys/socket.h>
++#include <netinet/in.h>
++#include <arpa/inet.h>
++
+ #include <assert.h> /* assert */
+ #include <ctype.h> /* isdigit */
+ #include <errno.h> /* errno */
+@@ -60,7 +65,6 @@
+ #include <stdio.h> /* sprintf, fprintf, stderr */
+ #include <stdlib.h> /* free, atol, calloc */
+ #include <string.h> /* memcpy, strchr, strlen */
+-#include <arpa/inet.h> /* for inet_addr */
+
+ #include "patricia.h"
+
diff --git a/security/bro/files/patch-patricia.h b/security/bro/files/patch-patricia.h
new file mode 100644
index 000000000000..10979f72537e
--- /dev/null
+++ b/security/bro/files/patch-patricia.h
@@ -0,0 +1,11 @@
+--- patricia.h.orig Sun Oct 5 18:29:52 2003
++++ patricia.h Sun Oct 5 18:30:05 2003
+@@ -51,6 +51,8 @@
+ #ifndef _PATRICIA_H
+ #define _PATRICIA_H
+
++#include <sys/types.h>
++
+ /* typedef unsigned int u_int; */
+ typedef void (*void_fn_t)();
+ /* { from defs.h */
diff --git a/security/bro/pkg-plist b/security/bro/pkg-plist
index 26da5c514c38..bf7fc1c0c929 100644
--- a/security/bro/pkg-plist
+++ b/security/bro/pkg-plist
@@ -1,17 +1,83 @@
@comment $FreeBSD$
sbin/bro
-share/bro/bro.init
-share/bro/analy.bro
-share/bro/dns.bro
-share/bro/finger.bro
-share/bro/ftp.bro
-share/bro/hot.bro
-share/bro/http.bro
-share/bro/mt.bro
-share/bro/port-name.bro
-share/bro/portmapper.bro
-share/bro/scan.bro
-share/bro/tcp.bro
-share/bro/telnet.bro
-share/bro/udp.bro
-share/doc/bro/bro-usenix98-revised.ps.gz
+%%DATADIR%%/active.bro
+%%DATADIR%%/alert.bro
+%%DATADIR%%/analy.bro
+%%DATADIR%%/anon.bro
+%%DATADIR%%/backdoor.bro
+%%DATADIR%%/bro.bif.bro
+%%DATADIR%%/bro.init
+%%DATADIR%%/capture-events.bro
+%%DATADIR%%/checkpoint.bro
+%%DATADIR%%/common-rw.bif.bro
+%%DATADIR%%/conn.bro
+%%DATADIR%%/const.bif.bro
+%%DATADIR%%/contents.bro
+%%DATADIR%%/demux.bro
+%%DATADIR%%/dns.bro
+%%DATADIR%%/dns-lookup.bro
+%%DATADIR%%/drop-adapt.bro
+%%DATADIR%%/event.bif.bro
+%%DATADIR%%/finger.bro
+%%DATADIR%%/finger-rw.bif.bro
+%%DATADIR%%/flag-irc.bro
+%%DATADIR%%/flag-warez.bro
+%%DATADIR%%/frag.bro
+%%DATADIR%%/ftp.bro
+%%DATADIR%%/ftp-anonymizer.bro
+%%DATADIR%%/ftp-cmd-arg.bro
+%%DATADIR%%/ftp-rw.bif.bro
+%%DATADIR%%/ftp-safe-words.bro
+%%DATADIR%%/hot.bro
+%%DATADIR%%/hot-ids.bro
+%%DATADIR%%/http.bro
+%%DATADIR%%/http-abstract.bro
+%%DATADIR%%/http-body.bro
+%%DATADIR%%/http-entity.bro
+%%DATADIR%%/http-event.bro
+%%DATADIR%%/http-header.bro
+%%DATADIR%%/http-reply.bro
+%%DATADIR%%/http-request.bro
+%%DATADIR%%/http-rewriter.bro
+%%DATADIR%%/http-rw.bif.bro
+%%DATADIR%%/icmp.bro
+%%DATADIR%%/ident-rewriter.bro
+%%DATADIR%%/ident.bro
+%%DATADIR%%/ident-rw.bif.bro
+%%DATADIR%%/inactivity.bro
+%%DATADIR%%/interconn.bro
+%%DATADIR%%/load-level.bro
+%%DATADIR%%/log.bro
+%%DATADIR%%/login.bro
+%%DATADIR%%/mime.bro
+%%DATADIR%%/mt.bro
+%%DATADIR%%/netstats.bro
+%%DATADIR%%/ntp.bro
+%%DATADIR%%/pcap.bro
+%%DATADIR%%/port-name.bro
+%%DATADIR%%/portmapper.bro
+%%DATADIR%%/print-filter.bro
+%%DATADIR%%/print-globals.bro
+%%DATADIR%%/print-resources.bro
+%%DATADIR%%/reduce-memory.bro
+%%DATADIR%%/scan.bro
+%%DATADIR%%/signatures.bro
+%%DATADIR%%/site.bro
+%%DATADIR%%/smtp-relay.bro
+%%DATADIR%%/smtp-rewriter.bro
+%%DATADIR%%/smtp.bro
+%%DATADIR%%/smtp-rw.bif.bro
+%%DATADIR%%/software.bro
+%%DATADIR%%/ssh-stepping.bro
+%%DATADIR%%/ssh.bro
+%%DATADIR%%/ssl-worm.bro
+%%DATADIR%%/stepping.bro
+%%DATADIR%%/synflood.bro
+%%DATADIR%%/tcp.bro
+%%DATADIR%%/tftp.bro
+%%DATADIR%%/udp.bro
+%%DATADIR%%/weird.bro
+%%DATADIR%%/worm.bro
+%%PORTDOCS%%%%DOCSDIR%%/bro-CN99.ps.gz
+%%PORTDOCS%%@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%