aboutsummaryrefslogtreecommitdiff
path: root/security/bruteforceblocker
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2019-02-12 04:24:46 +0000
committerKurt Jaeger <pi@FreeBSD.org>2019-02-12 04:24:46 +0000
commit1f10ca44d7553dc1aeacd121885dc84f695327c0 (patch)
treeb43f08543be2d18e7b1bd1c4152f2334760dd243 /security/bruteforceblocker
parentf1054be94850da81e8d3180248fe06742ce5c6d0 (diff)
downloadports-1f10ca44d7553dc1aeacd121885dc84f695327c0.tar.gz
ports-1f10ca44d7553dc1aeacd121885dc84f695327c0.zip
security/bruteforceblocker: update patterns
- Update patterns to make them match with log messages from recent version of OpenSSH - Remove LICENSE=NONE PR: 234137 Submitted by: Yasuhiro KIMURA <yasu@utahime.org> Approved by: danger (maintainer timeout)
Notes
Notes: svn path=/head/; revision=492748
Diffstat (limited to 'security/bruteforceblocker')
-rw-r--r--security/bruteforceblocker/Makefile8
-rw-r--r--security/bruteforceblocker/files/patch-bruteforceblocker.pl22
2 files changed, 26 insertions, 4 deletions
diff --git a/security/bruteforceblocker/Makefile b/security/bruteforceblocker/Makefile
index edd261d35574..b6351af998ff 100644
--- a/security/bruteforceblocker/Makefile
+++ b/security/bruteforceblocker/Makefile
@@ -3,24 +3,24 @@
PORTNAME= bruteforceblocker
PORTVERSION= 1.2.6
+PORTREVISION= 1
CATEGORIES= security
MAINTAINER= danger@FreeBSD.org
COMMENT= Checks for SSH bruteforce and blocks given IPs
-LICENSE= NONE
-
RUN_DEPENDS= p5-Unix-Syslog>=0:sysutils/p5-Unix-Syslog \
p5-Sys-Hostname-Long>=0:sysutils/p5-Sys-Hostname-Long \
p5-libwww>=0:www/p5-libwww \
p5-Net-DNS>=0:dns/p5-Net-DNS
+USES= perl5 shebangfix
USE_GITHUB= yes
GH_ACCOUNT= dgerzo
-NO_BUILD= yes
-USES= perl5 shebangfix
USE_PERL5= run
+NO_BUILD= yes
+
OPTIONS_DEFINE= DOCS
SUB_FILES= pkg-message
diff --git a/security/bruteforceblocker/files/patch-bruteforceblocker.pl b/security/bruteforceblocker/files/patch-bruteforceblocker.pl
new file mode 100644
index 000000000000..556070e4a5bb
--- /dev/null
+++ b/security/bruteforceblocker/files/patch-bruteforceblocker.pl
@@ -0,0 +1,22 @@
+--- bruteforceblocker.pl.orig 2018-12-18 11:17:19 UTC
++++ bruteforceblocker.pl
+@@ -79,13 +79,13 @@ my $res = Net::DNS::Resolver->new;
+ while (<>) {
+ if (/.*Failed password.*from ($work->{ipv4}|$work->{ipv6}|$work->{fqdn}) port.*/i ||
+ /.*Failed keyboard.*from ($work->{ipv4}|$work->{ipv6}|$work->{fqdn}) port.*/i ||
+- /.*Invalid user.*from ($work->{ipv4}|$work->{ipv6}|$work->{fqdn})$/i ||
+- /.*Did not receive identification string from ($work->{ipv4}|$work->{ipv6}|$work->{fqdn})$/i ||
+- /.*Bad protocol version identification .* from ($work->{ipv4}|$work->{ipv6}|$work->{fqdn})$/i ||
++ /.*Invalid user.*from ($work->{ipv4}|$work->{ipv6}|$work->{fqdn}) port.*/i ||
++ /.*Did not receive identification string from ($work->{ipv4}|$work->{ipv6}|$work->{fqdn}) port.*/i ||
++ /.*Bad protocol version identification .* from ($work->{ipv4}|$work->{ipv6}|$work->{fqdn}) port.*/i ||
+ /.*User.*from ($work->{ipv4}|$work->{ipv6}|$work->{fqdn}) not allowed because.*/i ||
+- /.*error: maximum authentication attempts exceeded for.*from ($work->{ipv4}|$work->{ipv6}|$work->{fqdn}).*/i ||
+- /.*error: PAM: authentication error for.*from ($work->{ipv4}|$work->{ipv6}|$work->{fqdn}).*/i ||
+- /.*fatal: Unable to negotiate with ($work->{ipv4}|$work->{ipv6}|$work->{fqdn}).*/i) {
++ /.*error: maximum authentication attempts exceeded for.*from ($work->{ipv4}|$work->{ipv6}|$work->{fqdn}) port.*/i ||
++ /.*error: PAM: authentication error for.*from ($work->{ipv4}|$work->{ipv6}|$work->{fqdn}) port.*/i ||
++ /.*Unable to negotiate with ($work->{ipv4}|$work->{ipv6}|$work->{fqdn}) port.*/i) {
+
+ my $IP = $1;
+ if ($IP =~ /$work->{fqdn}/i) {